Page 1 of 1

Opening an image from the browser always opens as maximized

Posted: Fri May 13, 2011 6:02 pm
by therorschach
I noticed that when you are in MDI mode (i.e. windows are no maximized) and you open an image from the browser, the image window will always open as maximized. I usually like to view multiple images at once, not maximized, so every time I open new images I have to un-maximize them despite being in MDI mode. I remember there was an option in earlier versions (I think around 1.7.* ish) to enable/disable images opening in maximized mode. I'm not sure why it was removed as it appears users have no choice but to open all images in maximized mode.

Re: Opening an image from the browser always opens as maximi

Posted: Fri May 13, 2011 6:13 pm
by ckv
You can disable this behavior by manually adding MaximizeViewWhenOpen=0 in View section to your xnview.ini or registry.

See this topic for more info.

Re: Opening an image from the browser always opens as maximi

Posted: Fri May 13, 2011 6:38 pm
by therorschach
I set this in my registry, but windows still always open maximized. When should registry changes take effect?

Image

Re: Opening an image from the browser always opens as maximi

Posted: Fri May 13, 2011 7:52 pm
by ckv
therorschach wrote:I set this in my registry, but windows still always open maximized. When should registry changes take effect?
In your screenshot you have MaximizeViewWhenOpen in 'browser' subkey, you should add MaximizeViewWhenOpen in 'View' subkey instead.

Re: Opening an image from the browser always opens as maximi

Posted: Fri May 13, 2011 7:54 pm
by therorschach
Ah, ok. That fixed it. Thanks!!