REQ: Don't use first frame for thumbnails

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Post by Olivier_G » Tue Jun 14, 2005 11:38 am

I support the percentage method (I suggested 50%, but 10% is better...), and the use of a 'keyframe' to speed up the Thumbnails creation.

Olivier

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jun 14, 2005 1:47 pm

Olivier_G wrote:I support the percentage method (I suggested 50%, but 10% is better...), and the use of a 'keyframe' to speed up the Thumbnails creation.
I can't add option in this version, but i can use a % to create thumbnail. So 10%??
Pierre.

ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit » Tue Jun 14, 2005 1:49 pm

I agree with 10%

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Tue Jun 14, 2005 3:03 pm

Me too.

Since we can use %, I think option for this is not needed at all.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Tue Jun 14, 2005 3:07 pm

Olivier_G wrote:I support the percentage method (I suggested 50%, but 10% is better...), and the use of a 'keyframe' to speed up the Thumbnails creation.

Olivier
What about this? I think this may be a reason for slow WMV th. creation.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

INI entry ?

Post by Clo » Tue Jun 14, 2005 3:28 pm

:arrow: Pierre

:) Hello Pierre!
I can't add option in this version, but i can use a % to create thumbnail. So 10%??
- I guess that this percent-value could be stated as an INI variable entry, so advanced users could adjust it “by hand” following their own needs…

:?: What do you think ?

:mrgreen: K R
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

Guest

Post by Guest » Tue Jun 14, 2005 10:15 pm

Another app gives you the option to skip over the initial black frames and also allows you to set the black threshold percentage (in case it's not completely black black).

This is generally quite succesful, apart from when there is some writing on these black frames. It also allows you to limit the maximum time spent on each thumbnail before no thumbnail will be created, in case a lot of the initial part of the movie is black.

I think this feature, along with the ability to specify either a percentage, or an absolute time from where the thumbnail should be created gives the maximum amount of flexibility.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Fri Jun 17, 2005 3:57 pm

I still have 1st black frame for some videos - 3 mov and 1 avi indeo video 5.
Dreamer

ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit » Fri Jun 17, 2005 4:05 pm

That black frame might also be a gap between two other frames which would be unavoidable.
XnViewMP 64bits and Windows 10 Pro x64 2004
PhotoFiltre Studio X

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Fri Jun 17, 2005 6:06 pm

Dreamer wrote:I still have 1st black frame for some videos - 3 mov and 1 avi indeo video 5.
I have 1st black frame also for some mpg, xvid and DivX 3, 4, 5 files.

I'm sure the first frame is used for those files, since I have tested files with non black 1st frame in VirtualDub and that frame is used as thumbnail in xnview.

For some DivX 5 files, correct frame (10%) is used as thumbnail (probably other 5.x version).
Dreamer

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sat Jun 18, 2005 6:48 am

Dreamer wrote:
Dreamer wrote:I still have 1st black frame for some videos - 3 mov and 1 avi indeo video 5.
I have 1st black frame also for some mpg, xvid and DivX 3, 4, 5 files.

I'm sure the first frame is used for those files, since I have tested files with non black 1st frame in VirtualDub and that frame is used as thumbnail in xnview.

For some DivX 5 files, correct frame (10%) is used as thumbnail (probably other 5.x version).
For all AVI file i use the frame at 10%
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sat Jun 18, 2005 11:05 am

xnview wrote:For all AVI file i use the frame at 10%
I believe in you, but several avi (divX) files ignore this setting - I'm 100% sure about it - 1st frame is used for those files.

I think some other files (mov, mpg) also ignore that setting.
Dreamer

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sat Jun 18, 2005 11:25 am

Dreamer wrote:
xnview wrote:For all AVI file i use the frame at 10%
I believe in you, but several avi (divX) files ignore this setting - I'm 100% sure about it - 1st frame is used for those files.

I think some other files (mov, mpg) also ignore that setting.
Is it possible to send me some samples?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sat Jun 18, 2005 11:50 am

xnview wrote:
Dreamer wrote:
xnview wrote:For all AVI file i use the frame at 10%
I believe in you, but several avi (divX) files ignore this setting - I'm 100% sure about it - 1st frame is used for those files.

I think some other files (mov, mpg) also ignore that setting.
Is it possible to send me some samples?
I'll try to upload some (divX) files to http://rapidshare.de/ . I'll let you know per PM.

I think all mov files ignore that setting, please check it out.
Dreamer

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sun Jun 26, 2005 11:28 am

Fixed - except MOV files.

Post Reply