RC6: Browser > Viewer > Fullscreen problem

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: helmut, XnTriq, xnview

User avatar
deus-ex
Posts: 171
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

RC6: Browser > Viewer > Fullscreen problem

Post by deus-ex »

RC6: L.M.B. switch mode set to 'Browser > Viewer > Fullscreen'
  • Open an image from browser with L.M.B., cycle through the modes with L.M.B. until you return to the Browser. Now hit ENTER-key on same image (ENTER switch mode set to 'Browse <> Fullscreen | Viewer <> Fullscreen') the image is loaded but resized to its image dimension regardless off the setting 'Fit image to window, all'.
Regards,
deus-ex

XnView 1.80 <x>
User avatar
xnview
Author of XnView
Posts: 37753
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: RC6: Browser > Viewer > Fullscreen problem

Post by xnview »

deus-ex wrote:RC6: L.M.B. switch mode set to 'Browser > Viewer > Fullscreen'
  • Open an image from browser with L.M.B., cycle through the modes with L.M.B. until you return to the Browser. Now hit ENTER-key on same image (ENTER switch mode set to 'Browse <> Fullscreen | Viewer <> Fullscreen') the image is loaded but resized to its image dimension regardless off the setting 'Fit image to window, all'.
Can't reproduce it...
Pierre.
User avatar
deus-ex
Posts: 171
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Post by deus-ex »

Hmm, this is puzzeling. Retested it and was only able to reproduce it one more time. For the other tries the ENTER-key refuses to open any image from the browser.

The new switch mode settings are becoming a disturbance to my good experiences with Xnview. Currently i'm not able to switch between browser and fullscreen back and forth with the ENTER-key as i used to do regardless of the settings i tried (same for starting Xnview with an image from commandline).
No offense, hopefully this can be fixed. Maybe these new settings can be made optional so that the previous behaviour (v1.74) which used to work for me (and others?) can be retained.


Regards,
deus-ex
User avatar
xnview
Author of XnView
Posts: 37753
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

deus-ex wrote:Hmm, this is puzzeling. Retested it and was only able to reproduce it one more time. For the other tries the ENTER-key refuses to open any image from the browser.

The new switch mode settings are becoming a disturbance to my good experiences with Xnview. Currently i'm not able to switch between browser and fullscreen back and forth with the ENTER-key as i used to do regardless of the settings i tried (same for starting Xnview with an image from commandline).
No offense, hopefully this can be fixed. Maybe these new settings can be made optional so that the previous behaviour (v1.74) which used to work for me (and others?) can be retained.
Sorry now i can't, all is changed.
Perhaps you could send me your .ini file?
Pierre.