JBIG2DEC Error when opening images

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: helmut, XnTriq, xnview

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

With your HTML…

Post by Clo »

:arrow: dawog

:D What a saga !

- I saved the page « Dawog's Home Page.htm » from your site in a temp dir. I added some "squatters" as PNG, GIF, JPG, BMP pics in that dir. (the root of the dir., where the HTML file is).
• Clicking from Total Commander in the list or from the XnView-Browser like formerly, nothing abnormal happens…

- If I got you alright, your two machines P4 are exactly mirrors one another about the main HDs contents, and both have the problem… So, there is a common “guilty” item / program there.
Do you think it's worth uninstalling Mozilla & seeing if that has an effect?
- I would answer rather «Yes», since your P2 with another Web browser behaves correctly.
- Here, I use IE6 through the Maxthon interface (or else, it's too poor and ugly), and HTM / HTML files are associated with another small interface using the IE6 engine -to get a quick view- 'cause that interface is very "light".
- The P4 has an Intel™ MB, with a built-in graphic-card.

• Finally, just "in the case", I would ckeck for viruses with a DOS AV scanner like the old good free F-Prot. It has solved already some odd issues in the same painting ;)
¤ To be continued…

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow

Re: RE: JBIG2DEC Error when opening images

Post by ckv »

dawog wrote:Do you think it's worth uninstalling Mozilla & seeing if that has an effect?
NO! Deleting the file-association should be enough, but I doubt it makes any difference.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.
User avatar
dawog
Posts: 11
Joined: Sat Jul 30, 2005 12:03 am
Location: Colorado Springs, CO

RE: JBIG2DEC Error when opening images

Post by dawog »

Claude...

I'm 100% certain that my system is virus/spyware free.

Even tho' I didn't think it would effect anything, I went ahead & uninstalled Mozilla (since I need to upgrade it to the latest version anyway). Uninstalling Mozilla had no effect on XnView's behavior on my 2.8 GHz P4 (no surprise).

Just out of curiousity, I thought I'd try to create some JBIG images (via conversion) to see if their presence in a folder would have any effect on XnView's behavior. With the JBIG2DEC plug-in restored, I tried saving several jpeg & tiff images to JBG format - all failed. After clicking on "Save," a small "Warning" window pops up that states: "Contact Your Dealer."

Since this problem is limited to my P4 systems only, I'll quit posting. Thanks again for all those who provided additional testing & suggestions.
User avatar
hawkse
Posts: 7
Joined: Sat Oct 01, 2005 9:04 pm

RE: JBIG2DEC Error when opening images

Post by hawkse »

Hi!

I just found this thread after a Google search and can add that I too have this problem. Using XNView 1.80.2 on Windows 2000 Professional with all available patches.

I usually experience this problem when browsing a folder, then opening a photo and then continue browsing using the "next" button.

My photo folders are comletely free of html files. There are only jpg & mov files in there.

Did anyone find a solution/cause to this problem?
User avatar
dawog
Posts: 11
Joined: Sat Jul 30, 2005 12:03 am
Location: Colorado Springs, CO

RE: JBIG2DEC Error when opening images

Post by dawog »

Hi Hawkse...

As far as I know, no solution was found except to rename or delete the JBIG2DEC plug-in. Since I don't have any JBIG images, I just renamed the plug-in "jbig2dec.exe" to "_jbig2dec.exe". It's located in the XnView\Plugins directory.
User avatar
hawkse
Posts: 7
Joined: Sat Oct 01, 2005 9:04 pm

RE: JBIG2DEC Error when opening images

Post by hawkse »

Thanks for the info.

That's what I thought after reading the thread. I'll just disable the plugin as well then.

Since I'm not even familiar with JBig2 it won't matter much to me.
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: RE: JBIG2DEC Error when opening images

Post by xnview »

dawog wrote:Hi Hawkse...

As far as I know, no solution was found except to rename or delete the JBIG2DEC plug-in. Since I don't have any JBIG images, I just renamed the plug-in "jbig2dec.exe" to "_jbig2dec.exe". It's located in the XnView\Plugins directory.
Very strange because i can't reproduce the problem...
Pierre.
User avatar
hawkse
Posts: 7
Joined: Sat Oct 01, 2005 9:04 pm

Re: JBIG2DEC Error when opening images

Post by hawkse »

xnview wrote: Very strange because i can't reproduce the problem...
Well, I'll hold off disabling the plugin and will try to figure out a way to reproduce it. Nothing strange going on here systemwise. 100% spyware & virus free. No weird software running in the background scanning things or the like.

The problem is very occasional. Sometimes I just see a command window flashing by before disappearing and that's it. Actually, yesterday was the first time I couldn't get out of the loop and had to kill XNView. Going through the same sequence (same folder, same photo) did not trigger the error again. I guess this'll be a difficult one to track down!

Any ideas on how I could go about isolating the source of this? (Like, when is Jbig2dec supposed to be used).
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: JBIG2DEC Error when opening images

Post by xnview »

hawkse wrote:Any ideas on how I could go about isolating the source of this? (Like, when is Jbig2dec supposed to be used).
The problem is that jbig2dec is supposed to be used ONLY when you have a .jb2 extension...
Pierre.
User avatar
hawkse
Posts: 7
Joined: Sat Oct 01, 2005 9:04 pm

Re: JBIG2DEC Error when opening images

Post by hawkse »

xnview wrote:The problem is that jbig2dec is supposed to be used ONLY when you have a .jb2 extension...
Yes, I figured that. What's the mechanism for recognizing a jb2 file? Just the file extension? Mime type? Any magick at all that could trigger a false "recognition"? Guess it would happen a lot more predictably then.

One thing I've noticed is that it does not happen for folders containing only tif files.
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: JBIG2DEC Error when opening images

Post by xnview »

hawkse wrote:
xnview wrote:The problem is that jbig2dec is supposed to be used ONLY when you have a .jb2 extension...
Yes, I figured that. What's the mechanism for recognizing a jb2 file? Just the file extension? Mime type? Any magick at all that could trigger a false "recognition"? Guess it would happen a lot more predictably then.

One thing I've noticed is that it does not happen for folders containing only tif files.
Extension and header
Pierre.