Edit > Set Selection size > Custom size... bug?

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
cday
XnThusiast
Posts: 2157
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Edit > Set Selection size > Custom size... bug?

Post by cday » Wed Mar 11, 2015 10:34 am

A custom selection size, although stored correctly in the ini file, is displayed with height and width transposed when the keyboard shortcut 'C' is used, and similarly shown incorrectly when the selection window is reopened.

Open an image, then...

Edit > Set Selection size > Custom selection...

Enter Width = 100 , Height = 120 [Tall rather than wide...]
Image_1.png
Image_1.png (5.69 KiB) Viewed 692 times
Edit > Set Selection size > Save selection as custom
Image_2.png
XnView screen
Image_2.png (618 Bytes) Viewed 692 times
Edit > Set Selection size > Saved selection (Keyboard shortcut 'C')
Image_3.png
XnView screen
Image_3.png (617 Bytes) Viewed 692 times
The selection is wide rather than tall... :(

Edit > Set Selection size > Custom size... (again)
Image_4.png
Image_4.png (5.86 KiB) Viewed 692 times
The width and height values are transposed... [Wide rather than tall]

Then close XnView and inspect the ini:

Code: Select all

UserSelHeight=120
UserSelRatioX=0
UserSelRatioY=0
UserSelWidth=100
The values in the ini are as they were entered: [Tall rather than wide...]

It looks as if the values stored in the ini are transposed when read to insert a custom selection and to repopulate the Set Selection size > Custom size... window... :?:

User avatar
XnTriq
Moderator & Librarian
Posts: 5447
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Edit > Set Selection size > Custom size... bug?

Post by XnTriq » Thu Mar 12, 2015 5:30 pm

Confirmed :bugconfirmed:

I wonder if this is related to another bug reported recently: Invalid jpg crop (when displayed image is exif-rotated)

Post Reply