XnView can't open created folder after Batch Processing

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
Mixer
Posts: 166
Joined: Fri Aug 28, 2015 6:24 am

XnView can't open created folder after Batch Processing

Post by Mixer » Wed Jun 29, 2016 5:53 pm

I needed to resize lots of pictures from Z:\Path\To\My\Images\original with Xnview 2.36.
I have selected them all in Browser, Tools->Batch Processing...
Set format to JPG, set Transformations to Resize, set "Close dialog after conversion" and "Open output folder in XnView".
Clicked directory picker button labeled "..." next to name input field for output directory, navigated to Z:\Path\To\My\Images and clicked button "Make new folder", then renamed new folder to "resized", selected it and pressed OK, so that new images were placed in Z:\Path\To\My\Images\resized.
Started batch processing by pressing Go.
And what do I see after conversion is complete?
Browser list (which is set to View as Details) contains lonely item named "resized" which lacks icon (or in case of win 10 x64 has wrong icon), although its type is defined as Directory.
This directory can not be opened with doubleclick or Enter and tooltip for this list item has its name doubled, calling this folder "resizedresized".
Window title bar and Browser's address bar where current directory is displayed both state that I'm already inside this directory (they both show address Z:\Path\To\My\Images\resized).
Good thing is that directory and converted files are created successfully and might be accessed after Tree pane folder view is refreshed. Maybe XnView really depends on visibility of new folder in Tree pane, because if directory pre-exists and is visible in tree, then XnView opens it after Batch Processing normally.

Post Reply