Page 1 of 1

Transparent pixels dont get filtered correctly

Posted: Sat Jul 09, 2016 7:58 am
by 3murmeln
Transparent pixels dont get filtered correctly if adjanced to none transparent pixels.

Attached I have a picture of a white circle with red background (background 100% transparent).
If you view this at 100% you correctly get a white circle.
If you view it scaled to less than 100% the circle edges start bleeding red, which is wrong.

This is because the filter doesnt weigh pixels by their transparency-value, so a red pixel with 100% transparency and a white pixel with no transparency become a light red pixel with 50% transparency instead of a white pixel with 50% transparency.

ADDENDUM:
- for viewing pictures the bug only happens with high quality zoom enabled
- for resizing an image the bug always happens (not with nearest pixel mode)

Re: Transparent pixels dont get filtered correctly

Posted: Sat Jul 09, 2016 8:15 am
by XnTriq
Confirmed for activated High quality zoom (Tools » Options... » View » View).

Re: Transparent pixels dont get filtered correctly

Posted: Sat Jul 09, 2016 9:56 am
by 3murmeln
It seems the bug even happens when you resize the image via resize-function, no matter which filter.
And here even disabling high quality zoom doesnt help.

Added it to the main-post.

Re: Transparent pixels dont get filtered correctly

Posted: Sat Jul 09, 2016 10:30 am
by XnTriq
3murmeln wrote:It seems the bug even happens when you resize the image via resize-function, no matter which filter.
See also: Reducing Halo Effect in Rescaled/Resized Images

Re: Transparent pixels dont get filtered correctly

Posted: Sun Apr 23, 2017 2:30 am
by XnTriq
XnView v2.40 (top) vs. v2.39 (bottom):
browser_lq_050.png
Thumbnails & preview @ 50% low-quality zoom
browser_hq_050.png
Thumbnails & preview @ 50% high-quality zoom
browser_lq_300.png
Thumbnails & preview @ 300% low-quality zoom
browser_hq_300.png
Thumbnails & preview @ 300% high-quality zoom
viewer_lq_050.png
Viewer/editor @ 50% low-quality zoom
viewer_hq_050.png
Viewer/editor @ 50% high-quality zoom
viewer_lq_150.png
Viewer/editor @ 150% low-quality zoom
viewer_hq_150.png
Viewer/editor @ 150% high-quality zoom
Remaining issues:
  1. In view mode, zooming in still produces a “halo” if ToolsOptions...ViewViewHigh quality zoomEnlarge is activated.
  2. High-quality zoom doesn't work in the preview pane.
PS: I haven't done any tests for fullscreen and fullscreen lite yet.