Windows 3.1x support !?

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

vanden
Posts: 5
Joined: Sun Dec 10, 2017 11:56 am

Windows 3.1x support !?

Post by vanden »

Hello,

In the "ReadMe.txt" file of XnView v2.43 it is written:
Platforms
=========
PC x86 Windows 3.1x, 95, 98, NT, Me, 2000, XP, Vista, 7, 8.1, 10

But in reality the latest version I found that works with Win3.11 is the 1.15
Old versions found here: https://download.xnview.com/old_versions/

All later versions do not work: the version with install make a Win32s error when launching the installer, the zip version also make a Win32s error when launching ...

So what is the latest Win3.1x compatible version?
Should not it remove the Win3.1x compatibility of the "ReadMe.txt" file?
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Windows 3.1x support !?

Post by xnview »

yes, 1.15 was the lastest i think. It's only the list of platforms that was/are used
Pierre.
vanden
Posts: 5
Joined: Sun Dec 10, 2017 11:56 am

Re: Windows 3.1x support !?

Post by vanden »

Finally I found a version 1.50 for Win3.11 (on the page download.xnview.com named Xnview-wfw.zip)

By cons I can not change the language on version 1.15 (in Option/Language only English appears), on Win10 it works.

And on version 1.50 I have an error every time I go in option :
Image
Then XnView quits and then I restart it Win3.11 crash.

By cons we can adjust the options through the file XNVIEW.INI (including switch to French for version 1.50)
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Windows 3.1x support !?

Post by xnview »

sorry but i can't help, i have no more a Windows 3.1
Pierre.
vanden
Posts: 5
Joined: Sun Dec 10, 2017 11:56 am

Re: Windows 3.1x support !?

Post by vanden »

Hello,

I have another problem, AVAST and AVG find a virus in xnviewde.dll and xnviewfr.dll files (Xnview 1.50) :
https://www.virustotal.com/fr/file/ea6e ... 513350950/
Is it a false positive ?
User avatar
xnview
Author of XnView
Posts: 36318
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Windows 3.1x support !?

Post by xnview »

vanden wrote: Is it a false positive ?
yes
Pierre.
vanden
Posts: 5
Joined: Sun Dec 10, 2017 11:56 am

Re: Windows 3.1x support !?

Post by vanden »

OK, Thanks

Finally I found the problem.
This is because of DosBox when using a folder to mount the virtual hard disk. Using a disk image and "option" works properly :D
Image