Page 1 of 1

Not more WebP -Support in v. 2.45

Posted: Sat Jun 09, 2018 5:27 pm
by moneywasher
I updated today from 2.44 to the version 2.45 and could not more view my webp images in the directories.
After reinstalling the version 2.44 all works fine again as before !
Is this a bug or there is now a special checkbox to directly activate WebP Support in XnView and I just not saw it ??

Re: Not more WebP -Support in v. 2.45

Posted: Sun Jun 10, 2018 2:44 pm
by xnview
do you have updated the webp plugin (now libwepp.dll)

Re: Not more WebP -Support in v. 2.45

Posted: Mon Jun 11, 2018 8:37 pm
by moneywasher
No, I just have installed since longer time the WebP_CodecSetup.exe from Google, to my Win 7 PC.
How I can update to this libwebp.dll? Coz the only one webp dll I found in the I/O Plugins of XNview's Website, is from 19. 01. 2015 !

I just wonder, that the version 2.44 works fine without any extra installation of webp dll. Both versions, 2.45 and 2.44 was "Standard" versions I've downloaded. Is there not more a webp dll installed in the plugins directory of v. 2.45 after installation??
In the 2.44 plugin directory the webp.dll is available, after installation.

Re: Not more WebP -Support in v. 2.45

Posted: Mon Jun 11, 2018 8:56 pm
by moneywasher
Okay - Now it WORKS for me in v. 2.45.
I just had to rename in the PlugIns directory the webp.dll to libwebp.dll ... and after restart XnView it shows all images perfect again.

Re: Not more WebP -Support in v. 2.45

Posted: Tue Jun 12, 2018 10:28 am
by xnview
the libwebp.dll is in complete setup

Re: Not more WebP -Support in v. 2.45

Posted: Fri Apr 26, 2019 4:55 pm
by Hanswurst
Just had the same issue. I don't remember if I manually downloaded webp plugin, but renaming the file from webp.dll to libwebp.dll worked well in XnView Classic 2.48.

Maybe the linked dll file above should be renamed?

Thank you for the info!

Re: Not more WebP -Support in v. 2.45

Posted: Mon Apr 29, 2019 6:52 am
by xnview
Hanswurst wrote:
Fri Apr 26, 2019 4:55 pm
Just had the same issue. I don't remember if I manually downloaded webp plugin, but renaming the file from webp.dll to libwebp.dll worked well in XnView Classic 2.48.

Maybe the linked dll file above should be renamed?
do you have downloaded the full package?

Re: Not more WebP -Support in v. 2.45

Posted: Mon Apr 29, 2019 12:04 pm
by Hanswurst
The standard version of XnView for Desktop, not the extended version.

Re: Not more WebP -Support in v. 2.45

Posted: Mon Apr 29, 2019 2:11 pm
by xnview
Hanswurst wrote:
Mon Apr 29, 2019 12:04 pm
The standard version of XnView for Desktop, not the extended version.
webp plugin is only in extended package

Re: Not more WebP -Support in v. 2.45

Posted: Mon Apr 29, 2019 2:12 pm
by Hanswurst
This means I manually downloaded it, but couldn't apply it because I didn't know that I have to rename the downloaded file.
Did I miss any instructions?

Re: Not more WebP -Support in v. 2.45

Posted: Wed May 01, 2019 1:44 pm
by xnview
Hanswurst wrote:
Mon Apr 29, 2019 2:12 pm
This means I manually downloaded it, but couldn't apply it because I didn't know that I have to rename the downloaded file.
Did I miss any instructions?
the name has changed some versions ago

Re: Not more WebP -Support in v. 2.45

Posted: Wed May 01, 2019 5:24 pm
by Hanswurst
Yeah so there should be done something about it?!

Current situation is you installed Standard XnView 2.48, want to add webp support. You download the webp.zip and extract it as instructed to the Plugins folder. It doesn't work, because you have to rename the dll.

Three solution suggestions:
- Make XnView recognize webp.dll besides libwebp.dll or (I didn't test other addons) simply all .dll files in the Plugins folder
- Rename the .dll in the zip to the proper name
- Add some instructions