Incompatibility with Ghostscript 9.50 not fixed? [Solved]

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
cday
XnThusiast
Posts: 2433
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Incompatibility with Ghostscript 9.50 not fixed? [Solved]

Post by cday » Wed May 13, 2020 11:10 am

The v2.49.2 changelog indicates that a compatibility problem with Ghostscript 9.50 [due to a change in Ghostscript] has been fixed:

But I am unable to open PDF files with Ghostscript 9.52 x32 installed, but can with Ghostscript 9.27 which predates the change... :(

User avatar
xnview
Author of XnView
Posts: 33337
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Incompatibility with Ghostscript 9.50 not fixed?

Post by xnview » Thu May 14, 2020 8:10 am

no problem with gs 9.52, could you send me the pdf that you try to load?
Pierre.

cday
XnThusiast
Posts: 2433
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Incompatibility with Ghostscript 9.50 not fixed?

Post by cday » Thu May 14, 2020 8:22 am

xnview wrote:
Thu May 14, 2020 8:10 am
no problem with gs 9.52, could you send me the pdf that you try to load?
Yes, unexpected, but I've rechecked and I am using 2.49.2 with only GS gs9.27 x32 installed and the file opens, it wouldn't open with GS gs9.52 x32 installed...

M-PDF.pdf
(22.34 KiB) Downloaded 119 times

User avatar
xnview
Author of XnView
Posts: 33337
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Incompatibility with Ghostscript 9.50 not fixed?

Post by xnview » Thu May 14, 2020 1:36 pm

no problem to load your file with GS 9.52 & 2.49.2, no other GS installed?
Pierre.

cday
XnThusiast
Posts: 2433
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Incompatibility with Ghostscript 9.50 not fixed?

Post by cday » Thu May 14, 2020 2:49 pm

xnview wrote:
Thu May 14, 2020 1:36 pm
no problem to load your file with GS 9.52 & 2.49.2, no other GS installed?
In 'Program Files' GS 9.52 x64 ...

User avatar
xnview
Author of XnView
Posts: 33337
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Incompatibility with Ghostscript 9.50 not fixed?

Post by xnview » Thu May 14, 2020 2:53 pm

cday wrote:
Thu May 14, 2020 2:49 pm
xnview wrote:
Thu May 14, 2020 1:36 pm
no problem to load your file with GS 9.52 & 2.49.2, no other GS installed?
In 'Program Files' GS 9.52 x64 ...
And in registry?
Pierre.

cday
XnThusiast
Posts: 2433
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Incompatibility with Ghostscript 9.50 not fixed? [Solved]

Post by cday » Thu May 14, 2020 3:07 pm

xnview wrote:
Thu May 14, 2020 2:53 pm
cday wrote:
Thu May 14, 2020 2:49 pm
xnview wrote:
Thu May 14, 2020 1:36 pm
no problem to load your file with GS 9.52 & 2.49.2, no other GS installed?
In 'Program Files' GS 9.52 x64 ...
And in registry?
I don't know much about the registry... :wink:

The laptop on which I am testing had a clean Windows 10 install fairly recently, I installed GS 9.52 x64 soon after when I installed XnView MP 0.96, and had hardly been in Windows until yesterday when needed to work with PDFs in XnView Classic, and installed GS 9.52 x32.

Then, as above, I couldn't open PDFs until I uninstalled GS 9.52 x32 and installed GS 9.27 x32 ...

cday
XnThusiast
Posts: 2433
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Incompatibility with Ghostscript 9.50 not fixed? [Solved]

Post by cday » Thu May 14, 2020 4:20 pm

I have now tested on another laptop with XnView Classic 2.49.2 and GS 9.52 x32 installed, and PDFs open normally... :D

Something unexplained on the first laptop, possibly a corrupted download, or a Windows 10 issue??

cday
XnThusiast
Posts: 2433
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Incompatibility with Ghostscript 9.50 not fixed? [Solved]

Post by cday » Tue May 19, 2020 8:53 am

cday wrote:
Thu May 14, 2020 4:20 pm
I have now tested on another laptop with XnView Classic 2.49.2 and GS 9.52 x32 installed, and PDFs open normally... :D

Something unexplained on the first laptop, possibly a corrupted download, or a Windows 10 issue??

I can now report following some further tests that XnView Classic 2.49.2 opens PDF files with either GS 9.52 or an earlier version installed... :D

[GS 9.50 not tested but also presumed to work.]

Post Reply