B2: Crash in Options-Browser-Thumbnails-Cache

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

B2: Crash in Options-Browser-Thumbnails-Cache

Post by GeorgD »

When going to Options-Browser-Thumbnails, everything is fine. Some 0.5seconds after clicking tab "Cache", XnView crashes. Not only for first start, but always. In case the data of the windows error reporting tool helps, I'll send it. /Georg
ckit
XnThusiast
Posts: 2451
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

I cannot reproduce this crash.
XnViewMP running on Windows 10 Pro x64 21H1
PhotoFiltre 11, PowerArchiver Toolkit, ShareX and Vivaldi Browser
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France

Post by Olivier_G »

Couldn't reproduce: no crash here.
Olivier
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: B2: Crash in Options-Browser-Thumbnails-Cache

Post by marsh »

GeorgD wrote:When going to Options-Browser-Thumbnails, everything is fine. Some 0.5seconds after clicking tab "Cache", XnView crashes. Not only for first start, but always. In case the data of the windows error reporting tool helps, I'll send it. /Georg
Try deleting all old "cache.db" files from HD and see if problem remains.
(I believe I saw this crash in B1 also. Maybe it happens when old and new files are mixed?)
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

All is OK

Post by Clo »

:) Hello !

• I can't reproduce the crash here. I started the ß-1 as a separate folder,
and I kept all same items for the ß-2 : INI, cache and so on.

- I made an "Optimize", no problem, it needed no more than 1 second !

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: B2: Crash in Options-Browser-Thumbnails-Cache

Post by GeorgD »

marsh wrote:Try deleting all old "cache.db" files from HD and see if problem remains.
Thanks for the hint :) Did not work directly (no files called "cache.db" on any fixed disk), but indirectly - I found out after some 10mins of fiddling that "XnView.db" in user's dir stored the bad content. This file caused the mentioned problem in 1.9b2 and b1, but worked fine in 1.9a3. A default packaged XnView 1.9b2 worked fine, until the dir was changed to user's dir AND the options were saved AND opened again. Seems like the option dialog made problems, not the use of the db in normal XnView usage... Anyway, bug solved for me :)
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France

Post by Olivier_G »

I wonder how to handle as smoothly as possible the DB update from stable 1.82.4 to stable 1.90: end-users should not experience bugs nor forgotten DB files.
A conversion of already cached Thumbnails in previous versions would be ideal... :?:

=> Moved to Feedback (apply to changes of Options settings too).
Olivier