Item losing the focus still unreadable

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Item losing the focus still unreadable

Post by Clo »

—> Pierre

:) Hello !

• You are still using the wrong colour when a marked item loses the focus :

   Image

- It's unreadable, this applies to all items in the programme.

Like I showed already, in Win Explorer the colour is right and allows the reading :

   Image

• It's really annoying…
• The colour is correct in the 1.8x versions! Same than in Win Explorer, so there is a snag somewhere…

• Win XP-Pro SP1

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
helmut
Posts: 8442
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Item losing the focus still unreadable

Post by helmut »

Clo wrote:...• It's really annoying…
• The colour is correct in the 1.8x versions! Same than in Win Explorer, so there is a snag somewhere…

• Win XP-Pro SP1
Windows uses two different colours for selections:

1. Selection with focus (Windows' default colour is dark blue)
2. Selection without focus (Windows' default colour is gray)

This way you can have multiple lists with selections and still see which selection has the focus. The same "system" is applied for the windows, if you have multiple windows open and look at the various titles, you will see that the active window is in a different colour than all other windows.

This is Windows' behaviour and not a problem in XnView. If you want to make the texts readable, you can change your Windows colour scheme. Though I have to say that in the Windows dialog "Display properties", tab "Appearance" I cannot see a way to change the colour for selected but non-focused objects.
User avatar
helmut
Posts: 8442
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

When re-reading your post I see that the info in my above answer is correct but it does not fit to the problem that you have reported.

I haven't checked in XnView much, but there really might be an issue with the colouring. And this topic is currently in "Fixed in Beta 4" forum, so I assume that Pierre has fixed something.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Still unreadable

Post by Clo »

—>helmut

• Hi !

• Still NOT fixed up in ß-4… :(

:mrgreen: G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 37571
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Still unreadable

Post by xnview »

Clo wrote:—>helmut

• Hi !

• Still NOT fixed up in ß-4… :(
Really??? But i use now the same colors as explorer!!
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

SP1 only

Post by Clo »

:) Really, I get the same defect than in the ß-3… Exactly that you can see on the images above when the focus is lost.

• However, it seems that this occurs only with XP SP1, since Paul-friend “Ouistiti” has tested with SP2, and asked me for I transmit that it works now for him…

:idea: Maybe as a test in the next version (RC1 ?), you could set an INI entry to choose -for instance- the BG colour of the window (light-cream here for me) which is stated in Windows ? This is the colour you see above as BG in Win Explorer and in the list of "Options"… ?

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Accuracies to lighten…

Post by Clo »

—> Pierre

:) Hello !

• To lighten the issue here { if I may say…:P }, below is a part of my nnn.theme file located in
E:\Documents and Settings\CLAUDE\Mes documents\perso_cata.theme,
where the colours I use in Windows are set with a classic Win 9x theme.
[Control Panel\Colors]
ActiveTitle=255 255 156
Background=58 110 165
Hilight=255 203 148
HilightText=0 0 128
TitleText=0 0 0
Window=255 255 213 —> The BG of the windows I talk of above = “Cream ”
WindowText=0 0 0

ButtonFace=212 208 200 —> The medium-grey shown in Win Explorer as a BG when the focus is lost, but that I don't get here still, while it works with XP SP2.
ButtonShadow=128 128 128 —> The dark-grey I get still instead of the right one above…
GrayText=128 128 128
ButtonText=0 0 0
InactiveTitleText=0 0 0
ButtonHilight=255 255 255
ButtonDkShadow=64 64 64
ButtonLight=212 208 200
• Hoping this helps, maybe to ease the addition of an INI entry (or a flag if any exists already ? I didn't find it…)

• Aside : Let's notice that for the colours by Windows above, the simple decimal RRR_GGG_BBB code is used.
- In XnView, this is the awful system using “complements” :|
- So, why not support the reverse hexa-code, which is much more easy to change by hand when needed for tests ? Like :
$BB_GG_RR

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 37571
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Accuracies to lighten…

Post by xnview »

Ok, i think that now it's good, is it possible to send you a version?
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Test version is OK !

Post by Clo »

:D Hello !

• With the test version, all is good now, as well for the Options as for the thumb nails labels ! Thank you !

- The medium-grey of Win is used as it should for the BG when the focus is lost.

• I wonder to know (roughly) what caused that defect ?

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
ckit
XnThusiast
Posts: 2453
Joined: Tue Feb 17, 2004 1:11 am
Location: Australia

Post by ckit »

Mines stays light grey for a while, then switches to dark grey for a while and then repeats.
Amusing to watch :)
Windows 10 Pro x64 21H2 and Vivaldi Browser (standalone)
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Quite OK

Post by Clo »

:) Hi !

• In ß-5, all is quite OK, I can't get the damn dark-grey again …

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice