Customizing colors of file tree pane

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
XnTriq
Moderator & Librarian
Posts: 5901
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq »

foxyshadis wrote:I'm curious, was any color ever added for the selected file's background/font? That's one of the only colors in the program that still seems to be the system default.
To my knowledge there are now four INI entries for customizing the colors of the folder tree pane.

Can anyone confirm that TreeFontHiColor is ignored if set to 100% black (0/#000000)?
  1. TreeBackColor=#666666
    TreeFontColor=#CCCCCC
    TreeFontHiColor=255
    » red
    TreeFontHiColor2=16777215
  2. TreeBackColor=#666666
    TreeFontColor=#CCCCCC
    TreeFontHiColor=0
    » TreeFontHiColor = TreeFontColor :?
    TreeFontHiColor2=16777215
  3. TreeBackColor=#666666
    TreeFontColor=#CCCCCC
    TreeFontHiColor=1
    » R1/G0/B0
    TreeFontHiColor2=16777215
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Does nothing---

Post by Clo »

:arrow: XnTriq

:) Hello !

• Maybe a bit aside, here I've :
TreeBackColor=255 255 222
TreeFontColor=60 0 0
TreeFontHiColor=180 0 0
TreeFontHiColor2=#00F000
…but I never see any “green” in the tree.
- All other entries work as expected, though…

:?:

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
XnTriq
Moderator & Librarian
Posts: 5901
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq »

Thanks for checking, Clo.

Something's not kosher in the way these settings are interpreted by XnView v1.92.1, but for now I can't narrow the problem down any further.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Kosher or not… That's the question !

Post by Clo »

:arrow: XnTriq

:) Hello !
Something's not kosher in the way these settings are interpreted by XnView v1.92.1…
• Yes, “pas très catholique…”. :D
That's pretty annoying because we need to update the Manual about the “TreeFontHiColor=…¦TreeFontHiColor2=…”
and that's impossible till Pierre explains clearly what the “2” entry might do.
- There is nothing in the <What's new>…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
XnTriq
Moderator & Librarian
Posts: 5901
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq »

Clo wrote:
Something's not kosher in the way these settings are interpreted by XnView v1.92.1…
• Yes, “pas très catholique…”. :D
Oops, pardon my Yinglish. I forgot we're a catholic network. Mea culpa. :wink:

This seems to be the thread where the feature was originally requested:
ghost zero ([url=http://newsgroup.xnview.com/viewtopic.php?t=13204]TreeFontHiColor2 option?[/url]) wrote:How about adding a TreeFontHiColor2 option? So both active and inactive pane text color can be seen?

Image
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Nope…

Post by Clo »

:arrow: XnTriq

:) Again…

• Sorry for this expression but it's the very orthodox French translation for “not kosher:P

• The ghost zero's pics are clear, but here nope ! Active and inactive panels have different BGs like they would,
but the font-colour stays the same, while IIUC it might be green for the inactive panel. :bug: ?

    Image      Image

• I used TreeFontHiColor2=0 240 0 for the test shown above, no progress.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 36291
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

XnTriq wrote:
foxyshadis wrote:I'm curious, was any color ever added for the selected file's background/font? That's one of the only colors in the program that still seems to be the system default.
To my knowledge there are now four INI entries for customizing the colors of the folder tree pane.

Can anyone confirm that TreeFontHiColor is ignored if set to 100% black (0/#000000)?
  1. TreeBackColor=#666666
    TreeFontColor=#CCCCCC
    TreeFontHiColor=255
    » red
    TreeFontHiColor2=16777215
  2. TreeBackColor=#666666
    TreeFontColor=#CCCCCC
    TreeFontHiColor=0
    » TreeFontHiColor = TreeFontColor :?
    TreeFontHiColor2=16777215
  3. TreeBackColor=#666666
    TreeFontColor=#CCCCCC
    TreeFontHiColor=1
    » R1/G0/B0
    TreeFontHiColor2=16777215
Yes right, it's to know if this entry exists (TreeFontHiColor & TreeFontHiColor 2). I'll fix it
Pierre.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

semi-fixed

Post by Clo »

:arrow: Pierre

:) Hello !

• Now in 1.93ß1, I get all colours but the entries are inverted with regard to the images above :
TreeFontHiColor=180 0 0 >>> Stands for INactive panel,
TreeFontHiColor2= #00F000 >>> Stands for Active panel !

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
xnview
Author of XnView
Posts: 36291
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: semi-fixed

Post by xnview »

Clo wrote::arrow: Pierre

:) Hello !

• Now in 1.93ß1, I get all colours but the entries are inverted with regard to the images above :
TreeFontHiColor=180 0 0 >>> Stands for INactive panel,
TreeFontHiColor2= #00F000 >>> Stands for Active panel !

:mrgreen: KR
Claude
Clo
Right :-(
Pierre.
User avatar
XnTriq
Moderator & Librarian
Posts: 5901
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: semi-fixed

Post by XnTriq »

Clo wrote:• Now in 1.93ß1, I get all colours but the entries are inverted with regard to the images above :
TreeFontHiColor=180 0 0 >>> Stands for INactive panel,
TreeFontHiColor2= #00F000 >>> Stands for Active panel !
Fixed in beta 2.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Changed again--

Post by Clo »

:arrow: XnTriq

:) Hello !

• Confirmed OK now, I'd just to invert my values again… :D

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
Guest

Post by Guest »

Hi, i looked all through the .ini file and cannot find these in the file to change them. Do I have to add them manually, and if so under what section?
User avatar
XnTriq
Moderator & Librarian
Posts: 5901
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq »

Anonymous wrote:Hi, i looked all through the .ini file and cannot find these in the file to change them. Do I have to add them manually, and if so under what section?
You have to add them manually to the [browser] section.
dragonsblade71uk
Posts: 7
Joined: Fri Jun 01, 2007 12:29 pm

Post by dragonsblade71uk »

Ok ty, I now have black treeview.