RC4: 'Add text' doesn't work

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

RC4: 'Add text' doesn't work

Post by ckv » Fri Jun 03, 2005 11:23 am

Add text don't work with all fonts in windows 98 and in XP it don't work at all. (Maybe unicode font bug) Edit: heh heh I was so wrong. :D

To reproduce.
- open picture in XnView
- Shift+T or in the menu Image/Add text...
- In XP select any font (I didn't try them all, but about six different fonts didn't work) In Windows 98 I found only one font what didn't work and I can't remember it's name, but it was default the font.
- press ok and add font. (nothing happends)

Edit:
Hmmm. :| I just deleted the XnView.ini and tryed again and now any of the fonts don't work in windows 98, just like in XP.

_ :bug::bug: ___ :bug: _ :bug: __ :bug: ___ :bug:
:bug: ______ :bug::bug: _____ :bug: _ :bug:
:bug: ______ :bug::bug: ______ :bug::bug:
_ :bug::bug: ___ :bug: _ :bug: _____ :bug:
Last edited by ckv on Thu Jun 09, 2005 11:48 am, edited 2 times in total.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

ckit
XnThusiast
Posts: 2444
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Fri Jun 03, 2005 11:32 am

Yes, I can confirm this bug.
After clicking OK in the Add Text dialog, you can move the text around but the moment you click where you want it nothing happens.
Windows 10 Pro x64 1903
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
xnview
Author of XnView
Posts: 31869
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Jun 03, 2005 1:06 pm

ckit wrote:Yes, I can confirm this bug.
After clicking OK in the Add Text dialog, you can move the text around but the moment you click where you want it nothing happens.
Yes, a new little bug.
Pierre.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Mon Jun 06, 2005 4:51 pm

Not fixed in RC5.

Bug changed a bit.
Now it adds the 'text pointer' to the picture but don't still add the actual text. :|
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Mon Jun 06, 2005 6:33 pm

ckv wrote:Not fixed in RC5.
Confirmed.

Moved back to "New/Open"

ckit
XnThusiast
Posts: 2444
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Tue Jun 07, 2005 2:02 am

Fixed for me in RC5
Windows 10 Pro x64 1903
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Tue Jun 07, 2005 5:56 pm

ckit wrote:Fixed for me in RC5
ckit could you also try with windows 98 and / or with clean ini (if you haven't yet)
I got this to work in RC3 so it might be ini related :|
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Tue Jun 07, 2005 9:12 pm

ckv wrote:I got this to work in RC3 so it might be ini related :|
Yes, it doesn't work with my old .ini file only, no problems with default settings. What about you?

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Wed Jun 08, 2005 5:41 am

Dreamer wrote:Yes, it doesn't work with my old .ini file only, no problems with default settings. What about you?
Hmm. I works with new clean ini now, but I made new ini for RC5 in the first place, and it didn't work. Only difference is that I adjust configs what I prefer. Maybe ini gets messed because of some of those adjustments.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

'RightButtonFlag' in ini causes this

Post by ckv » Wed Jun 08, 2005 4:01 pm

Pierre Dreamer I think I found the problem it's ini value called 'RightButtonFlag'. I made little debugging job and compared working and non working ini with Compare it! program.

Heres report file Compare it! report
In left side is the non working ini
It's the last difference in this report file.

When I changed 'RightButtonFlag' to '0' add text works if I set it back to '1' add text don't work. :|
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
xnview
Author of XnView
Posts: 31869
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 'RightButtonFlag' in ini causes this

Post by xnview » Thu Jun 09, 2005 11:11 am

ckv wrote:Pierre Dreamer I think I found the problem it's ini value called 'RightButtonFlag'. I made little debugging job and compared working and non working ini with Compare it! program.

Heres report file Compare it! report
In left side is the non working ini
It's the last difference in this report file.

When I changed 'RightButtonFlag' to '0' add text works if I set it back to '1' add text don't work. :|
Ok, right i fix it
Pierre.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Fri Jun 10, 2005 4:40 pm

Fixed! Thanks Pierre. :mrgreen:
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Fri Jun 10, 2005 7:15 pm

Confirmed.

Locked