B1: Custom Rotate does nothing

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

B1: Custom Rotate does nothing

Post by helmut » Thu Dec 08, 2005 7:12 pm

When rotating an image using "Rotate > Custom...", the image is not rotated, regardless which angle you enter. :bug:

User avatar
xnview
Author of XnView
Posts: 33666
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B1: Custom Rotate does nothing

Post by xnview » Thu Dec 08, 2005 7:39 pm

helmut wrote:When rotating an image using "Rotate > Custom...", the image is not rotated, regardless which angle you enter. :bug:
Sorry i have not this bug, if i drag or enter a degree, picture is rotated...
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Works fine

Post by Clo » Thu Dec 08, 2005 8:18 pm

:) Hi Pierre !

- That works perfectly here under XP-Pro.

- A trivial issue in the palette for "Customized colours" (for the backgtound) : The button "Define customized colours" (or so, it's in French here) stays blurred always; that works, though.

- I miss a "Reset" button to get "0" quickly… Using the slider then the arrow-buttons is quite tedious…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: B1: Custom Rotate does nothing

Post by marsh » Thu Dec 08, 2005 8:20 pm

xnview wrote:
helmut wrote:When rotating an image using "Rotate > Custom...", the image is not rotated, regardless which angle you enter. :bug:
Sorry i have not this bug, if i drag or enter a degree, picture is rotated...
It does nothing when apply to image is not selected. It applies change to image only when 'apply' is selected.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: B1: Custom Rotate does nothing

Post by helmut » Thu Dec 08, 2005 8:42 pm

marsh wrote:
xnview wrote:
helmut wrote:When rotating an image using "Rotate > Custom...", the image is not rotated, regardless which angle you enter. :bug:
Sorry i have not this bug, if i drag or enter a degree, picture is rotated...
It does nothing when apply to image is not selected. It applies change to image only when 'apply' is selected.
I see now that I was a bit too unspecific: It does nothing when confirming the Rotate dialog pressing "OK" button. (Apply to image is not checked).

User avatar
xnview
Author of XnView
Posts: 33666
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B1: Custom Rotate does nothing

Post by xnview » Thu Dec 08, 2005 9:24 pm

helmut wrote:
marsh wrote:
xnview wrote: Sorry i have not this bug, if i drag or enter a degree, picture is rotated...
It does nothing when apply to image is not selected. It applies change to image only when 'apply' is selected.
I see now that I was a bit too unspecific: It does nothing when confirming the Rotate dialog pressing "OK" button. (Apply to image is not checked).
I confirm now :-)
Pierre.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Mon Dec 19, 2005 11:04 pm

Fixed in b2.

X.

Locked