b1: fit window to image- horizontal not quite there

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
Guest

b1: fit window to image- horizontal not quite there

Post by Guest » Tue Dec 13, 2005 10:51 pm

Windows XP Pro SP2, xnview 1.82. Fit window to image is almost working perfectly but the horizontal window border is not resizing all the way. my desktop resolution is 1280x1024 and the images are 631x968 and 687x1028.

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: b1: fit window to image- horizontal not quite there

Post by xnview » Thu Dec 15, 2005 1:51 pm

Anonymous wrote:Windows XP Pro SP2, xnview 1.82. Fit window to image is almost working perfectly but the horizontal window border is not resizing all the way. my desktop resolution is 1280x1024 and the images are 631x968 and 687x1028.
Could you post a screenshot?
Pierre.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Thu Dec 22, 2005 9:41 am

I confirm this problem in 1.80.3:
Deleted ini, changed in Options Fit window to image and Force XnView to fit image, image greater than display.
XnView window was maximized only vertically, but horizontally the size was set to 408 pixels.

In b1 and b2 it behaves correctly, ie. XnView window is maximized.

Fixed IMO, can be closed.

X.

Guest

Post by Guest » Fri Dec 30, 2005 1:42 pm

For me it almost stretches all the way horizontally. The horizontal scroll bar is still there and can be moved a little bit. Set your desktop to 1280x1024 and try with this image:

http://www.deviantart.com/view/26997028/

Guest

Post by Guest » Mon Jan 16, 2006 4:10 pm

Has anyone else tested this with the link to the pic I provided above?

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Mon Jan 16, 2006 5:21 pm

Yes, there is problem in rc1, the window is not enough resized horizontally.
Reopen.

link:
http://img379.imageshack.us/my.php?imag ... ize3wi.jpg

X.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Fri Jan 20, 2006 11:27 am

fixed in rc2.

X.

Locked