B1: Xnview doesn't rotate images based on EXIF

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
grkn
Posts: 5
Joined: Fri Jun 24, 2005 6:33 pm
Contact:

B1: Xnview doesn't rotate images based on EXIF

Post by grkn » Wed Dec 14, 2005 9:30 pm

<Moderator's note: This topic has been moved>

I'm using Xnview 1.82 beta 1, and it doesn't automatically rotate images when watching them in the browser (even though the option is enabled), and when trying to use the lossless rotator.

This is true for pictures from both my canon camera and my cellphone.
Using xp pro btw.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Xnview doesn't rotate images based on EXIF

Post by helmut » Wed Dec 14, 2005 10:15 pm

grkn wrote:<Moderator's note: This topic has been moved>

I'm using Xnview 1.82 beta 1, and it doesn't automatically rotate images when watching them in the browser (even though the option is enabled), and when trying to use the lossless rotator.

This is true for pictures from both my canon camera and my cellphone.
Using xp pro btw.
Does your camera and handy have an orientation sensor? If yes, the orientation information of the sensor is written to the image as attribute "EXIF orientation". This attribute is interpreted by XnView and the image is rotated accordingly.

If your camera hasn't got an orientation sensor, this will not work.

See also FAQ "How to rotate images automatically".

grkn
Posts: 5
Joined: Fri Jun 24, 2005 6:33 pm
Contact:

Post by grkn » Wed Dec 14, 2005 10:29 pm

Hehe, I think I messed up, thinking that pictures where the subject was upside down wasn't rotated correctly.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Thu Dec 22, 2005 9:31 am

Close. Non-issue.

X.

Locked