b2: Refresh crash

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

b2: Refresh crash

Post by ckv » Sun Dec 25, 2005 4:22 pm

The bug occurs also in 1.80.3

Edit: As it turned out, this bug is somewhat random and there are no sure way to reproduce the bug except maybe in XnView 1.80.3.

This should be sure way to reproduce in version 1.80.3:
- Delete or rename your xnview.ini
- Disable cache and enable folders in browser
- Set the 'Browser / Startup Directory' option to Specified, but leave the path field empty
- Restart XnView
- Hit F5 or press the Refresh button in the browser
= XnView crashes


Not so sure way to reproduce in version 1.82b:
- Disable cache and enable folders in browser
- Set the browser to open at startup
- Set the 'Browser / Startup Directory' option to Specified, but leave the path field empty
- Restart XnView
- Hit F5 or press the Refresh button in the browser
= XnView crashes


By setting the 'Startup Directory' option to Specified and leaving path field empty, is the only way to start the browser in to mode where no folders are open and the folder tree is in 'My computer'. This is more a trick than function, but I like it to work that way, so please don't fix this in the way that this 'function' stops working. :)
Last edited by ckv on Sun Dec 25, 2005 9:20 pm, edited 11 times in total.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Works here---

Post by Clo » Sun Dec 25, 2005 4:58 pm

:) Hello !

- I cannot reproduce a crash following your steps. I tested both ß-2 and 1.80.3, no problem : the browser starts alright showing only the tree, not any folder as expected.
- When I press F5, I get the first folder of my “Favourite folders” menu…

- Under XP-Pro.

BTW : This workaround (to leave a blank field) is very useful for me, since before we had an option "Don't start the thumb-nails" which has been suppressed. Also, I like to start the browser empty, then open the directory I need…

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Sun Dec 25, 2005 5:27 pm

Have you set the browser to open on at startup? It seems that that bug won't occur if the browser don't open on startup.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Test again---

Post by Clo » Sun Dec 25, 2005 5:42 pm

:| No, 'cause this was not specified in your steps, and I never set this, but I go to test again in that way ! :)

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
XnTriq
Moderator & Librarian
Posts: 5602
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Sun Dec 25, 2005 5:55 pm

Windows 2000 SP4:
¤ 1.80.3 crashes
¤ 1.82 Beta 2 works fine (browser jumps to XnView installation folder)

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Else---

Post by Clo » Sun Dec 25, 2005 5:57 pm

:) Ah ! This is another song !

- With the ß-2, the crash occurs, address of the error Offset 0002BEF1 :bug:

- With 1.80.3, no crash still, but F5 makes that the folder of XnView is displayed in the thumb-nail board :P
- I use the layout #4…

• Hum… I guess that “my” old option "Don't start the thumbnails" might be restored… It didn't cause such issues.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Funny !

Post by Clo » Sun Dec 25, 2005 5:59 pm

:arrow: XnTriq

:D Hello !

• Funny temperamental :bugconfirmed: , since I get exactly the opposite !

[OT] Please, look at your PMs ;) [/OT]

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Sun Dec 25, 2005 8:53 pm

Clo & XnTriq
Yeah this bug is somewhat random. I tested with clean ini and it doesn't crash. Theres still have to have to be an option what causes this.

Edit: Ok I got it. The folders have to be enabled in browser. I updated the reproduce instructions. (should be sure way to reproduce)
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

With hidden & folders

Post by Clo » Sun Dec 25, 2005 9:11 pm

:arrow: ckv

:P Continuation:

- Same here with "Folders" enabled, crash with the ß-2 (same address of error than above), and nothing with the 1.80.3, just the folder of XnView as thumb-nails…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: With hidden & folders

Post by ckv » Sun Dec 25, 2005 9:23 pm

@Clo
LOL. Ok try my new "sure way to reproduce in version 1.80.3" instructions in the first post.

Edit: Also could backup your 1.82b ini file, Pierre might want it. (I deleted my 1.82b ini :( and I can't reproduce it anymore)
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

With new INIs---

Post by Clo » Sun Dec 25, 2005 9:46 pm

:arrow: ckv

:D Same here with new INIs (I renamed the current ones in both versions) :
- Impossible to crash the 1.80.3 according to your updated steps,
- Still a pretty crash with the ß-2, anyway, it crashed already at will before…

- Possible that other settings among the default ones (since we have fresh INIs) be relevant, hard to track them …

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique
Contact:

Post by ouistiti » Sun Dec 25, 2005 10:45 pm

Sorry i can't reproduce this behaviour...
Odd ! Not any crash here !

xnView v1.82 ß2 (WinXP SP2)

Friendly

Paul
L'important n'est pas de convaincre, mais de donner à réfléchir.
The important thing is not to convince, but to incite to think.

1,77245385090552...

ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Re: b2: Refresh crash

Post by ckit » Sun Dec 25, 2005 10:51 pm

ckv wrote: Not so sure way to reproduce in version 1.82b:
- Disable cache and enable folders in browser
- Set the browser to open at startup
- Set the 'Browser / Startup Directory' option to Specified, but leave the path field empty
- Restart XnView
- Hit F5 or press the Refresh button in the browser
= XnView crashes


By setting the 'Startup Directory' option to Specified and leaving path field empty, is the only way to start the browser in to mode where no folders are open and the folder tree is in 'My computer'. This is more a trick than function, but I like it to work that way, so please don't fix this in the way that this 'function' stops working. :)
Confirmed.
XnViewMP 64bits and Windows 10 Pro x64 2004
PhotoFiltre Studio X

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: b2: Refresh crash

Post by Dreamer » Mon Dec 26, 2005 12:53 am

ckit wrote:
ckv wrote: Not so sure way to reproduce in version 1.82b:
- Disable cache and enable folders in browser
- Set the browser to open at startup
- Set the 'Browser / Startup Directory' option to Specified, but leave the path field empty
- Restart XnView
- Hit F5 or press the Refresh button in the browser
= XnView crashes


By setting the 'Startup Directory' option to Specified and leaving path field empty, is the only way to start the browser in to mode where no folders are open and the folder tree is in 'My computer'. This is more a trick than function, but I like it to work that way, so please don't fix this in the way that this 'function' stops working. :)
Confirmed.
I can confirm too. Win XP SP2, XnView beta 2.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Re: b2: Refresh crash

Post by Xyzzy » Tue Dec 27, 2005 10:59 am

ckv wrote:Not so sure way to reproduce in version 1.82b:
- Disable cache and enable folders in browser
- Set the browser to open at startup
What options exactly do you mean? No confirmation so far, XP SP2 Pro.

X.

Locked