RC1: HTML files always show as thumb

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

RC1: HTML files always show as thumb

Post by robc » Tue Jan 10, 2006 12:10 pm

HTM/HTML files, which I set in "Custom files", display as a thumbnail (the text contained in the file, just like a text file) whatever the setting, both marking or clearing the "Show as thumbnail" checkbox in Options. If I don't enter them as custom files, they show all the same: it appears HTML files are considered like image files, but it seems to me they should be treated like text files, or "worse"... in most cases, seeing the text inside the HTML file is completely useless, since it gives no information about the contents, while for normal text files it could be useful; it would be nice, though, to have a thumbnail of the _rendered_ page :wink:

Is this a bug, present also in previous betas, or have I misunderstood the available options? I just need to display any HTML file with its icon and no thumbnail, just like it's possible with text files.

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: HTML files always show as thumb

Post by xnview » Tue Jan 10, 2006 2:50 pm

robc wrote:HTM/HTML files, which I set in "Custom files", display as a thumbnail (the text contained in the file, just like a text file) whatever the setting, both marking or clearing the "Show as thumbnail" checkbox in Options. If I don't enter them as custom files, they show all the same: it appears HTML files are considered like image files, but it seems to me they should be treated like text files, or "worse"... in most cases, seeing the text inside the HTML file is completely useless, since it gives no information about the contents, while for normal text files it could be useful; it would be nice, though, to have a thumbnail of the _rendered_ page :wink:

Is this a bug, present also in previous betas, or have I misunderstood the available options? I just need to display any HTML file with its icon and no thumbnail, just like it's possible with text files.
If you uncheck the custom files with "HTM HTML", you see .html files in browser?
Pierre.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Jan 10, 2006 3:10 pm

Yes, I've always seen them, I put them under the "custom" category to be able to switch off their thumbnails, which I couldn't anyway :? The thumb is exactly the same as text files, that is part of the text inside the file in a small font on a white background. HTM/HTML files don't follow the same behavior as text files, though, since I can show the latter either with their icon or with the thumb with no problem.

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jan 10, 2006 3:20 pm

robc wrote:Yes, I've always seen them, I put them under the "custom" category to be able to switch off their thumbnails, which I couldn't anyway :? The thumb is exactly the same as text files, that is part of the text inside the file in a small font on a white background. HTM/HTML files don't follow the same behavior as text files, though, since I can show the latter either with their icon or with the thumb with no problem.
Refresh don't change anything? Strange, for me, html files are not shown.
Perhaps you could send me your .ini?
Pierre.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Jan 10, 2006 3:47 pm

Sure, but I'll send you a Registry export, since I'm keeping settings there. Look for a PM in a few minutes...

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jan 10, 2006 4:01 pm

robc wrote:Sure, but I'll send you a Registry export, since I'm keeping settings there. Look for a PM in a few minutes...
You can create a xnview.ini by unchecking registry
Pierre.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Jan 10, 2006 4:19 pm

OK, disregard my PM, below's the .ini (though I usually prefer the registry :wink: ).

zipped .ini

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jan 10, 2006 4:38 pm

robc wrote:OK, disregard my PM, below's the .ini (though I usually prefer the registry :wink: ).

zipped .ini
Ok, with your ini i have this one :-)
http://newsgroup.xnview.com/viewtopic.php?t=4634
But .html are not shown if i uncheck custom file with html
Pierre.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Jan 10, 2006 5:23 pm

Pierre, sorry, I couldn't make myself understood: HTML are correctly shown or hidden according to the option settings, what seems impossible is to have them display their icon and not the thumb: for other file types (for example text and PDF), if I uncheck "show as thumbnail" they're display their corresponding icon, if I check it they display their thumbnail... HTML files, if visible, always display as thumbnails whatever the setting.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Fri Jan 20, 2006 10:01 am

In rc2 I cannot make thumbnails for HTMLs, they are always displayed as icons.

BTW, strange that HTMLs are not considered text files- they are just plain text files.

X.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Fri Jan 20, 2006 2:07 pm

As I said above, they are text files but IMHO they should not be treated as such, since showing the first few lines gives a hint of the content of a normal text file, but just a bunch of hmtl tags in an html file... I, for one, wish to treat them differently.

But... in rc2 I don't see htm files whatever I do :( I need to set "all other files" to show html files, if I put them in the "custom" category they are not displayed (in rc1 they were) :shock:

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Fri Jan 20, 2006 3:08 pm

robc, post your ini with problems.

As for web pages, XnView could use Gecko for pages display, but I believe it would be slow. Oh, and we could have web browser in XnView :wink:

X.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Sat Jan 21, 2006 9:26 am

It was the same as I had posted a few posts above, though I simply re-enabled Registry use instead of the .ini :?

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Sat Jan 21, 2006 9:52 am

OK, I've deleted the .ini and restarted XnView, re-applying all my custom settings (colors, thumb size, etc.) by hand and now I correctly see HTML files... it seems it was just an .ini problem.

Locked