RC1: Border of Thumbnails is strange (3D effect)

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

RC1: Border of Thumbnails is strange (3D effect)

Post by Olivier_G » Wed Jan 11, 2006 12:33 am

In Thumbnail>Appearance, if you set 'Border size' to 2 or higher, you get a strange 3D effect (cf white lines around thumbnails on top and left):
Image
(example with its settings, notice 'flat style')

Moreover, the spacing between two thumbnails seems to be 2x 'Spacing' value whereas it should be 1x 'Spacing' value (ie: there is only 1 spacing between 2 objects).

Olivier
PS: Thank you Pierre for this improvement over the previous version.

Edit: I removed my comment about color of border. Seems fine...
Last edited by Olivier_G on Wed Jan 11, 2006 12:26 pm, edited 2 times in total.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh » Wed Jan 11, 2006 3:10 am

Confirmed. Border looks like shadow is being used even when it is turned off! Set border to 4.
Image

User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Re: RC1: Border of Thumbnails is strange (3D effect)

Post by Olivier_G » Thu Jan 19, 2006 7:48 pm

Olivier_G wrote:you get a strange 3D effect (cf white lines around thumbnails on top and left)
Not completely fixed with RC2: there is now a single white line shown at the bottom, for border's size of 1 or higher.
Moreover, the spacing between two thumbnails seems to be 2x 'Spacing' value whereas it should be 1x 'Spacing' value
Seems to be now a rather strange value based on 2x spacing - something... :? (minor request for 1.82, though...)

Olivier

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: Border of Thumbnails is strange (3D effect)

Post by xnview » Thu Jan 19, 2006 7:54 pm

Olivier_G wrote:
Olivier_G wrote:you get a strange 3D effect (cf white lines around thumbnails on top and left)
Not completely fixed with RC2: there is now a single white line shown at the bottom, for border's size of 1 or higher.
Moreover, the spacing between two thumbnails seems to be 2x 'Spacing' value whereas it should be 1x 'Spacing' value
Seems to be now a rather strange value based on 2x spacing - something... :? (minor request for 1.82, though...)

Olivier
Argglll, do you have a screenshot? :-)
Pierre.

User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Re: RC1: Border of Thumbnails is strange (3D effect)

Post by Olivier_G » Thu Jan 19, 2006 8:20 pm

xnview wrote:Argglll, do you have a screenshot? :-)
Here you are (white line at the bottom, between blue 'Thumbnail back' and red Border):

Image

User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Re: RC1: Border of Thumbnails is strange (3D effect)

Post by Olivier_G » Wed Jan 25, 2006 11:00 pm

xnview wrote:Argglll
S.O.L.V.E.D... in RC3! :P
-> can move to 'Closed'.

Thank you, Pierre.

Olivier
PS: I will continue the other suggestion, but it's - now - a minor request only... :)

Locked