Problem with grid display at V1.82.1

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

User avatar
Maiger
Posts: 17
Joined: Thu Feb 09, 2006 8:12 am
Location: Austria/Europe
Contact:

Problem with grid display at V1.82.1

Postby Maiger » Thu Feb 09, 2006 2:36 pm

I'm using V1.82.1 (06/FEB/2006) on WinXP-Pro (SP2) and Win2000 (SP4).
I see no difference in the grid, if I change the value at the key "GridType" in the ini-file. Regardless which value I use (0,1 or 2), I always get the same strangely grid display after restarting XnView. The first column is not numbered, the second column starts with "1", the third with "2" and so on.
Also the rows are not numbered at lower zoom levels. If I increase the zoom, at some level I get the letters "A", "B" and so on. If I increase the zoom level more, the letters will change "A"-->"AA"-->"AAA" and "B"-->"AB"-->"AAB" and so on.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Grig---grid---

Postby Clo » Thu Feb 09, 2006 7:31 pm

—> Maiger

:) Hello, welcome aboard !

¤ I had opened an old thread about the grid-improvement, maybe did you read it THERE ?
¤ It seems that only the square shape maintenance has been fixed up…
…If I increase the zoom, at some level I get the letters "A", "B" and so on. …If I increase the zoom level more, the letters will change
"A"-->"AA"-->"AAA" and "B"-->"AB"-->"AAB" and so on.

This looks normal… I guess it's a general Win "numbering" mode as alpha, similar to the HD one (IIRC, after “Z” we might have “AA”, after “ZZ” —> “AAA” …).
- However, you are right somewhere, since while «zooming in» progressively (5% step is set), I noticed "A" again after "Z", that is abnormal IMHO…

:mrgreen: VG
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Maiger
Posts: 17
Joined: Thu Feb 09, 2006 8:12 am
Location: Austria/Europe
Contact:

Re: Problem with grid display at V1.82.1 (V1.82.2)

Postby Maiger » Fri Feb 10, 2006 9:01 am

Clo wrote::) Hello, welcome aboard !

¤ I had opened an old thread about the grid-improvement, maybe did you read it THERE ?

Thanks for the welcome !

I've read your old thread about the grid-improvement, but the reason for a new thread was the following:
I refer to the change log of V1.82 ....

Added : Add GridSpacing & GridType & KeepGridForNextPrevious as hidden ini
0 > No labels
1 > Displays digits and letters for the X and Y coordinates (like actually)
2 > Displays only digits for X, and letters for Y


GridSpacing & KeepGridForNextPrevious works OK.
GridType doesn't work!

In the current Version 1.82.2, GridType will be set to '1' and should display digits and letters for the X and Y coordinates.
I only get digits for the X coordinates and the strange thing is, the will start with '1' in the second field.
The letters for the Y coordinates appears only at a higher zoom level.
e.g. zoom below 150% will show no letters for Y coordinates, the fields are empty!

IMHO is this a bug in the current version, because the new feature GridType is added and is not working !

Kind Regards
Gerhard

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Funny…

Postby Clo » Fri Feb 10, 2006 9:23 am

:) Hello

- Indeed, a new thread is possible, just see that the Mods could decide, I'm not a Mod here …;)

- The strange thing is that I didn't see the changelog ... :?

• Well, I will test that is working, and which minimum step can be set for the grid; but certainly the marking off is buggy currently, you are right !

:mrgreen: V.G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Maiger
Posts: 17
Joined: Thu Feb 09, 2006 8:12 am
Location: Austria/Europe
Contact:

Re: Funny…

Postby Maiger » Fri Feb 10, 2006 9:49 am

Clo wrote:- The strange thing is that I didn't see the changelog ... :?

File WhatsNew.txt at line 68 in the current V1.82.2 installation ... :?:

Regards, Gerhard :wink:

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Guilty : Search

Postby Clo » Fri Feb 10, 2006 10:21 am

:) Right, a failure of the Search in the editor… :P

- You could see some results of the tests I made in the old thread ;)

:mrgreen: VG
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Maiger
Posts: 17
Joined: Thu Feb 09, 2006 8:12 am
Location: Austria/Europe
Contact:

Postby Maiger » Mon Feb 13, 2006 1:47 pm

Can we say now, that the grid numbering and the ini-file-key GridType is not working in the current V1.82.x Versions :?:

Regards
Gerhard

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Buggy for now

Postby Clo » Mon Feb 13, 2006 11:21 pm

:) Hello Gerhard!

• I think we may say that…

- The other entries work though GridSpacing=… could be improved (to get a rectangular mesh), and obviously two supplemental ones are requested and still missing (blurred text)…
- So, Pierre has to fix up and complete this in the next 1.80.3. Some other functions have problems, hence I don't guess that we'll have this version tomorrow… :|

:mrgreen: V.G.
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Buggy for now

Postby xnview » Thu Feb 16, 2006 2:29 pm

Clo wrote::) Hello Gerhard!

• I think we may say that…

- The other entries work though GridSpacing=… could be improved (to get a rectangular mesh), and obviously two supplemental ones are requested and still missing (blurred text)…
- So, Pierre has to fix up and complete this in the next 1.80.3. Some other functions have problems, hence I don't guess that we'll have this version tomorrow… :|

Ok, i'll fix it
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Wha !

Postby Clo » Thu Feb 16, 2006 5:59 pm

:arrow: Pierre

:) Hello Pierre !

- Thanks to fix¦complete this, I guess that then, we'll have the nicest grid-thingy of all viewers !

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Maiger
Posts: 17
Joined: Thu Feb 09, 2006 8:12 am
Location: Austria/Europe
Contact:

Postby Maiger » Thu Feb 16, 2006 8:00 pm

IMHO XnView currently is the nicest viewer ...
with or without the grid display :D

Thanks Pierre, for all your work!

Kind Regards
Gerhard

User avatar
Maiger
Posts: 17
Joined: Thu Feb 09, 2006 8:12 am
Location: Austria/Europe
Contact:

Postby Maiger » Mon Mar 06, 2006 10:05 pm

Problem solved now in V1.82.3 :D
Thanks!


Return to “Testing - Closed/Solved”

Who is online

Users browsing this forum: No registered users and 2 guests