XnView 1.70 RC3 (Windows)

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

XnView 1.70 RC3 (Windows)

Postby xnview » Mon May 17, 2004 7:59 pm

Hello,

XnView v1.70 RC3 is available here (last release candidate before final release): http://www.xnview.com/beta/XnView-RC3.zip

Added : Configuration for text shown in fullscreen/slideshow

If you find bugs, please contact me.

Pierre.
Last edited by xnview on Tue May 18, 2004 7:06 am, edited 1 time in total.

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: XnView v1.70 RC3 (Windows)

Postby helmut » Mon May 17, 2004 11:31 pm

In full screen mode my test video (MPEG) is just black. It is played properly in the preview and normal view, but when switching to full screen it's just black.

When switching from full screen to 'Fit image to window, all' by pressing '/' key, the video is shown.

User avatar
ckit
XnThusiast
Posts: 2423
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah Australia
Contact:

Re: XnView v1.70 RC3 (Windows)

Postby ckit » Tue May 18, 2004 1:15 am

helmut wrote:In full screen mode my test video (MPEG) is just black. It is played properly in the preview and normal view, but when switching to full screen it's just black.

When switching from full screen to 'Fit image to window, all' by pressing '/' key, the video is shown.

I can reproduce this bug with a MPEG4 AVI file, I'm converting it to XviD 1.0.0 Final AVI and testing that and then I'll use a standard MPEG and test that.

MPEG4 AVI = fail
XviD 1.0.0 Final = fail (it worked the first time but failed every other time)
Bad Boys Game Trailer MPG = fail
Far Cry Gameplay MPG = fail (this one did have the highest success rate)
manhattan_chase_game_trailer_divx50.avi = fail
painkillertrailer(esrb_approved)_div50.avi = fail (worked once or twice)

I think the problem has to do with switching to Full screen on certain frames while the movie is playing.

Pressing '/' key will only fix it once, press '/' key again and I get a black screen again.

AstroBoy-e3-2004.mov = Success every time
NSDUYLAT_(lg).mov = Success every time
sims2_e3_04_sup.mov = Success every time

MOV files are NOT affected by this bug.

Guest

Postby Guest » Tue May 18, 2004 4:25 pm

Hello,

Thank you for fullscreen text customization. One additional small idea is that fullscreen text could also have a border as an option like cinema subtitles (or DVD player subtitles) white text with black Nxpixel character border (customizable border size and colour). Then this option would be perfect.
However actual is also satisfying.

Going back to disapearing scrollbars after the leaving fullscreen. There's still :bug: there:
:arrow: Zoom some part of the image, so there're both vertical and horz scrollbars
:arrow: Go into fullscreen
:arrow: Leave fullscreen
:arrow: Voilà ! No vertical scrollbar now (in RC2 I remember horz scrollbar was disapearing ;P)

Regards,

OnO
Posts: 6
Joined: Fri May 14, 2004 10:55 am
Location: Cracow, Poland
Contact:

Postby OnO » Tue May 18, 2004 4:29 pm

That was me ^^^^^^ writing this reply.

There's crackd http proxy at my provider :evil: , sometimes looses my php session..
OnO de la Cravovia

Guest

crw

Postby Guest » Wed May 19, 2004 1:03 am

image size in canon crw file?

User avatar
ckit
XnThusiast
Posts: 2423
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah Australia
Contact:

Postby ckit » Wed May 19, 2004 1:14 am

Anonymous wrote:Hello,

Thank you for fullscreen text customization. One additional small idea is that fullscreen text could also have a border as an option like cinema subtitles (or DVD player subtitles) white text with black Nxpixel character border (customizable border size and colour). Then this option would be perfect.
However actual is also satisfying.

Going back to disapearing scrollbars after the leaving fullscreen. There's still :bug: there:
:arrow: Zoom some part of the image, so there're both vertical and horz scrollbars
:arrow: Go into fullscreen
:arrow: Leave fullscreen
:arrow: Voilà ! No vertical scrollbar now (in RC2 I remember horz scrollbar was disapearing ;P)

Regards,


Yes, I agree XnView v1.70 RC3 still loses it's vertical scrollbar on images in View mode after coming out of Full Screen view.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Wed May 19, 2004 7:34 am

ckit wrote:Yes, I agree XnView v1.70 RC3 still loses it's vertical scrollbar on images in View mode after coming out of Full Screen view.

Strange, with the RC2, i have the problem of horizontal scrrolbar, but now no problem.
Which OS?
Pierre.

User avatar
ckit
XnThusiast
Posts: 2423
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah Australia
Contact:

Postby ckit » Wed May 19, 2004 11:44 am

Windows 2000 SP4

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Postby helmut » Wed May 19, 2004 11:57 am

xnview wrote:Strange, with the RC2, i have the problem of horizontal scrrolbar, but now no problem.
Which OS?
Pierre.

With RC3:
Windows 2000 (no SP) works o.k., but Windows XP doesn't. The problem does occur each time you toggle from fullscreen and back. Once the vertical scroll bar is gone, zooming in or out makes it appear, again.

User avatar
ckit
XnThusiast
Posts: 2423
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah Australia
Contact:

Postby ckit » Wed May 19, 2004 3:05 pm

helmut wrote:
xnview wrote:Strange, with the RC2, i have the problem of horizontal scrrolbar, but now no problem.
Which OS?
Pierre.

With RC3:
Windows 2000 (no SP) works o.k., but Windows XP doesn't. The problem does occur each time you toggle from fullscreen and back. Once the vertical scroll bar is gone, zooming in or out makes it appear, again.


I have the exact same problem except with Win2000 SP4. Zooming in or out fixes the problem for me too.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Wed May 19, 2004 4:10 pm

helmut wrote:With RC3:
Windows 2000 (no SP) works o.k., but Windows XP doesn't. The problem does occur each time you toggle from fullscreen and back. Once the vertical scroll bar is gone, zooming in or out makes it appear, again.

And on my win2000 SP2 or Win XP (no SP), i have no problem :-(
Pierre.

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Postby helmut » Wed May 19, 2004 4:56 pm

xnview wrote:
helmut wrote:With RC3:
Windows 2000 (no SP) works o.k., but Windows XP doesn't. The problem does occur each time you toggle from fullscreen and back. Once the vertical scroll bar is gone, zooming in or out makes it appear, again.

And on my win2000 SP2 or Win XP (no SP), i have no problem :-(
Pierre.

From what I can see this bug has been around for many XnView versions, so I think it's not too serious ;-)

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Wed May 19, 2004 6:39 pm

From what I can see this bug has been around for many XnView versions, so I think it's not too serious ;-)

But i hate bugs :D
Pierre.

User avatar
crazytb
Posts: 124
Joined: Wed Oct 15, 2003 2:51 am
Location: Brazil
Contact:

Postby crazytb » Wed May 19, 2004 7:20 pm

Thank you for fullscreen text customization. One additional small idea is that fullscreen text could also have a border as an option like cinema subtitles (or DVD player subtitles) white text with black Nxpixel character border (customizable border size and colour). Then this option would be perfect.


Maybe the "border" could be more difficult to implement. Instead of "border", a simple "shadow" is much easier to implement and it also does the job. :)


Return to “Testing - Closed/Solved”

Who is online

Users browsing this forum: No registered users and 1 guest