[Fixed] Five bugs: Video/Audio player, ...

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

[Fixed] Five bugs: Video/Audio player, ...

Post by Dreamer » Sun Jul 25, 2004 10:36 pm

I found some bugs (I think :wink: )

1. If audio or video is playing and I go from fullscreen or view mode to browser (and from browser to view mode or fullscreen) it's playing twice

2. If audio or video is playing and I want to go from fullscreen to view mode (with middle mouse button) or to browser (with mouse double click) it doesn't works (only Enter works)

3. If audio or video is playing and I switch between fullscreen, view mode and browser XnView crashes sometimes (probably because of twice playing)

4. If I switch from image to video in fullscreen, only audio plays (and black window). In view mode it's ok as well as if I go from browser to fullscreen

5. If "Hide mouse cursor in fullscreen" is on, it's not shown either if audio or video is playing or rename dialog box is shown (not real bug but it's not possible to control audio and video). I suggest new feature - show mouse cursor if mouse is moved

I tested with mp3, wav, mid, divX, mpeg - Win XP, SP1, XnView v1.70.4

One feature request at the end - can be add option to change white background color if audio or video is playing?

Thanks a lot !
Last edited by Dreamer on Tue Jul 05, 2005 5:21 pm, edited 1 time in total.

User avatar
helmut
Posts: 8184
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Five bugs: Video/Audio player, ...

Post by helmut » Mon Jul 26, 2004 10:40 am

Dreamer,

thank your for your defect reports. As you might know, the audio & video player has been fully reworked, obviously it's still a bit buggy. Please find some comments below.
Dreamer wrote:...
1. If audio or video is playing and I go from fullscreen or view mode to browser (and from browser to view mode or fullscreen) it's playing twice
Confirmed. I also think that when opening a video/audio it should not restart from beginning. But when changing the behaviour, there might be people that want the current behaviour back... (another option?)
Dreamer wrote: 2. If audio or video is playing and I want to go from fullscreen to view mode (with middle mouse button) or to browser (with mouse double click) it doesn't works (only Enter works)
Confirmed. For images, switching from normal image view to full screen and back works using the middle mouse button (I've just learnt this reading your report). If this is a feature for images, it should also work for video & audio.
Dreamer wrote: 3. If audio or video is playing and I switch between fullscreen, view mode and browser XnView crashes sometimes (probably because of twice playing)
Couldn't reproduce this one - only found another bug: In the browser, when selecting a video and switching to image view mode and then back to the browser, the preview is no longer displayed.
Dreamer wrote: 4. If I switch from image to video in fullscreen, only audio plays (and black window). In view mode it's ok as well as if I go from browser to fullscreen
Confirmed. Navigation in fullscreen results in black videos.
Dreamer wrote: 5. If "Hide mouse cursor in fullscreen" is on, it's not shown either if audio or video is playing or rename dialog box is shown (not real bug but it's not possible to control audio and video). I suggest new feature - show mouse cursor if mouse is moved
Confirmed. Mouse navigation without mouse cursor is really a bit hard ;-)
Dreamer wrote: One feature request at the end - can be add option to change white background color if audio or video is playing?
Currently there is one background colour for image view, only - no difference between normal view, fullscreen view, or videos. Would it be sufficient to have one background colour for image view and one for fullscreen view or is there a need to have a special colour for videos?

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Mon Jul 26, 2004 2:58 pm

3. If audio or video is playing and I switch between fullscreen, view mode and browser XnView crashes sometimes (probably because of twice playing)

Couldn't reproduce this one
If I go to audio (not video) in browser, then I press Enter (for fullscreen), then again Enter (for back to browser) it's always crashes.

I tested with mp3, wav, mid
4. If I switch from image to video in fullscreen, only audio plays (and black window). In view mode it's ok as well as if I go from browser to fullscreen

Confirmed. Navigation in fullscreen results in black videos.
Maybe some help: If tv or sat card player is on, or other video in other player is playing it works
Currently there is one background colour for image view, only - no difference between normal view, fullscreen view, or videos. Would it be sufficient to have one background colour for image view and one for fullscreen view or is there a need to have a special colour for videos?
One background color for everything is enough (for me), but problem is that if I switch in fullscreen from (specially dark) image to audio or video with white background (several times) it's not good for eyes :shock:

Thanks :)

User avatar
xnview
Author of XnView
Posts: 32733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Five bugs: Video/Audio player, ...

Post by xnview » Wed Jul 28, 2004 11:31 am

Dreamer wrote:4. If I switch from image to video in fullscreen, only audio plays (and black window). In view mode it's ok as well as if I go from browser to fullscreen
You switch only from view mode to fullscreen?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: Five bugs: Video/Audio player, ...

Post by Dreamer » Wed Jul 28, 2004 4:58 pm

xnview wrote:
Dreamer wrote:4. If I switch from image to video in fullscreen, only audio plays (and black window). In view mode it's ok as well as if I go from browser to fullscreen
You switch only from view mode to fullscreen?
Pierre.
I misunderstood exactly :? , black window is only in fullscreen, if I go from image to video (with pg down, for example).

User avatar
xnview
Author of XnView
Posts: 32733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Five bugs: Video/Audio player, ...

Post by xnview » Wed Jul 28, 2004 6:21 pm

Dreamer wrote:I misunderstood exactly :? , black window is only in fullscreen, if I go from image to video (with pg down, for example).
Ok, so not the first time?
You are in fullscreen, and you use pgdown to view your image & video, and you have a black screen when it's a video?
Which OS?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Wed Jul 28, 2004 7:24 pm

You are in fullscreen, and you use pgdown to view your image & video, and you have a black screen when it's a video?
Yes, and not only with pg down, with mouse scroll and space too.
Which OS?
Windows XP Pro, SP1

and again:
helmut wrote: Confirmed. Navigation in fullscreen results in black videos.
I wrote: Maybe some help: If tv or sat card player is on, or other video in other player is playing (in background) it works good (no black screen)

User avatar
helmut
Posts: 8184
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Five bugs: Video/Audio player, ...

Post by helmut » Mon Aug 09, 2004 8:50 pm

helmut wrote:
Dreamer wrote: 4. If I switch from image to video in fullscreen, only audio plays (and black window). In view mode it's ok as well as if I go from browser to fullscreen
Confirmed. Navigation in fullscreen results in black videos.
An important detail: The problem occurs only when navigating from an image to a video. When navigating from video to video, the problem does not occur.

User avatar
xnview
Author of XnView
Posts: 32733
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Five bugs: Video/Audio player, ...

Post by xnview » Tue Aug 10, 2004 7:59 am

helmut wrote:An important detail: The problem occurs only when navigating from an image to a video. When navigating from video to video, the problem does not occur.
Ok, i can reproduce it!
Pierre.

Lostclown
Posts: 99
Joined: Thu Jul 22, 2004 12:21 am
Location: Iceland

Post by Lostclown » Tue Aug 10, 2004 4:20 pm

Dreamer wrote:
3. If audio or video is playing and I switch between fullscreen, view mode and browser XnView crashes sometimes (probably because of twice playing)

Couldn't reproduce this one
If I go to audio (not video) in browser, then I press Enter (for fullscreen), then again Enter (for back to browser) it's always crashes.

I tested with mp3, wav, mid
I was able to reproduce this problem with an mp3 file.

Regards, Lostclown

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: Five bugs: Video/Audio player, ...

Post by Dreamer » Thu Nov 18, 2004 9:27 pm

helmut wrote:
Dreamer wrote:5. If "Hide mouse cursor in fullscreen" is on, it's not shown either if audio or video is playing or rename dialog box is shown (not real bug but it's not possible to control audio and video). I suggest new feature - show mouse cursor if mouse is moved
Confirmed. Mouse navigation without mouse cursor is really a bit hard ;-)
Now, when I discovered RMB context menu in fullscreen, I miss this even more... Could you add it, please? - Auto-hide mouse cursor in fullscreen (after 2 seconds) and show if it's moved...

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Tue Jul 05, 2005 5:22 pm

Fixed in 1.80.1.

Locked