XnView sous FreeBSD 4.9

Questions générales en Français

Moderators: XnTriq, xnview

Post Reply
User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

XnView sous FreeBSD 4.9

Post by Mar.mack » Sun Mar 28, 2004 4:56 pm

Salut Pierre :)

J'ai installé FreeBSD 4.9 sur mon portable et forcément j'ai installé Xnview pour gérer mes images :)

Bien que je sache que la version Windows est la plus riche, je t'avouerai être déçu de la version disponible sous FreeBSD. :|
(NB: j'ai compilé Xnview à l'aide du dernier code source disponible: version 1.68 8) )

Premier constat, l'interface: c'est pas trop jolie, m'enfin c'est compréhensible, porté un logiciel à l'identique c'est du boulot...
J'aurais pourtant aimé pouvoir avoir une barre d'outils skinnable (y'a que 2 skins possibles...) et des boutons plats (et non en relief)
J'aurais aussi apprécier pouvoir l'avoir en français... :'-(

M'enfin c'est pas grave, tout ça n'est pas génant en soit. C'est déjà bien que que Xnview soit disponible sur FreeBSD :)

Deuxième constat: Xnview ne conserve pas toutes les préférences? :bug:
J'ai voulut éditer le fichier des préférences pour corriger à la main les options qui posaient problème, mais Xnview à la cloture réécrit le fichier et zappe mes réglages... :'-(

Parmis les options qui pose problème (les réglages ne sont pas conservés) :
  • Position de la fenêtre sur le bureau (j'utilise Xfce4 comme environment)
  • 'Tools > Options > View > High zoom quality (slowest) > Enlarge / Fit to Window' ('Reduce' est conservé)
  • 'Tools > Options > Browser > Thumbnail > No thumbnail for files larger than (KB): 5000' (la valeur à la fermeture est re-réglé sur 100... oui, y'a des 'n' en trop :))
  • 'Tools > Options > * > PiNG' (petit 'i' en trop... mais sinon pas de pb :) )
  • 'Info > Visit Xnview * / ReadMe / What's New' (il ne se passe rien... mais je pense que c'est parce que je n'ai pas définit de logiciel par défaut...)
Voilà ce que j'ai constaté.
Je suppose qu'il doit y avoir d'autres choses... à suivre donc :)


MAJ: pas de menu pour basculer d'une fenêtre Xnview à l'autre...


MAJ 2: Xnview conserve ses préférences dans un le fichier '/home/nom_utilisateur/.xnviewrc' et créé un répertoire '/home/nom_utilisateur/.xnview/' contenant un répertoire 'cache' (quand l'option est active...). Pourquoi ne pas tout mettre dans '/home/utilisateur/.xnview/'?

User avatar
xnview
Author of XnView
Posts: 33648
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Xnview sous FreeBSD 4.9

Post by xnview » Tue Mar 30, 2004 11:48 am

Salut,
Mar.mack wrote:Bien que je sache que la version Windows est la plus riche, je t'avouerai être déçu de la version disponible sous FreeBSD. :|
Oui je sais, mais je manque de temps!
(NB: j'ai compilé Xnview à l'aide du dernier code source disponible: version 1.68 8) )
Comment code source???? Ils ne sont pas dispo??[/quote]
Premier constat, l'interface: c'est pas trop jolie, m'enfin c'est compréhensible, porté un logiciel à l'identique c'est du boulot...
J'aurais pourtant aimé pouvoir avoir une barre d'outils skinnable (y'a que 2 skins possibles...) et des boutons plats (et non en relief)
J'aurais aussi apprécier pouvoir l'avoir en français... :'-(
Oui je dois rajouter les skins, ainsi que le support des langues!
Deuxième constat: Xnview ne conserve pas toutes les préférences? :bug:
Parmis les options qui pose problème (les réglages ne sont pas conservés) :
  • Position de la fenêtre sur le bureau (j'utilise Xfce4 comme environment)
  • 'Tools > Options > View > High zoom quality (slowest) > Enlarge / Fit to Window' ('Reduce' est conservé)
  • 'Tools > Options > Browser > Thumbnail > No thumbnail for files larger than (KB): 5000' (la valeur à la fermeture est re-réglé sur 100... oui, y'a des 'n' en trop :))
  • 'Tools > Options > * > PiNG' (petit 'i' en trop... mais sinon pas de pb :) )
  • 'Info > Visit Xnview * / ReadMe / What's New' (il ne se passe rien... mais je pense que c'est parce que je n'ai pas définit de logiciel par défaut...)
Ok, je regarderais!
Pierre.

User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

Post by Mar.mack » Tue Mar 30, 2004 5:32 pm

Oui je sais, mais je manque de temps!
Rassure-toi, m'a critique portait non pas sur le manque de nouvelles fonctionnalités... mais sur celles que j'ai toujours eut l'habitude d'avoir depuis que je connais Xnview (la version 0.99 je crois...)...
Comment code source???? Ils ne sont pas dispo??
Ah oui?
Bah écoute, moi je l'ai fait via CVSUP, mais il se peut que je me trompe: Xnview nécessitant des packages annexes...

En même temps, quand je consulte cette page...

Marco :)

User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

Post by Mar.mack » Sun Apr 04, 2004 4:37 pm

Je viens de constater un autre bug...
Quand j'essai de charger une image qui n'a pas été charger en mode 'parcourir' (dû au bug de chargement en fonction du poids de l'image), au lieu de charger le 'visualisateur', xnview disparait... en gros il plante.

PS: j'ai l'impression qu'il manque une petite option pour que le 'viusalisateur' se charge en plein écran...

User avatar
xnview
Author of XnView
Posts: 33648
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Apr 05, 2004 8:21 am

Mar.mack wrote:Je viens de constater un autre bug...
Quand j'essai de charger une image qui n'a pas été charger en mode 'parcourir' (dû au bug de chargement en fonction du poids de l'image), au lieu de charger le 'visualisateur', xnview disparait... en gros il plante.
Quelle manip faix tu exactement?.
Pierre.

User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

Post by Mar.mack » Mon Apr 05, 2004 4:39 pm

bah rien de particulier...
Je me contente de double cliquer sur la vignette (qui n'a pas été chargé) pour la pouvoir la voir en mode 'visualisation'...
Sauf qu'à ce moment là, xnview disparait...

Cela ne pose pas de pb avec les images qui dont il existe un aperçu en mode 'parcourir'...

User avatar
xnview
Author of XnView
Posts: 33648
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Apr 06, 2004 7:29 am

Mar.mack wrote:bah rien de particulier...
Je me contente de double cliquer sur la vignette (qui n'a pas été chargé) pour la pouvoir la voir en mode 'visualisation'...
Sauf qu'à ce moment là, xnview disparait...
Cela ne pose pas de pb avec les images qui dont il existe un aperçu en mode 'parcourir'...
Donc une image non reconnu??? Quel format?
Pierre.

User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

Post by Mar.mack » Tue Apr 06, 2004 12:40 pm

comme je l'ai dit plus haut il y a un bug qui empêche de charger les images de plus de 100 Ko.
L'image faisant plus de 100Ko quelque soit son format, elle n'est pas chargé... ici c'est du JPG.

User avatar
xnview
Author of XnView
Posts: 33648
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Apr 07, 2004 12:03 pm

Mar.mack wrote:comme je l'ai dit plus haut il y a un bug qui empêche de charger les images de plus de 100 Ko.
L'image faisant plus de 100Ko quelque soit son format, elle n'est pas chargé... ici c'est du JPG.
Hum, etrange. Tu n'aurais pas par hasard activé l'option "No thumb with size >. .."?
Pierre.

User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

Post by Mar.mack » Wed Apr 07, 2004 7:18 pm

je viens de revérifier... et je crois t'avoir dit une bêtise...
Toutes mes excuses...
J'avais réussit à viré cette option entre-temps... il semble que les images JPG en question n'atteignent pas la dîte taille (63Ko), la visualisation se fait correctement sur le côté gauche. Mais elles ne possèdent pas de vignettes.
Et le chargement en plein écran fait planter Xnview (disparition instantanée du logiciel de l'écran)...
Je t'envois les images en question...

User avatar
xnview
Author of XnView
Posts: 33648
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Apr 08, 2004 6:38 am

Mar.mack wrote:je viens de revérifier... et je crois t'avoir dit une bêtise...
Toutes mes excuses...
J'avais réussit à viré cette option entre-temps... il semble que les images JPG en question n'atteignent pas la dîte taille (63Ko), la visualisation se fait correctement sur le côté gauche. Mais elles ne possèdent pas de vignettes.
Et le chargement en plein écran fait planter Xnview (disparition instantanée du logiciel de l'écran)...
Je t'envois les images en question...
ok

User avatar
Mar.mack
Posts: 89
Joined: Fri Dec 12, 2003 8:01 pm
Contact:

Post by Mar.mack » Thu Apr 08, 2004 8:38 pm

Il semble que le problème soit plus grave que ça...
En plein écran la navigation d'une image à l'autre ne fonctionne pas correctement...
Puis-je t'envoyer un lot de 31 fichiers (~7 Mo) pour test?

User avatar
xnview
Author of XnView
Posts: 33648
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Apr 09, 2004 8:44 am

Mar.mack wrote:Il semble que le problème soit plus grave que ça...
En plein écran la navigation d'une image à l'autre ne fonctionne pas correctement...
Puis-je t'envoyer un lot de 31 fichiers (~7 Mo) pour test?
Euh un peu bcq, t'as pas un ftp?
Peux tu m'expliquer un peu plus precisement le pb?
Pierre.

Post Reply