nconvert 4.79 segmentation fault when rotating

Discussions on NConvert - the command line tool for image conversion and manipulation

Moderators: XnTriq, xnview

Post Reply
suki_babee
Posts: 2
Joined: Tue Jun 26, 2007 6:23 pm

nconvert 4.79 segmentation fault when rotating

Post by suki_babee » Tue Jun 26, 2007 6:47 pm

I noticed image rotations of arbitrary angles result in jagged edges, so I was happy to see the 4.79 release add a "-rotate_flag smooth" option. But I can't get it to work.

This works (with jaggies): nconvert -rotate 9 -o out.jpg orig.jpg
this produces the same result (I guess the smooth flag is not picked up) : nconvert -rotate_flag smooth -rotate 9 -o out.jpg orig.jpg
but anything specified after the "-rotate" param results in a segmentation fault : nconvert -rotate 9 -rotate_flag smooth -o out.jpg orig.jpg
for instance, this command works on ver 4.51, but segmentation faults on 4.79 : nconvert -rotate 9 -crop 0 0 100 100 -o out.jpg orig.jpg

output :

Code: Select all

** NCONVERT v4.79 (c) 1991-2007 Pierre-E Gougelet (May 16 2007/10:54:38) **
        Version for Linux x86 (X11)  (All rights reserved)
** This is a freeware software (for non commercial use)

Segmentation fault (core dumped)
I am running the Linux x86 version on Ubuntu 6.10.

suki_babee
Posts: 2
Joined: Tue Jun 26, 2007 6:23 pm

seg fault on basic crop too

Post by suki_babee » Tue Jun 26, 2007 6:54 pm

I have not done a lot of testing, but I see that a basic command :

nconvert -crop 0 0 100 100 -o out.jpg orig.jpg

also seg faults on 4.79, but runs fine on 4.51. I can't be the first to notice something like this. Is nconvert dependent on shared libraries? What can I do to help isolate the problem / collect more info ?

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: seg fault on basic crop too

Post by xnview » Wed Jun 27, 2007 6:58 am

suki_babee wrote:I have not done a lot of testing, but I see that a basic command :

nconvert -crop 0 0 100 100 -o out.jpg orig.jpg

also seg faults on 4.79, but runs fine on 4.51. I can't be the first to notice something like this. Is nconvert dependent on shared libraries? What can I do to help isolate the problem / collect more info ?
Ok, i'll update a version...
Pierre.

Post Reply