Page 1 of 1

Resize changes file when image size unchanged

Posted: Sat Mar 05, 2016 1:48 am
by 54pete
Hi, I find that my image files are being updated even though the Resize parameters are greater than or equal to the image size (and I want to decrease only). I'm trying to maintain a folder of smaller images, and only resizing the few that many be occasionally added.

I'm using: nconvert -resize longest 480 -ratio -rflag decr -rtype lanczos -overwrite

All my images are getting 'converted' even though they are all 480 pixels or less. The files change by only a few bytes, sometimes up a bit and sometimes down. The changed files force an unnecessary and undesirable sync/backup process to activate.

I have tried specifying both resize parameters (-resize 480 480). I've tried without -ratio, -rflag and -rtype (and tried different resampling types). All give the same behaviour. I also get a similar result with XnView and XnConvert.

I hope someone can help (most of) my files to remain unchanged. Cheers, Peter

Re: Resize changes file when image size unchanged

Posted: Mon Mar 07, 2016 11:12 am
by xnview
-decr resize or not the picture, but save is always done.