MP0.30 BUG {file index} in fullscreen sometimes incorrect

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Post Reply
thibaud
Posts: 271
Joined: Sat Dec 02, 2006 12:41 am
Contact:

MP0.30 BUG {file index} in fullscreen sometimes incorrect

Post by thibaud » Sat Oct 16, 2010 9:30 pm

small bug:
only in full screen viewer!
the file index is sometimes wrong by a few images when navigating quickly.
if using fullscreen via F11 > viewer on second screen (great never noticed that before :)) then file index is not updated at all.

congrats again and a huge thanks for the tremendous effort you've put in this release Pierre, speed is awesome.
there's some rough edges here and there, but overal it's looking pretty good.

User avatar
xnview
Author of XnView
Posts: 32762
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP0.30 BUG {file index} in fullscreen sometimes incorrec

Post by xnview » Wed Oct 20, 2010 9:14 am

thibaud wrote:small bug:
only in full screen viewer!
the file index is sometimes wrong by a few images when navigating quickly.
I can't reproduce... Do you use 'Read ahead' setting?
And if you are in view mode, press 'I', do you same problem?
if using fullscreen via F11 > viewer on second screen (great never noticed that before :))
what do you have not noticed???
Pierre.

thibaud
Posts: 271
Joined: Sat Dec 02, 2006 12:41 am
Contact:

Re: MP0.30 BUG {file index} in fullscreen sometimes incorrec

Post by thibaud » Wed Oct 20, 2010 11:20 am

xnview wrote:
thibaud wrote:small bug:
only in full screen viewer!
the file index is sometimes wrong by a few images when navigating quickly.
I can't reproduce... Do you use 'Read ahead' setting?
And if you are in view mode, press 'I', do you same problem?
yes I'm using read ahead (which is on by default)
and here is a screenshot of the problem when using "I".
Image
xnview wrote:
thibaud wrote: if using fullscreen via F11 > viewer on second screen (great never noticed that before :))
what do you have not noticed???
being able in a multiple display environment to have the browser on one monitor and the fullscreen view on the other one. that is just great!
however it appeared that this may not have been purposely implemented.(no wonder I wasn't able to find it explicitly referenced in the menu or settings)...
I wasn't able to reproduce that dual display combination until I re-sized the browser windows to overlap both displays, then once the full screen view is opened on one monitor reposition the browser window into the other monitor.
note: again, in that situation the viewer {file index} is indeed not updated at all.
if one thing, that demonstrate that proper multi-display support isn't too far off. and should hopefully be a piece of cake to implement ;)

User avatar
xnview
Author of XnView
Posts: 32762
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP0.30 BUG {file index} in fullscreen sometimes incorrec

Post by xnview » Wed Oct 20, 2010 11:26 am

thibaud wrote: yes I'm using read ahead (which is on by default)
and here is a screenshot of the problem when using "I".
Status bar info is good, right? And if 'read ahead' is off?
Pierre.

thibaud
Posts: 271
Joined: Sat Dec 02, 2006 12:41 am
Contact:

Re: MP0.30 BUG {file index} in fullscreen sometimes incorrec

Post by thibaud » Wed Oct 20, 2010 11:44 am

yes status bar is always right.
if read ahead is off it's less lightly to happen. but I still managed to have a delta of one image in some circumstances: {file index} not updated on animated gif!

User avatar
xnview
Author of XnView
Posts: 32762
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP0.30 BUG {file index} in fullscreen sometimes incorrec

Post by xnview » Thu Oct 21, 2010 4:01 pm

Please check XnViewMP 0.31
Pierre.

thibaud
Posts: 271
Joined: Sat Dec 02, 2006 12:41 am
Contact:

Re: MP0.30 BUG {file index} in fullscreen sometimes incorrec

Post by thibaud » Thu Oct 21, 2010 6:25 pm

works fine now.
even in full screen mode on second monitor.

Post Reply