MP 0.35 crashes when browsing NAS network drives

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Post Reply
redpaprika
Posts: 5
Joined: Wed Jun 01, 2011 9:02 pm

MP 0.35 crashes when browsing NAS network drives

Post by redpaprika » Wed Jun 01, 2011 9:18 pm

Hi,

thanks for your excellent work! I like MP but it allways crashes, when browsing NAS network drives - and I have all my images on NAS network drives. Sometimes XnView MP v0.35 crashes immediately, when I try to enter a directory with images inside, sometimes ony after some clicks. Browsing local drives and network drives on other windows computers never crash. And browsing of the NAS network drives with the "old" XnView works fine. I'm using Windows Vista and NAS network drives from Synology and Buffalo.

The Windows Error is:

Code: Select all

Problemsignatur:
  Problemereignisname:	APPCRASH
  Anwendungsname:	xnview.exe
  Anwendungsversion:	0.0.0.0
  Anwendungszeitstempel:	4d3040b9
  Fehlermodulname:	QtGui4.dll
  Fehlermodulversion:	4.7.1.0
  Fehlermodulzeitstempel:	4ce7c416
  Ausnahmecode:	c0000005
  Ausnahmeoffset:	001530e0
  Betriebsystemversion:	6.0.6002.2.2.0.256.6
  Gebietsschema-ID:	1031
  Zusatzinformation 1:	7d0f
  Zusatzinformation 2:	0e478b232d9dff5c362dbf27eb7248d2
  Zusatzinformation 3:	9c36
  Zusatzinformation 4:	a38052a5b47caecbdca60a25c129600e

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.35 crashes when browsing NAS network drives

Post by xnview » Thu Jun 02, 2011 7:29 pm

Even on a folder with only 1 or 2 file (on your NAS)??
Pierre.

redpaprika
Posts: 5
Joined: Wed Jun 01, 2011 9:02 pm

Re: MP 0.35 crashes when browsing NAS network drives

Post by redpaprika » Fri Jun 03, 2011 7:31 am

Hi!

I tried a few things. The number of images and subfolders doen't seem to be the problem. First I tried to create a folder with only 2 images and I could browse it witout crash. So I tried to find out, up to how many images it works, but there was no direct relation with the number of images. Sometimes 300 images made no problem, sometimes 2 crashed. But then I found out, that folders that were previously opended in Windows Explorer, don't crash MP. Thats why my first try worked, because I copied the images to the new directory with Windows Explorer.
So If I go inside a folder on the NAS with Windows Explorer, this folder (and every subfolder, even if I didn't enter it in Windows Explorer) are safe for MP. Every other folder on the NAS crashes MP until I open it once in Windows Explorer. Rebooting resets this behaviour and again every folder crashes, until once opened outside of MP.

I hope this helps,
Best regards, Andras

User avatar
xnview
Author of XnView
Posts: 33644
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.35 crashes when browsing NAS network drives

Post by xnview » Fri Jun 03, 2011 1:07 pm

i've sent you a PM
Pierre.

Post Reply