Exiftool and filenames with unicode characters

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

herb
Posts: 125
Joined: Sat Jul 18, 2009 3:19 pm

Exiftool and filenames with unicode characters

Postby herb » Sun Sep 20, 2015 5:01 pm

Hello,

this topic is only to inform you, that Exiftool version > 9.79 is able to handle filenames with also unicode characters on windows systems by itself.

Please update to latest Exiftool version.
Instead of sending the windows file-short-name to Exiftool, you have to send the filename UTF-8 encoded to Exiftool.
But you have also to give the option: -charset filename=utf8
To get the real filename also in output of Exiftool will be much better than seeing only the windows file-short-name.

Thanks in advance
Best regards
Herb

herb
Posts: 125
Joined: Sat Jul 18, 2009 3:19 pm

Re: Exiftool and filenames with unicode characters

Postby herb » Tue Feb 09, 2016 1:35 pm

Hello Pierre,

please enhance XnViewMP with next version.
It looks much better, when also Exiftool displays a correct filename instead of the windows short name.

Best regards
Herb

herb
Posts: 125
Joined: Sat Jul 18, 2009 3:19 pm

Re: Exiftool and filenames with unicode characters

Postby herb » Mon Sep 11, 2017 2:41 pm

Hello Pierre,

I still hope that XnViewMP (currently 0.87) will be enhanced, so that Exiftool will display the file-long-name (on windows).

Best regards
Herb


Return to “MP - Suggestions”

Who is online

Users browsing this forum: No registered users and 3 guests