0.90 linux: Google Maps no longer working on ubuntu 18.04

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
rmtk
Posts: 131
Joined: Tue Dec 07, 2010 2:04 am

0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by rmtk » Sun Jun 24, 2018 12:50 pm

I can no longer see Google Maps in GPS tab after I upgraded my OS from 17.10 to 18.04. Please investigate it.
It's unrelated to my settings. I've test it on a clean installed OS.

User avatar
xnview
Author of XnView
Posts: 29884
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by xnview » Mon Jun 25, 2018 2:00 pm

i have not 18.04, do you have message in the terminal?
Pierre.

rmtk
Posts: 131
Joined: Tue Dec 07, 2010 2:04 am

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by rmtk » Tue Jun 26, 2018 5:25 am

Incompatible version of OpenSSL ?

## MyView::onLoaded ok
### resetViewport (323d560) ==> 100 30 (40 30) 0 0
QObject::connect: No such signal GPSMapWidget::reloadMap()
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
qt.network.ssl: QSslSocket: cannot resolve sk_new_null
qt.network.ssl: QSslSocket: cannot resolve sk_push
qt.network.ssl: QSslSocket: cannot resolve sk_free
qt.network.ssl: QSslSocket: cannot resolve sk_num
qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
qt.network.ssl: QSslSocket: cannot resolve sk_value
qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
qt.network.ssl: QSslSocket: cannot resolve SSLeay
qt.network.ssl: QSslSocket: cannot resolve SSLeay_version
qt.network.ssl: QSslSocket: cannot call unresolved function SSLeay
qt.network.ssl: Incompatible version of OpenSSL
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init

User avatar
xnview
Author of XnView
Posts: 29884
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by xnview » Tue Jun 26, 2018 9:14 am

yes it seems
Pierre.

rmtk
Posts: 131
Joined: Tue Dec 07, 2010 2:04 am

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by rmtk » Sun Jul 01, 2018 3:12 pm

will be fix in the next version ?

User avatar
xnview
Author of XnView
Posts: 29884
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by xnview » Mon Jul 02, 2018 9:03 am

rmtk wrote:
Sun Jul 01, 2018 3:12 pm
will be fix in the next version ?
i'll try to put the old opensll library in package
Pierre.

frgo
Posts: 1
Joined: Wed Jul 11, 2018 6:24 am

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by frgo » Wed Jul 11, 2018 6:34 am

Hi,

On manjaro (arch) there is also this QObject::connect: No such signal GPSMapWidget::reloadMap() error and it has nothing to do with OpenSSL.

Code: Select all

# MyView::onLoaded ok 
### resetViewport (28aacb0)  ==> 357 444  (357 267) 0 0
QObject::connect: No such signal GPSMapWidget::reloadMap()
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
qt5ct: D-Bus system tray: no
https://aur.archlinux.org/packages/xnviewmp/

krakatoa_pb
Posts: 3
Joined: Fri Oct 14, 2016 3:40 pm

Re: 0.90 linux: Google Maps no longer working on ubuntu 18.04

Post by krakatoa_pb » Tue Aug 07, 2018 7:10 am

Hi,

I just tested this solution with my Ubuntu 18.04 (x64) and it's works!

apt-get install libssl1.0-dev

(see: https://github.com/wkhtmltopdf/wkhtmltopdf/issues/2938)

Pascal

Post Reply