Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Bugs which are supposed to be fixed in the next test version (not available yet)

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
oakside
Posts: 7
Joined: Thu Nov 07, 2013 7:58 pm

Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by oakside »

Problem:
Images should be showing unscaled (1:1), but are instead showing scaled (downscaled, to about 99%). Scaler has problem or poor quality.

Notes:
Very noticeably degrades quality, especially with text and lines, producing much aliasing. Pressing key shortcut (asterisk) to go to 1:1 scale will bring to proper scale for most images (quality improves immediately), but not for all (see "Spek.png", strange, still aliased text and poor quality). Compared with other image viewers, they do not exhibit problem.

I've tried various HiDPI and scaling settings in XnView (high zoom quality never, lanczos, bicubic, zoom on hidpi, etc). Also forcing alternate DPI settings (via XnViewMP.exe, Properties, Compatibility, Change High DPI, Override, Application). Also tried modifying "Auto Image Size" (problem definitely occurs with "Fit Image to Window, Large Only"). Will try to hunt down the cause more if not related to bug that is already reported and fixed. Thanks for any help with this.

Examples:
Screen 1 (auto fit, 99% scale), Screen 2 (100% scale, manually set 1:1 with "asterisk")
All (Video, Screens, Samples) (MEGA, rar) (video shows once through with auto-fit 99%, then pressing "asterisk" for 100%, then "plus" for 110%)

Specs:
XnView MP 0.98.2 x64 (zip, portable mode)
Windows 10 Pro (20H2, build 19042)
Monitor: Philips 27" UHD (2560x1440, 125% scale)
Last edited by oakside on Tue Apr 13, 2021 10:06 am, edited 1 time in total.
User avatar
xnview
Author of XnView
Posts: 35069
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by xnview »

I can't reproduce on HiDPI screen with scaling of 125%, do you have same problem with 'High zoom quality' => 'Zoom in&Zoom out' + bilinear?
The problem is only viewing at 99%?
And if you use 100% for font scaling?
Do you have same problem with 0.98.1?
Pierre.
User avatar
oakside
Posts: 7
Joined: Thu Nov 07, 2013 7:58 pm

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by oakside »

xnview wrote: Mon Apr 12, 2021 1:15 pm I can't reproduce on HiDPI screen with scaling of 125%, do you have same problem with 'High zoom quality' => 'Zoom in&Zoom out' + bilinear?
The problem is only viewing at 99%?
And if you use 100% for font scaling?
Do you have same problem with 0.98.1?
Thanks for taking a look at this, Pierre. And for all your work on the fantastic XnView.

1. Bilinear looks much better (high quality, in/out), just a bit soft, but no aliasing. (I tried many combos, maybe I missed that one, apologies!)
Will use that for now. All the others are downscaling poorly for some reason? (I usually use Lanczos with most apps, XnView batch convert.)

So perhaps this is actually two problems?

2. Images displaying at 99.?% scale, when "Auto Image Size" set (Fit to Window, Large Only). If switched to "No Fit", images display fine (at 100% scale, scaling now properly off). Will disable that for now. Note: Any downscaling still poor quality (if not using bilinear).

Hopefully the source of these problems can be found, and next XnView version I can use sharper scaling (lanczos/spline), plus enable "Auto Image Size again.

Update: Same problems with 0.98.1, no problems with 0.98. Related: Maybe this or this (both over at "Retest"). Note: I've been using XnView MP for years, maybe time for a settings reset (but that won't be fun, only if necessary).
User avatar
xnview
Author of XnView
Posts: 35069
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by xnview »

oakside wrote: Mon Apr 12, 2021 5:25 pm 1. Bilinear looks much better (high quality, in/out), just a bit soft, but no aliasing. (I tried many combos, maybe I missed that one, apologies!)
Will use that for now. All the others are downscaling poorly for some reason? (I usually use Lanczos with most apps, XnView batch convert.)
:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
2. Images displaying at 99.?% scale, when "Auto Image Size" set (Fit to Window, Large Only). If switched to "No Fit", images display fine (at 100% scale, scaling now properly off). Will disable that for now. Note: Any downscaling still poor quality (if not using bilinear).
:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
oakside
Posts: 7
Joined: Thu Nov 07, 2013 7:58 pm

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by oakside »

xnview wrote: Wed Apr 14, 2021 2:30 pm :bugconfirmed: Thanks to your detailed description I can reproduce the problem.
That's just amazing. Bugs squashed (or collected and put outside). Thank you for caring! Can't wait for 0.98.3.
User avatar
xnview
Author of XnView
Posts: 35069
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.98.3. Please check and confirm the bug fix here.
Pierre.
User avatar
oakside
Posts: 7
Joined: Thu Nov 07, 2013 7:58 pm

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by oakside »

Thank you for 0.98.3!

The good news is the scaling quality is much better. Used my test images to verify. :D

The bad news is images are still very slightly scaled (99.x%) for some reason, as described before. Just higher quality and less noticeable since scaling is now much improved. Verified by using my test images, pressing "asterisk" to go to 100%, which clearly shows change in image. when they should be untouched. Notes: Same behavior as described before, and in my test video. Same settings: Auto Image Size, Fit to Window, Large Only. Test images are much smaller res than window, should display perfectly 1:1 unscaled. :?

Edit: Maybe related, noticed my test images (except spek.png) seem like they are being slightly cropped when this occurs, maybe due to resolution (tiny, and not even mod2). I will need to test a lot more over the next few weeks to see just how many images are affected, but does not look like many right now.
User avatar
xnview
Author of XnView
Posts: 35069
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Scaling Problems (Aliasing, Poor Quality, Not 1:1)

Post by xnview »

oakside wrote: Thu May 06, 2021 9:21 pm The bad news is images are still very slightly scaled (99.x%) for some reason, as described before. Just higher quality and less noticeable since scaling is now much improved. Verified by using my test images, pressing "asterisk" to go to 100%, which clearly shows change in image. when they should be untouched. Notes: Same behavior as described before, and in my test video. Same settings: Auto Image Size, Fit to Window, Large Only. Test images are much smaller res than window, should display perfectly 1:1 unscaled. :?

Edit: Maybe related, noticed my test images (except spek.png) seem like they are being slightly cropped when this occurs, maybe due to resolution (tiny, and not even mod2). I will need to test a lot more over the next few weeks to see just how many images are affected, but does not look like many right now.
:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
Post Reply