0.12: Wrong IPTC text encoding displayed

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

0.12: Wrong IPTC text encoding displayed

Post by Jarda » Fri Nov 28, 2008 3:25 pm

I use Czech MS Windows 2000 with CP-1250 as default charset and XnView 1.95.4 as default image viewer. So I add into JPGs file IPTC field (e.g. Caption) any Czech text and save. In XnView 1.95.4 is the typed caption text displayed correctly unlike in XnViewMP 0.12. I think XNViewMP expected UTF-8 so all the Czech chars upon basic ASCII are poorly displayed.

Note: Similar bug appears in XnView for Windows when I use the option "Update or create XMP" from present IPTC field text.

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.12: Wrong IPTC text encoding displayed

Post by xnview » Fri Nov 28, 2008 4:06 pm

Jarda wrote:I use Czech MS Windows 2000 with CP-1250 as default charset and XnView 1.95.4 as default image viewer. So I add into JPGs file IPTC field (e.g. Caption) any Czech text and save. In XnView 1.95.4 is the typed caption text displayed correctly unlike in XnViewMP 0.12. I think XNViewMP expected UTF-8 so all the Czech chars upon basic ASCII are poorly displayed.

Note: Similar bug appears in XnView for Windows when I use the option "Update or create XMP" from present IPTC field text.
Right MP use UTF-8, so perhaps an option to choose the charset???
Pierre.

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Re: 0.12: Wrong IPTC text encoding displayed

Post by Jarda » Fri Nov 28, 2008 8:34 pm

xnview wrote:
Jarda wrote:I use Czech MS Windows 2000 with CP-1250 as default charset and XnView 1.95.4 as default image viewer. So I add into JPGs file IPTC field (e.g. Caption) any Czech text and save. In XnView 1.95.4 is the typed caption text displayed correctly unlike in XnViewMP 0.12. I think XNViewMP expected UTF-8 so all the Czech chars upon basic ASCII are poorly displayed.

Note: Similar bug appears in XnView for Windows when I use the option "Update or create XMP" from present IPTC field text.
Right MP use UTF-8, so perhaps an option to choose the charset???
The option to choose the charset would be great (ideal) solution (not only in XnView MP but in "classic" XnView for creating XMP from IPTC field also)!

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.12: Wrong IPTC text encoding displayed

Post by xnview » Sat Nov 29, 2008 1:10 pm

Sorry i'm wrong, XnViewMP use local charset so perhaps a problem in 0.12
Pierre.

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Re: 0.12: Wrong IPTC text encoding displayed

Post by Jarda » Sun Nov 30, 2008 6:44 pm

xnview wrote:Sorry i'm wrong, XnViewMP use local charset so perhaps a problem in 0.12
Strange... Not all Czech chars are broken but please take a look here:

http://www.asmodeus.info/text/testarea/ ... ew1954.png
(correctly displayed IPTC caption field text in XnView 1.95.4)

http://www.asmodeus.info/text/testarea/ ... viewmp.png
(IPTC caption text displayed incorrectly in XnView MP 0.12)

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.12: Wrong IPTC text encoding displayed

Post by xnview » Mon Dec 01, 2008 7:26 am

Jarda wrote:
xnview wrote:Sorry i'm wrong, XnViewMP use local charset so perhaps a problem in 0.12
Strange... Not all Czech chars are broken but please take a look here:
Ok, in the tooltips, but in the iptc panel, encoding is correct?
Pierre.

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Re: 0.12: Wrong IPTC text encoding displayed

Post by Jarda » Mon Dec 01, 2008 8:47 am

xnview wrote:
Jarda wrote:
xnview wrote:Sorry i'm wrong, XnViewMP use local charset so perhaps a problem in 0.12
Strange... Not all Czech chars are broken but please take a look here:
Ok, in the tooltips, but in the iptc panel, encoding is correct?
In the panel is displayed in the same way as in tooltip.

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.12: Wrong IPTC text encoding displayed

Post by xnview » Mon Dec 01, 2008 8:48 am

Jarda wrote:
xnview wrote:
Jarda wrote: Strange... Not all Czech chars are broken but please take a look here:
Ok, in the tooltips, but in the iptc panel, encoding is correct?
In the panel is displayed in the same way as in tooltip.
Could you contact me by email?
Pierre.

Jarda
Posts: 22
Joined: Sat Jun 14, 2008 4:41 pm

Re: 0.12: Wrong IPTC text encoding displayed

Post by Jarda » Mon Dec 01, 2008 5:58 pm

xnview wrote: Could you contact me by email?
Ok, You have new mail with screenshot :)

Post Reply