Metadata icons shown after cleaning

*** Please report new bugs here! ***

Moderator: Dreamer

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Metadata icons shown after cleaning

Post by marsh » Wed Oct 07, 2009 11:09 am

The extra data icons (thumb,icc, xmp, iptc, exif) are shown after all metadata has been cleaned and program restarted. Thumbnail caching disabled. Optimize thumb db corrects this, but it is unexpected.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Metadata icons shown after cleaning

Post by xnview » Wed Oct 07, 2009 11:18 am

When you use Clean dialog?
Pierre.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Metadata icons shown after cleaning

Post by marsh » Wed Oct 07, 2009 11:21 am

xnview wrote:When you use Clean dialog?
In thumbnails view with only browser visible. All items checked except optimize.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Metadata icons shown after cleaning

Post by xnview » Wed Oct 07, 2009 11:23 am

marsh wrote:
xnview wrote:When you use Clean dialog?
In thumbnails view with only browser visible. All items checked except optimize.
Sorry but i don't understand :-)
Pierre.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Metadata icons shown after cleaning

Post by marsh » Wed Oct 07, 2009 11:34 am

xnview wrote:
marsh wrote:
xnview wrote:When you use Clean dialog?
In thumbnails view with only browser visible. All items checked except optimize.
Sorry but i don't understand :-)
Only some of the overlay icons are updated immediately after using clean metadata. The images have no metadata after cleaning, but the thumbnails still show all the little info icons at bottom after restarting program. All looks normal after erasing db file.

User avatar
helmut
Posts: 8171
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Metadata icons shown after cleaning

Post by helmut » Mon Feb 20, 2017 10:15 pm

Problem still exists in v0.84:
When cleaning a JPG file with EXIF information and embedded thumbnail, the overlay icons "Embedded thumbnail" and "EXIF rotation" are still shown although the image has been cleaned.

To reproduce:

1. In browser, navigate to a folder with an image that has EXIF metadata (embedded thumbnail, EXIF rotation, ...)
2. In browser, select "Tools > Meta data > Clean...".
3. In "Clean metadata" dialog check all checkboxes and confirm with "OK".
Actual behaviour (bug): Browser still shows overlay icons for "Embedded thumbnail" and "EXIF rotation". :bugfixed:

Expected behaviour: No overlay icons since all metadata has been removed from the image.

A refresh using F5 key doesn't refresh. When browsing a different folder and then returning to the folder, then, the overlay icons are no longer shown.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Metadata icons shown after cleaning

Post by xnview » Tue Feb 28, 2017 2:52 pm

helmut wrote:Problem still exists in v0.84:
you can reproduce it each time? the icons are no more here after a clean
Pierre.

User avatar
helmut
Posts: 8171
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Metadata icons shown after cleaning

Post by helmut » Tue Feb 28, 2017 5:13 pm

xnview wrote:
helmut wrote:Problem still exists in v0.84:
you can reproduce it each time? the icons are no more here after a clean
Yes, I can reproduce this all the time. Exact steps are written above.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Metadata icons shown after cleaning

Post by xnview » Tue Feb 28, 2017 7:08 pm

helmut wrote:
xnview wrote:
helmut wrote:Problem still exists in v0.84:
you can reproduce it each time? the icons are no more here after a clean
Yes, I can reproduce this all the time. Exact steps are written above.
on Windows 10?
Pierre.

User avatar
helmut
Posts: 8171
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Metadata icons shown after cleaning

Post by helmut » Tue Feb 28, 2017 8:01 pm

xnview wrote:on Windows 10?
Yes, on Windows 10 64 bit.

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Metadata icons shown after cleaning

Post by xnview » Wed Mar 01, 2017 8:30 am

helmut wrote:
xnview wrote:on Windows 10?
Yes, on Windows 10 64 bit.
i remember that i had this problem sometimes, but currently i'm not able to reproduce :(
i've tried on slow or fast drive...
Pierre.

User avatar
helmut
Posts: 8171
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Metadata icons shown after cleaning

Post by helmut » Wed Mar 01, 2017 8:58 pm

xnview wrote:i remember that i had this problem sometimes, but currently i'm not able to reproduce :(
i've tried on slow or fast drive...
Perhaps the attached JPEG image (zipped) let's you reproduce the problem. It has an embedded thumbnail, XMP, ITPC, and EXIF data.
Attachments
Metadata.zip
(30.41 KiB) Downloaded 32 times

User avatar
XnTriq
Moderator & Librarian
Posts: 5447
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Metadata icons shown after cleaning

Post by XnTriq » Wed Mar 01, 2017 9:15 pm

Confirmed for v0.84 32-bit Windows (“Embedded thumbnail” + “EXIF orientation”)

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Metadata icons shown after cleaning

Post by xnview » Mon Jun 12, 2017 3:33 pm

i've re-tried this bug, but can't reproduce it
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5447
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Metadata icons shown after cleaning

Post by XnTriq » Tue Jun 20, 2017 9:00 pm

xnview wrote:i've re-tried this bug, but can't reproduce it
Did you also do a test with deactivated cache, Pierre?

Post Reply