Page 1 of 2

MP 0.35 Win: Layout not remembered

Posted: Sun Mar 20, 2011 7:40 am
by Gingerbread Guy
XnView MP won't remember the custom layout I choose. The width of the thumbnails column always resets to about half the window size after restarting. Choosing to store the settings as either INI or registry made no difference. Is this a known issue?

Re: MP 0.35 Win: Layout not remembered

Posted: Sun Mar 20, 2011 8:50 am
by xnview
do you start XnViewMP in maximized state?

Re: MP 0.35 Win: Layout not remembered

Posted: Sun Mar 20, 2011 5:37 pm
by Gingerbread Guy
The window fills the screen, but the shortcut is set to "Normal window".

Re: MP 0.35 Win: Layout not remembered

Posted: Mon Mar 21, 2011 8:07 am
by xnview
there is a little issue if XnView is started maximized...

Re: MP 0.35 Win: Layout not remembered

Posted: Mon Mar 21, 2011 5:05 pm
by Gingerbread Guy
So then the answer is yes, this is a known issue, and it will be fixed at some point in the future?

Re: MP 0.35 Win: Layout not remembered

Posted: Mon Mar 21, 2011 8:05 pm
by xnview
yes :)

Re: MP 0.35 Win: Layout not remembered

Posted: Mon Mar 21, 2011 9:31 pm
by Gingerbread Guy
Great, thank you :)

Re: MP 0.35 Win: Layout not remembered

Posted: Wed Mar 23, 2011 12:21 am
by Gingerbread Guy
Bad news. I've given XnViewMP another go, this time making sure the window is not maximized. Same result. Screenshots to illustrate:
desired_layout.png
How I want the layout.
desired_layout.png (81.22 KiB) Viewed 2459 times
after_restart.png
How it ends up after restarting XnViewMP.
after_restart.png (115.23 KiB) Viewed 2459 times

Re: MP 0.35 Win: Layout not remembered

Posted: Wed Mar 23, 2011 2:04 pm
by JohnFredC
In my experience, some of the layouts do not remember the Preview splitter position.

I haven't confirmed this for all layouts, but if one designs a custom layout with the preview panel at the top and the thumbs at the bottom, then the splitter position between the preview and the thumbs is not correctly restored between MP sessions.

Re: MP 0.35 Win: Layout not remembered

Posted: Tue Apr 05, 2011 12:54 pm
by Gingerbread Guy
No comment from the author, especially since another user noticed the same issue? :(

Looking back at my screenshot, I see another potential bug in there. Look at the Japanese text: XnViewMP doesn't use the appropriate font. Compare with XnView started through AppLocale (because it doesn't support Unicode): the font is the same as in Windows Explorer.
XnView_Japanese.png
XnView_Japanese.png (17.3 KiB) Viewed 2231 times

Re: MP 0.35 Win: Layout not remembered

Posted: Tue Apr 05, 2011 2:27 pm
by JohnFredC
Gingerbread Guy wrote:No comment from the author, especially since another user noticed the same issue? :(
I'm sure Pierre will get to it eventually. He's just one guy and there are many issues more important to address before the layout splitter position.

Re: MP 0.35 Win: Layout not remembered

Posted: Tue Apr 05, 2011 8:31 pm
by xnview
Gingerbread Guy wrote:No comment from the author, especially since another user noticed the same issue? :(
Sorry, i'll check asap...

Re: MP 0.35 Win: Layout not remembered

Posted: Fri Jun 17, 2011 1:58 pm
by xnview
Ok, i can reproduce, i'll fix it

Re: MP 0.35 Win: Layout not remembered

Posted: Wed Jul 13, 2011 12:35 pm
by xnview
Please check XnViewMP 0.38

Re: MP 0.35 Win: Layout not remembered

Posted: Thu Jul 14, 2011 12:56 am
by JohnFredC
Based on my initial (but not exhaustive) testing, this appears to be fixed in 0.38.