Page 1 of 1

0.48 win-x86: Zoom bug with mouse-scroll after file launch

Posted: Sat May 19, 2012 3:10 am
by budz45
Hi,

Windows 7 sp1

here is my reproduction steps;

1.) Run a 'clean' XnView MP 0.48
2.) Go to Settings>Keyboard/Mouse and set the 'Zoom in/out' for "mouse wheel"...
3.) ..Now go to Settings>General and disable the setting "Fullscreen when starting with a file"...
4.) Now Press "Ok" on 'Settings'
3.) In the 'Browser', open any image file to open in the view mode
3.) Close 'Browser' tab
4.) Make sure on your system that .jpg files is already associated to open with XnViewMP (file association tool)
5.) In Windows Explorer double-click on the "Am76I8rCQAAFlyj.jpg" file to open...
6.) ..File opens as normal in XnViewMP with XnViewMP window displaying as foreground program window as normal...BUT...
7.) ..Immediately try to Zoom in/out with Mouse-wheel and the Zoom feature does not respond

Make sure that at step 6 (above) you Zoom immediately with your Mouse-scroll as soon as the picture is opened and nothing else.

I have attached the picture as a ZIP
Am76I8rCQAAFlyj.zip
(118.47 KiB) Downloaded 76 times
----------------------------------------------------------------------------------
Note: This issue affects any image files opened from Win Explorer/external file manager. I certainly believe that the reason for this bug is simply a fix needed for the file-opening method (file---> xnview.exe)

Note: There is thankfully no bug with the middle-click (Fullscreen command) when doing the same (step 7) reproduction. :D

Note: Hmm... this same Zoom bug issue does not exist on same XnView MP when opening the same file from "Recent files" :D -nice

Note: This bug issue does not exist on XnView win 1.9x after doing the same reproduction tests :)

----------------------------------------------------------------------------------
So all in all in summary, the Mouse-scroll wheel is not getting detected immediately for the Zoom command(s) (when laucngin picture file from Win Explorer) since a user would have to click on the opened picture first or do some other program action first before the Mouse-wheel function gets detected to be used. So this needs a fix.
----------------------------------------------------------------------------------

Please investigate and fix.

Re: 0.48 win-x86: Slight Zoom bug after Win Explorer file la

Posted: Sat May 19, 2012 2:08 pm
by RickS
I can't duplicate on my Win XP netbook. No problem in zooming your file opened in Windows Explorer after following your routine.

Re: 0.48 win-x86: Zoom bug with mouse-scroll after file laun

Posted: Sat May 19, 2012 2:52 pm
by budz45
RickS wrote:I can't duplicate on my Win XP netbook. No problem in zooming your file opened in Windows Explorer after following your routine.
Oooops :wink: sorry I meant the problem is Zooming with the Mouse-scroll...Right, I will edit the original post topic along with topic rename. Please try reproduction again.

Re: 0.48 win-x86: Zoom bug with mouse-scroll after file laun

Posted: Sat May 19, 2012 4:43 pm
by RickS
Oooops :wink: sorry I meant the problem is Zooming with the Mouse-scroll...Right, I will edit the original post topic along with topic rename. Please try reproduction again.
I already had those settings, but I tried again with different zoom parameters. Still works OK here. I tried this on both my Win XP and Win 7 machines and using your file.
I just can't duplicate your results.

Re: 0.48 win-x86: Zoom bug with mouse-scroll after file laun

Posted: Sat May 19, 2012 6:42 pm
by budz45
The issue does exist. :(

On my system, I think this might be caused by two possible things:
- The "Single view for multi-opened files" is enabled
- Qt issue

Right, could you guys Enable the setting "Single view for multi-opened files" and then try the reproduction again??
------------------------------------

Here is a new amended reproduction;

1.) Run a 'clean' XnView MP 0.48
2.) Go to Settings>Keyboard/Mouse and set the 'Zoom in/out' for "mouse wheel"...
3.) Go to Settings>Interface and enable the "Single view for multi-opened files" setting
4.) ..Now go to Settings>General and disable the setting "Fullscreen when starting with a file"...
5.) ..Also in Settings>General enable the setting "One instance of program only" press "Ok" on restart prompt...
6.) ..Now Press "Ok" on 'Settings' and close XnViewMP program
7.) Start XnViewMP again
8.) From the 'Browser', open any image file to open in the view mode
9.) Close 'Browser' tab (but keep opened view tab open)
10.) Make sure on your system that .jpg files is already associated to open with XnViewMP (file association tool)
11.) In Windows Explorer double-click on the "Am76I8rCQAAFlyj.jpg" file to open...
12.) ..File opens as normal in XnViewMP with XnViewMP window displaying as foreground program window as normal...BUT...
13.) ..Immediately try to Zoom in/out with Mouse-wheel and the Zoom feature does not respond


If you then try this same reproduction again with "Single view for multi-opened files" disabled then the Zoom bug does occur :)

Re: 0.48 win-x86: Zoom bug with mouse-scroll after file laun

Posted: Wed May 23, 2012 8:12 am
by xnview
budz45 wrote: 1.) Run a 'clean' XnView MP 0.48
2.) Go to Settings>Keyboard/Mouse and set the 'Zoom in/out' for "mouse wheel"...
3.) Go to Settings>Interface and enable the "Single view for multi-opened files" setting
4.) ..Now go to Settings>General and disable the setting "Fullscreen when starting with a file"...
5.) ..Also in Settings>General enable the setting "One instance of program only" press "Ok" on restart prompt...
6.) ..Now Press "Ok" on 'Settings' and close XnViewMP program
7.) Start XnViewMP again
8.) From the 'Browser', open any image file to open in the view mode
9.) Close 'Browser' tab (but keep opened view tab open)
10.) Make sure on your system that .jpg files is already associated to open with XnViewMP (file association tool)
11.) In Windows Explorer double-click on the "Am76I8rCQAAFlyj.jpg" file to open...
12.) ..File opens as normal in XnViewMP with XnViewMP window displaying as foreground program window as normal...BUT...
13.) ..Immediately try to Zoom in/out with Mouse-wheel and the Zoom feature does not respond
If you drag&drop a file, same problem? Or File/Open?

Re: 0.48 win-x86: Zoom bug with mouse-scroll after file laun

Posted: Wed May 23, 2012 11:41 am
by budz45
xnview wrote: If you drag&drop a file, same problem? Or File/Open?


No :) the problem does not exist when you drag&drop to view mode or when you File>Open

The issue only happens with double-click on file (from Win Explorer)