Page 1 of 1

Posted: Fri Jul 20, 2012 2:18 pm
by ueliash
I installed XnViewMP-051 to a new Fedora 17 and get
[elias@localhost ~]$ XnView/
/home/elias/XnView/XnView: error while loading shared libraries: cannot open shared object file: No such file or directory

In fact, a newer version is installed in Fedora 17:
[root@localhost lib]# rpm -q libpng
[root@localhost lib]# ls -l /usr/lib/libpng*
lrwxrwxrwx. 1 root root 19 Jul 19 15:05 /usr/lib/ ->
lrwxrwxrwx. 1 root root 19 Jul 20 15:56 /usr/lib/ ->
lrwxrwxrwx. 1 root root 19 Jul 19 15:03 /usr/lib/ ->
-rwxr-xr-x. 1 root root 183712 Apr 7 21:28 /usr/lib/
lrwxrwxrwx. 1 root root 11 Jul 19 15:05 /usr/lib/ ->

I tried
ln -s
but then the result was
[elias@localhost ~]$ XnView/
/home/elias/XnView/XnView: /lib/ version `PNG12_0' not found (required by /home/elias/XnView/lib/

Any solution?
U Elias


Posted: Sat Jul 21, 2012 11:35 am
by xnview
you can't install libpng 1.2?


Posted: Thu Jul 26, 2012 6:21 pm
by ueliash
I seems complicated to unistall libpng15. I tried
> sudo rpm -e libpng-1.5.10-1.fc17.i686
error: Failed dependencies: is needed by (installed) gdk-pixbuf2-2.26.1-1.fc17.i686 is needed by (installed) cairo-1.10.2-7.fc17.i686 is needed by (installed) cairo-gobject-1.10.2-7.fc17.i686 is needed by (installed) cups-libs-1:1.5.2-12.fc17.i686 is needed by (installed) libpng-devel-2:1.5.10-1.fc17.i686
and so on ...
Perhaps I shall wait to the next release.


Posted: Fri Jul 27, 2012 4:59 am
by MaxSt
ueliash wrote:I seems complicated to unistall libpng15.
You don't need that. You need to install libpng12.