0.51 win-x86: File(s) with Apostrophe in filenames

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

0.51 win-x86: File(s) with Apostrophe in filenames

Post by budz45 » Fri Nov 02, 2012 1:11 am

Hi,

There is a serious issue I just discovered when I double-click on a .jpg file in Win Explorer to open in XnViewMP that has the apostrophe character in filename ' '

The file cannot open. However when apostrophe is removed form filename then the file can open.

For example, download this attached file and double-click on the file in win explorer to open in MP. The file does not open
example picture.zip
(22.2 KiB) Downloaded 66 times
XnView win 1.9x does not have this issue.

This is important to fix. Thanks Pierre.
Last edited by budz45 on Thu Jan 10, 2013 11:51 pm, edited 1 time in total.
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: 0.51 win-x86: File(s) with Apostrophe in filenames

Post by budz45 » Wed Dec 26, 2012 8:06 pm

This issue still exists in 0.53 :(

To reproduce, you must drag & drop the file onto xnview.exe for the file to open but it is not getting opened in View simply because the filename contains apostrophe. This issue does not exist with XnView 1.9x (drag&drop to exe).

Ok the problem affects filenames with apostrophe at the beginning and end of filename

e.g. filename

Code: Select all

'cars123'.jpg
e.g. filename

Code: Select all

'babies in the office' addison lee_2mn45sec.png
Please fix.
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.51 win-x86: File(s) with Apostrophe in filenames

Post by xnview » Wed Apr 10, 2013 9:30 am

Ok, a bug in Qt, i contact them...
Pierre.

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: 0.51 win-x86: File(s) with Apostrophe in filenames

Post by budz45 » Sun Apr 21, 2013 10:27 pm

xnview wrote:Ok, a bug in Qt, i contact them...
Pierre, this is a serious Qt bug. Yes I hope you contacted them about this or else some XnView users that are creative in renaming of photos are going to be quite disappointed.

Thank you Pierre for cooperatively identifying this issue.
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: 0.51 win-x86: File(s) with Apostrophe in filenames

Post by budz45 » Fri Jun 21, 2013 3:16 pm

In 0.56,

This issue is now resolved for opening an image to view from Recent files, Browser, Drag & drop to view :) ...

...HOWEVER this issue still persists with opening the image with xnview.exe (double-click on file from Win Explorer or drag & drop file to xnview.exe)
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: 0.51 win-x86: File(s) with Apostrophe in filenames

Post by budz45 » Fri Feb 21, 2014 6:13 am

budz45 wrote: ...HOWEVER this issue still persists with opening the image with xnview.exe (double-click on file from Win Explorer or drag & drop file to xnview.exe)
Please fix :(

This last issue still exists in 0.64 when I open with xnview.exe and when I drag & drop file to xnview.exe :(
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.51 win-x86: File(s) with Apostrophe in filenames

Post by xnview » Fri Feb 21, 2014 9:14 am

currently Qt has not yet fix this issue :(
Pierre.

Post Reply