Ratings and Labels Disappear

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

fjsaral
Posts: 2
Joined: Thu Aug 15, 2013 7:56 am

Ratings and Labels Disappear

Post by fjsaral »

I have an extensive video clip library of video tutorials which I need to manage, organize, view, and export files temporarily (drag & drop) to work on them with external software. Over time I have purchased (and now I own) ACDSee Pro, Lightroom, Media Pro, iMatch and many others. It turns out that XnView (especially XnViewMP) is the best among them for video, and so far it’s free! It does not choke up with large video files, it has a nice viewer, and some important organizational features. Unfortunately, there are a couple features that don’t work as expected.

The problems are with rating and labeling the files. The ratings and labels don’t stick no matter what work around I’ve tried. I’ve heard others having similar troubles with different workflows, but mine I believe is straight forward. If I select the Catgories panel exclusively and then select categories or tags they are fine; they don’t disappear. But after having about 40 or more images or videos in a folder, ratings and labels disappear. The categories stick. For such a nice piece of software, categorizing is absolutely crucial, and I’ve made it part of my regular workflow. My workaround is to define the ratings as categories, which is not as useful because they are not visible. I am using XnViewMP 0.61, because XnView does not possess the ability to ‘AND’ two or more categories. Note that the rating for the first few files in a folder work perfectly. It’s the ones further down. Perhaps you have some ideas. Thank you very much.
piXuniverse
Posts: 23
Joined: Sat Jul 27, 2013 2:13 pm

Re: Ratings and Labels Disappear

Post by piXuniverse »

This problem might be related in some way to my "bug report" here:
http://newsgroup.xnview.com/viewtopic.php?f=62&t=28484

The developer said he cannot reproduce it, i hope maybe your bug report is more reproducible and we can get this bug fixed, since it does seem to be a bug after all, not only a problem i had.
User avatar
SethP
Posts: 4
Joined: Fri Sep 27, 2013 9:19 pm
Location: Sweden

Re: Ratings and Labels Disappear

Post by SethP »

I had the problem with ratings disappearing, but I guess I found out how to stop them from disappearing. I just send ratings and colour codings to XMP.

How: Options, Metadata, check Export ratings to XMP-metadata, check Export colour code to XMP-metadata and check Write commentary in XMP. (I'm using a Swedish translation but I guess you'll find the right checkboxes to mark/check.)

Now I'm not sure this will work in the long run since I just made these changes, but it seems to be working at least.

But another bug (or annoyance) is that ratings doesn't always show. Sometimes they don't appear in the preview panel but mostly they don't show up when I double-click an image and get it in a View tab (and then in Full screen), especially when dealing with raw images (.rw2 (Panasonic) in my case). Strangely enough they (the ratings) seem to show/appear when I right-click and choose Open or Full screen from there instead?

Im using XnView MP v0.61 in a 64 bit Windows 7 (fully updated) environment.

Edit:
Since this is my first contribution to this forum I want to say thanx for a pretty good program though. :wink:

Edit2:
God'damn! :shock: Just now all of my ratings went down the drain. And they didn't show up again even after I restarted XnView MP. Edit again: Well, not exactly all of them, for now. Just the ones I rated after changing options to Export ratings to XMP.
User avatar
xnview
Author of XnView
Posts: 39371
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and Labels Disappear

Post by xnview »

SethP wrote: Edit2:
God'damn! :shock: Just now all of my ratings went down the drain. And they didn't show up again even after I restarted XnView MP. Edit again: Well, not exactly all of them, for now. Just the ones I rated after changing options to Export ratings to XMP.
And the rating are in XMP data?
Pierre.
User avatar
SethP
Posts: 4
Joined: Fri Sep 27, 2013 9:19 pm
Location: Sweden

Re: Ratings and Labels Disappear

Post by SethP »

I'll check that and get back to you.

(Unfortenately my modem broke a couple of days ago so now I'm posting at work. But I'll get back to you when I get new hardware, which should be on Thursday or Friday... if I'm "lucky".)
Gérard 91
Posts: 89
Joined: Wed Sep 23, 2009 8:33 pm

Re: Ratings and Labels Disappear

Post by Gérard 91 »

Hi,
rw2 files : the problem is for all Raw files. It's not possible to write IPTC/XMP data in . Labels and ratings are in Xnview Database . So, if Data base problems occurs, labels and ratings loss are possible.
In Jpeg , in case of Data base problem (delete, crashes...) , you still have these informations in files and Xnview MP read them. This, of course, if you don't forget to check the right option before tag (like me the first time!).
Once, I have been afraid, Xnview didn't show theses informations. But after closing and reopening the program, they were still there.
When tagging and rtagging many times files in the same dierctory I have had some inexplicable crashs and noticed that artefact happened between two.

Happily, I must say to never notice any damaged or lost file ! Thank's Pierre.

Gérard
User avatar
SethP
Posts: 4
Joined: Fri Sep 27, 2013 9:19 pm
Location: Sweden

Re: Ratings and Labels Disappear

Post by SethP »

Pierre:
What then does "Export ratings to XMP-metadata" mean? :?
I thought that checking that option would make the ratings more stable.. or something like that.

Gérard91:
I just have to ask what you mean with "check the right option before tag"?
User avatar
xnview
Author of XnView
Posts: 39371
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and Labels Disappear

Post by xnview »

SethP wrote: What then does "Export ratings to XMP-metadata" mean? :?
I thought that checking that option would make the ratings more stable.. or something like that.
If the format support it (JPEG, PNG), rating are exported in XMP Metadata, so in the file, and not only in Database
Pierre.
Gérard 91
Posts: 89
Joined: Wed Sep 23, 2009 8:33 pm

Re: Ratings and Labels Disappear

Post by Gérard 91 »

Hi SethP!
Sorry I haven't seen your message till now.
I mean : cheking the right box in Tools (via F12)/Metadata/IPTC & XMP/export label and rating to XMP (or something close to that, I have a french Version)
Cordialement
Gérard 91
Posts: 89
Joined: Wed Sep 23, 2009 8:33 pm

Re: Ratings and Labels Disappear

Post by Gérard 91 »

For Pierre ..... about display problem of rating (and label)

There are some post about that problem and I noticed it some times and this morning too.
After directory opening, XnView doesn't display picture's rating although they were tagged (in XMP see screen save1http://www.si-mage.fr/telechargements/T ... isible.jpg). I tried to close and launch XnView two times, try to refresh, impossible to get the rating upon the thumbnail.
I renamed the directory, and had already Label displayed (see screen save2 http://www.si-mage.fr/telechargements/T ... isible.JPG).

I suppose metadata corresponding to that directory were affected. So renaming the directory probably refreshes data.

I didn't noticed precisely what I have done before in that directory. I just remember I had created new files with Photoshop launching original from XnView (I don't remember if Xnview crash occurred or not during that job)

Having no idea how to reproduce the problem and help to identify reasons, I suggest Pierre :
1) to explain precisely how the program proceed to record information (write and rewrite meta) in order to avoid some mistaken operation.
2) give an option to refresh database for a directory (including subdirectories) based on embedded XMP, even if it's necessary to wait end of that process in order to go on.
This are just suggestion
Bien cordialement
Gérard
User avatar
xnview
Author of XnView
Posts: 39371
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and Labels Disappear

Post by xnview »

There is one bug, if XnView has not finished to read metadata from a folder, and you use viewer, some rating/label can be wrong

If this happens, you can remove the folder from database in options>database
Pierre.
Gérard 91
Posts: 89
Joined: Wed Sep 23, 2009 8:33 pm

Re: Ratings and Labels Disappear

Post by Gérard 91 »

Hi Pierre,
Thanks for your answer. I do remove the directory which was orphan.

It seems at the moment I have some surprising behaviour, similar as some reported on the forum but I am not sure to understand well what is done by each option of this box
I am probably a little bit dummy, so in order to progress some questions:

- Are IPTC/XMP data stored with thumbnails or separately ?
- So when thumbnails rebuild button is launch, are embedded data (IPTC & XMP in files) verified and updated in database ?
- Why excluded Directories (in second tab) are still present (in the first tab)
- What should happen when remove a directory in first tab (it seems to be erase but still there when re-opening the box with same files number)
- what is expected for each optimise option

Perhaps we are too much (so I am) demanding with you but it would be nice to have explanation !
I suggest you use a sticky post to explain implemented special function (id difficult to guess) as metadata, you may update from time to time. It would be better to differentiate bug from functional improvement.

I agree with the Idea of "m. Th." in that forum, UI should be self explaining. It would be marvelous, but I wonder if it is reasonably possible ...

Best regards

Gérard
User avatar
xnview
Author of XnView
Posts: 39371
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and Labels Disappear

Post by xnview »

Gérard 91 wrote: - Are IPTC/XMP data stored with thumbnails or separately ?
You means in the database?
- So when thumbnails rebuild button is launch, are embedded data (IPTC & XMP in files) verified and updated in database ?
No, only thumbnails, i'll add a 'synchronize with file'
- Why excluded Directories (in second tab) are still present (in the first tab)
Must not be here!
- What should happen when remove a directory in first tab (it seems to be erase but still there when re-opening the box with same files number)
Files with no rating/labels are removed
- what is expected for each optimise option
http://newsgroup.xnview.com/viewtopic.p ... 2&p=114065
Pierre.
Gérard 91
Posts: 89
Joined: Wed Sep 23, 2009 8:33 pm

Re: Ratings and Labels Disappear

Post by Gérard 91 »

Thank you Pierre
So I understand that IPTC/XMP... and thumbnail, stored in two database (Thumb.db and Xnview.db), are managed together at first read of directory, but afterwards rebuilt separately
No, only thumbnails, i'll add a 'synchronize with file'
Nice if Database could be rebuilt from files on demand. (In my opinion files are more reliable at the moment for data storage but database necessary for fast request)
- Why excluded Directories (in second tab) are still present (in the first tab)
Must not be here!
I think so, but they are still there. and when I try to remove them, they disappear just for a while... But when reopening the box immediately, they are still there!
Something to do to have the specified behaviour ?
viewtopic.php?f=60&t=28692&p=114065
Thanks ! I have seen it too quickly I'll read it more precisely

Kind regards
User avatar
xnview
Author of XnView
Posts: 39371
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and Labels Disappear

Post by xnview »

Gérard 91 wrote:
- Why excluded Directories (in second tab) are still present (in the first tab)
Must not be here!
I think so, but they are still there. and when I try to remove them, they disappear just for a while... But when reopening the box immediately, they are still there!
Something to do to have the specified behaviour ?
are you able to reproduce it with a clean database?
Pierre.