Page 1 of 1

0.64 win-x86: bad Properties window after delete image file

Posted: Wed Jan 15, 2014 5:10 am
by budz45
Hi,

I just discovered a small GUI bug in XnViewMP but I think this might be an 'old' bug that has never been recognized untill now.

reproduction;

1.) In Windows Explorer, create a New Folder in any directory
2.) Put any Two JPG image files into this new folder
3.) Double-click just One of the JPG files (to open in XnView MP)
4.) Go back to the folder in Win Explorer....
5.) ..Now Delete the same image file that is currently opened in XnView MP..
6.) ..XnView MP recognizes the file no longer exists now the view switches to next JPG image...However...
7.) ...Now press "Properties" command
8.) ...Blank display of "Properties" window (BUG)

Re: 0.64 win-x86: bad Properties window after delete image f

Posted: Fri Feb 21, 2014 6:21 am
by budz45
It results in a blank Properties window
2014-02-21_062044.png
2014-02-21_062044.png (21.66 KiB) Viewed 672 times

Re: 0.64 win-x86: bad Properties window after delete image f

Posted: Tue Mar 11, 2014 12:17 pm
by xnview
See Issue 277 for current status and details.

Re: 0.64 win-x86: bad Properties window after delete image f

Posted: Sun May 18, 2014 1:38 am
by budz45
Still NOT fixed in XnViewMP 0.68

Pierre, I have discovered something good.....If a user presses the commands 'Next' or 'Previous' file after Step 6 but before Step 7 of my Reproduce then the Properties window gets displayed as normal. So to fix this, I think XnViewMP should have an internal auto-process that would auto press Next/Prev just once to trigger the reload. Try it.

Re: 0.64 win-x86: bad Properties window after delete image f

Posted: Mon May 19, 2014 8:11 am
by xnview
you use this way to reproduce
1.) In Windows Explorer, create a New Folder in any directory
2.) Put any Two JPG image files into this new folder
3.) Double-click just One of the JPG files (to open in XnView MP)
4.) Go back to the folder in Win Explorer....
5.) ..Now Delete the same image file that is currently opened in XnView MP..
6.) ..XnView MP recognizes the file no longer exists now the view switches to next JPG image...However...
7.) ...Now press "Properties" command
8.) ...Blank display of "Properties" window (BUG)
?

Re: 0.64 win-x86: bad Properties window after delete image f

Posted: Tue May 20, 2014 6:41 pm
by budz45
xnview wrote:you use this way to reproduce
1.) In Windows Explorer, create a New Folder in any directory
2.) Put any Two JPG image files into this new folder
3.) Double-click just One of the JPG files (to open in XnView MP)
4.) Go back to the folder in Win Explorer....
5.) ..Now Delete the same image file that is currently opened in XnView MP..
6.) ..XnView MP recognizes the file no longer exists now the view switches to next JPG image...However...
7.) ...Now press "Properties" command
8.) ...Blank display of "Properties" window (BUG)
?
Yes I use that Reproduce method.

I have sent you my Ini already but perhspa I could send yoiu my entire XnViewMP program folder as a zip.

Pierre, shall I send you my program folder?

Re: 0.64 win-x86: bad Properties window after delete image f

Posted: Wed May 21, 2014 9:20 am
by m.Th.
I can reproduce this.

I think that we must stress that the problem is in the View mode and not in the Browse mode.

Also that the file is deleted from outside (Windows Explorer) and not from XnView.