Playing Video clips - When required

*** Please report new bugs here! ***

Moderator: Dreamer

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Playing Video clips - When required

Post by B.Douille » Tue Apr 01, 2014 11:53 am

Currently (v0.64), videos can be played in the Browser Preview Pane and in Full Screen but there is no way to enable playing in one and disable in the other.

There are 2 options related to this but no combination allows a true choice:
- In Browser > File List > Custom filter: option "Show in preview" should apply only for the Browser Preview Pane (to allow playing or not). Current (wrong) behavior is that it also acts as a filter to includes/excludes video files from View and Full screen modes :?
- In View > View, the option "Autoplay (video)" allows automatic or manual start of video*. This option should only impact View and Full Screen modes. The current (wrong) behavior is that it's taken account as well as for the Browser Preview pane, triggering unwanted reading** while we are just browsing through files :?

Why is it painful? Once a video was played in preview pane, it's impossible to change anything with the file (move, delete, change date...). XnView locks the file and the only way is to close XnView :x This means a user should disable video playback most of the time, change the settings when he wants to show some nice clips and change back afterwards :(

Also,in View mode and quick slideshow, video are always skipped, whatever the options. The only way is to go to full screen / slideshow straight from Browser.
Last edited by B.Douille on Sat Apr 18, 2015 11:34 am, edited 5 times in total.
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

samirala
Posts: 3
Joined: Mon May 12, 2014 8:27 pm

Re: Playing Video clips - When required

Post by samirala » Mon May 12, 2014 8:43 pm

I got a similar problems:
1. when on thumbnail view doing double clic on a foto will open the viewer, but doing double clic on a video nothing happens, the video just plays on the preview window
2. when doing double clic on a foto the viewer will open, but the videos are filtered out, its only posible to see fotos, same on fullscreen, videos are filtered out

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Playing Video clips - When required

Post by B.Douille » Tue Sep 30, 2014 6:01 pm

samirala wrote: same on fullscreen, videos are filtered out
That's right, in the case you have a mix of photos and videos and you open a photo in View mode. From there, switching to full screen, the videos are filtered-out.
If you open a photo or a video in Full Screen from the browser, it plays and you can navigate from still to clips as you like.

Note: same in v0.68
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Playing Video clips - When required

Post by B.Douille » Sat Apr 11, 2015 3:52 pm

Still in v. 0.72. Can we have these options changed so playing videos in the small Explorer Preview Pane can be disabled while keeping the possibility to play them in Full Screen?

Enabling playing videos in the small Explorer Preview Pane causes issue with file move / delete / rename / date change,... as the file is locked for playback :(

Best regards
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Playing Video clips - When required

Post by xnview » Sat Apr 18, 2015 1:38 am

you would like an 'Auto play' setting for Browser preview and another for Fullscreen?
Pierre.

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Playing Video clips - When required

Post by B.Douille » Sat Apr 18, 2015 10:45 am

I think both exists already in the menu. It's just the current behavior which is not accurate:
There are 2 options related to this but no combination allows a true choice:
- In Browser > File List > Custom filter: option "Show in preview" should apply only for the Browser Preview Pane (to allow playing or not). Current (wrong) behavior is that it also acts as a filter to includes/excludes video files from View and Full screen modes :?
- In View > View, the option "Autoplay (video)" allows automatic or manual start of video*. This option should only impact View and Full Screen modes. The current (wrong) behavior is that it's taken account as well as for the Browser Preview pane, triggering unwanted reading** while we are just browsing through files :?
* Additional bug: Need a restart of XnView before it's taken account.
** This locks the file and prevent doing anything in it (rename/delete/change date,...)
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Playing Video clips - When required

Post by xnview » Mon Apr 20, 2015 1:54 pm

it's a problem if we have one setting for preview & view?
Pierre.

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Playing Video clips - When required

Post by B.Douille » Tue Apr 21, 2015 12:33 pm

Do you mean, activate preview in the "Custom filter" would also allow to see the video in view mode ?
It's not ideal in term of logic / ergonomic for the setup menu.
If it's an option to activate autoplay in Browser and in view mode, I would not add another option (yet) and let the user start play manually.
Still, the autoplay option exist for full screen / diaporama, where it is important.

Daniel
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Playing Video clips - When required

Post by xnview » Wed Apr 22, 2015 3:49 am

no i means, is it a problem if we have the same setting for preview AND view?
Pierre.

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Playing Video clips - When required

Post by B.Douille » Wed Apr 22, 2015 5:49 am

It would be a problem, yes.
Suggestion :
- In Browser > File List > Custom filter: option "Show in preview" allows autoplay in the Browser Preview Pane (and is ignored in all other modes).
- In View > View, the option "Autoplay (video)" allows automatic or manual start of video in Full Screen mode.
Regarding the View mode, currently we can't see any video there. Either don't touch it or put an always manual start (no additional option needed).

Daniel
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Playing Video clips - When required

Post by xnview » Thu Apr 23, 2015 2:38 pm

B.Douille wrote: Suggestion :
- In Browser > File List > Custom filter: option "Show in preview" allows autoplay in the Browser Preview Pane (and is ignored in all other modes).
- In View > View, the option "Autoplay (video)" allows automatic or manual start of video in Full Screen mode.
But Browser>File List>Custom filter>Show in preview is used to open video in preview, it's not a autoplay setting??
Regarding the View mode, currently we can't see any video there. Either don't touch it or put an always manual start (no additional option needed).
you can't open a video in view mode??
Pierre.

User avatar
B.Douille
Posts: 183
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Playing Video clips - When required

Post by B.Douille » Thu Apr 23, 2015 9:56 pm

The option currently has a dual role: It dispays the video to be seen in the preview pane and then it starts playing the video. That's normal behaviour.

Seeing / paying videos in View mode: It's like they were filtered-out of the list of files.
Samirala highlighted this, earlier in this post:
I got a similar problems:
1. when on thumbnail view doing double clic on a foto will open the viewer, but doing double clic on a video nothing happens, the video just plays on the preview window
2. when doing double clic on a foto the viewer will open, but the videos are filtered out, its only posible to see fotos, same on fullscreen, videos are filtered out
Best regards,
Daniel
Daniel, promoting XnView since 2004 and now using MP only (Platform Windows 10 & Windows 7, both 64 bits)

Teo
Posts: 17
Joined: Sat Sep 12, 2015 9:31 pm

Re: Playing Video clips - When required

Post by Teo » Sat Sep 12, 2015 11:05 pm

Hi. There are problems with video playback. I created a detailed table. I'm using XnViewMP Version 0.72x32.

With the current configuration when I double click, the video should open in a new tab, just like a photo opens in a new tab. Then if auto play is selected, the video should start playing in the new tab. If it is not selected, the video should just wait in a new tab. However when I double click, XnViewMP never opens the video in a new tab. I have closed down the preview pane. I don't want to preview. I want to play the video. I double click on the video but it doesn't open in a new tab. However if I right click and select open, then it does. I don't want to right click > open, I want to double click to open. Can you please check? Picasa is a good example how double click could work for videos. In Picasa if you double click, the video opens in a new tab and starts playing. While the video is playing if you double click again, it returns back to main screen. If you could make it the same way, that would be great.

By the way, you have done a great job with XnViewMP. I have searched this forum for dark skin. I came across to a few messages mentioning "dark theme" but they didn't say dark theme is available inside the new XnViewMP program but not in the regular XnView. I didn't know there was a much improved version called XnViewMP. I recommend that you cancel the current XnView and make the XnViewMP the new XnView. I love the dark theme. I made it even darker thanks to the styling css section you added within the program. I have never seen editable css integrated within software. This is great. I made everything work just the way I want it to be. Now if I could only make videos work. Thanks

Image

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Playing Video clips - When required

Post by xnview » Thu Sep 24, 2015 8:32 am

Teo wrote:Hi. There are problems with video playback. I created a detailed table. I'm using XnViewMP Version 0.72x32.
Thanks, but could you check with 0.75?
Pierre.

Teo
Posts: 17
Joined: Sat Sep 12, 2015 9:31 pm

Re: Playing Video clips - When required

Post by Teo » Sun Sep 27, 2015 3:44 pm

Hi,

I downloaded the 0.75 windows setup version from here. After installation in help>about it says XnViewMP, Version 0.75 x32 (Sep 21 2015).

However, it doesn't play any videos at all. When I single click, the preview pane shows the video player but the video doesn't play and the play button is greyed out. When I double click, nothing happens. When I right click and select open, it slowly opens a new tab that has the name of the video but the video doesn't play and the play button is greyed out again. I have been unable to play any video in 0.75 in either preview pane or new tab. Everything else works fine. I can open 0.72 side by side with 0.75 and in 0.72 I can right click>open and it does play in new tab.

Image

I recommend that you ditch 0.75, go back to 0.72 and fix problems instead adding any new features. 0.72 seems fixable. It was already playing the videos when you right click > open. 0.75 is a broken version. In 0.75 when I right click > open, it takes 3 seconds for the tab to appear and then it doesn't play the video anyway. In 0.72 right click > open, opens the new tab quickly and it plays the video. However there are lots of other problems.

Post Reply