Page 1 of 1

Poor image quality of thumbnails

Posted: Sun Jul 06, 2014 11:49 pm
by Shimapan
This is using XnView 0.68 x64 on the current Kubuntu 14.04.

Because I'm using a high display resolution (1920x1200), I've set the thumbnails to 192x144. Thumbnail quality is set to "High Quality (Jpeg)".
However, the thumbnails aren't "High Quality" at all, but rather poor quality.

Here's a screenshot of the poor quality thumbnails in XnView: (click for big image)

Image

As you can see, most thumbnails have a rather poor quality (looks like quality 75 with colour subsampling). Even the few who look not too bad (6206, 6213) aren't that great.

For comparison, here's a screenshot from the thumbnails in Dolphin (file manager from Kde 4.13).
As you can see, thumbnails are high quality in Dolphin: (click for big image)

Image

I've already tried deleting the entire thumbnail database, exiting and reopening XnView two times, but it didn't help.
The option to recreate thumbnails doesn't change anything either.

I can see two explanations for this, both of which I would consider a bug:
  • :bugconfirmed: There's a bug in the quality settings, and even if you select "High Quality (Jpeg)" for the thumbnails, it still uses the "Low Quality" settings.
  • :bugfixed: The setting is misnamed, and despite being named "High Quality", it uses rather low quality settings instead. For "High Quality", I'd expect a quality setting of at least 90 (better 94) and NO colour subsampling.
I don't know which of the two it is, but it would be great if you could fix it :mrgreen:

Re: Poor image quality of thumbnails

Posted: Mon Jul 07, 2014 9:36 am
by m.Th.
Most probably that XnView MP uses for thumbnail the default size which is rather small for nowadays monitors.

Go to Tools | Settings | Database and enter there bigger values for thumbnail's Width and Height (for ex. 300x200). Alternatively you can press 'Get thumbnail size' in order to take the actual size from the thumbs pane. After this you must rebuild the thumbs if you want to see the new "quality". You can do this either by selecting the thumbs which you want and go to View | Rebuild Thumbnails either by pressing Rebuild Thumbnails in the same Settings page mentioned above to rebuild all the thumbs from DB.

OTOH, perhaps you might want to use WebP as your format for the thumbs because it will scale much better when your DB grows.

Re: Poor image quality of thumbnails

Posted: Sun Sep 09, 2018 6:24 am
by robert7
There may be another additional problem.

Even if the thumbnail is set to enough high value, the appearance may be still poor. It could be XnView is using "embedded thumbnail" - so you may want to turn it off using "Tools/Setting" then "Browser/Thumbnail" set "Use ambedded thumbnail" to "unchecked".

Then "Settings/Browser/Catalog/Delete all" (this will force rebuild of all thumbnails after those are viewed again. Or as alternative "Settings/Browser/Catalog/Rebuild thumbnails" or menu "View/Rebuild thumbnails".

Re: Poor image quality of thumbnails

Posted: Mon Sep 10, 2018 10:23 am
by xnview
could you send me the image file?

Re: Poor image quality of thumbnails

Posted: Fri Sep 06, 2019 7:11 pm
by CauZion
Hi, I'm using XnViewMP and have specified max size thumbnail 800x600.
I have purged and rebuilt all thumbnails.
When I browse folders, I have several thumbnails with poor quality and others with good quality for images of the same size, quality, and resolution.

I'm sending some images attached, so maybe you can tell me what's wrong.

I couldn't send the original images because they are too large and this Forum is not allowing to send them. Each of the two photos has about 10MB

I love XnView by the way.

Re: Poor image quality of thumbnails

Posted: Mon Sep 09, 2019 7:04 am
by m.Th.
CauZion wrote:
Fri Sep 06, 2019 7:11 pm
Hi, I'm using XnViewMP and have specified max size thumbnail 800x600.
I have purged and rebuilt all thumbnails.
When I browse folders, I have several thumbnails with poor quality and others with good quality for images of the same size, quality, and resolution.
Go to Settings \ Thumbnail \ Misc (first tab)

Do a screenshot of the above and post it here (preffered) or tell us which are the values of „Use embedded thumbnail” and „Create from original image if embedded thumbnail is smaller than thumbnail size”.

Hint: if the 1st one is „On” and the second one is „Off” and the file is JPEG then the thumbs will be blurry because the embedded thumbnail for JPEGs is very small.

Re: Poor image quality of thumbnails

Posted: Wed Nov 20, 2019 8:31 pm
by literakl
I had the same problem. XNviewMP 0.94 64bit on Windows. I have tried every possible setting and action. The last attempt was to disable the thubnail database and unchecked the Use associated thubnail (sorry, my GUI is in czech). Once I restarted the app it started to work correctly.