XnViewMP 0.79 x64 Open file very slow :(

*** Please report new bugs here! ***

Moderator: Dreamer

Deetee
Posts: 4
Joined: Wed Apr 27, 2016 4:01 am

XnViewMP 0.79 x64 Open file very slow :(

Postby Deetee » Wed Apr 27, 2016 4:18 am

Hi guys.
Im using Windows 8.1, 64 bits, XnViewMP 0.79

Whenever i open an image file (jpeg, tga, tiff etc), it took very long to open the file.

Previously (same version or slightly older versio, cant rmber), it was perfectly fine. I think 2-3 weeks ago, all of sudden it just load super slow.
Whenever i open an image file, it took approximately 7-8seconds to launch XnViewMP. Windows photo viewer open it in less than a second time.


I tried reinstall. Doesnt work.
I tried uninstall and reinstall. Doesnt work.
I tried uninstall, then delete all left over folders then reinstall... Doesnt work either....

Please help :(

Deetee
Posts: 4
Joined: Wed Apr 27, 2016 4:01 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby Deetee » Fri Apr 29, 2016 9:26 am

no help at all? :(

User avatar
XnTriq
Moderator & Librarian
Posts: 5104
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby XnTriq » Fri Apr 29, 2016 11:45 am

Welcome to the forum, Deetee (-:

Did you delete xnview.ini (Help » About » General » INI filename) and the following registry entries?

  • HKEY_LOCAL_MACHINE\Software\XnViewMP
  • HKEY_CURRENT_USER\Software\XnView\XnViewMP
  • HKEY_CURRENT_USER\Software\Trolltech

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview » Sun May 01, 2016 9:09 am

youhave not that before with same version?
Pierre.

Deetee
Posts: 4
Joined: Wed Apr 27, 2016 4:01 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby Deetee » Tue May 03, 2016 7:49 am

XnTriq wrote:Welcome to the forum, Deetee (-:

Did you delete xnview.ini (Help » About » General » INI filename) and the following registry entries?

  • HKEY_LOCAL_MACHINE\Software\XnViewMP
  • HKEY_CURRENT_USER\Software\XnView\XnViewMP
  • HKEY_CURRENT_USER\Software\Trolltech


Hi XnTriq, Thanks for the reply... also thanks for the welcome :)
I still find xnview.ini inside my C:\Users\User\AppData\Roaming\XnViewMP
I am not good in regedit. Thus i am pretty sure i nvr touch anything in regedit.
but i did went to few regedit location that you listed there, most of them appear to be no value set on the default.

xnview wrote:youhave not that before with same version?

Hi XnView, I dont think i have such problem before with the same version. It just happen out of no where.
I used to thought my pc issue, until it last for several weeks that i was convinced it should not be pc issue.



Regardless... Today, magically... it works pretty fine.
Wouldnt say perfectly fine, but it is pretty alright now.
I dont know what is going on... and i didnt do a thing at all.

Previously it took 7-8 seconds just to launch xnviewMP.
now on local disk, it launch xnviewMP immediately and display very quick (probably 0.5seconds time).
but on network, it still launch xnviewMP immediately, but it will hang there for 2-3 seconds before i can click anything. (hang as in the image is shown on xnviewMP, but on top of that it is written as <empty> and the mouse is still on loading icon) (I rmber previously there is no delay at all)

Well... i guess it works fine for now. at least i don have to wait 7-8 seconds just for it to launch.

Thanks for both of your reply. sorry for the trouble as it just magically works alright now.

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview » Tue May 03, 2016 9:37 am

yuo open an image file from windows explorer, right?? If so i found a bug here
Pierre.

DeFi
Posts: 5
Joined: Sat Mar 24, 2012 12:26 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby DeFi » Wed May 04, 2016 10:47 pm

Hi,
I'm also experiencing speed problems with the newer versions of XnViewMP (including 0.79). When opening an image file from the desktop right after booting the PC, XnViewMP takes 5 to 10 seconds to display it (system is on a SSD). Opening the file a second time is moderately faster. With my old XnView 2.32 it opens immediately under the same conditions. While experimenting to fix the problem, I deleted the ini-files and played with the thumbnail cache settings, but nothing seems to work. However I discovered a maybe related bug:
When I open an image file from the desktop or in explorer directly in viewer mode and start cycling the image files in the respective folder, XnViewMP will cycle through all files in the folder. This includes really all files (.lnk, .exe .obj ... etc.). The files XnViewMP can not render are displayed as blank. If I however switch XnViewMP to browser-view it first starts very slowly listing all files. After the listing is complete, it filters the files according to my settings, so only image files remain. If I now switch back to viewer-mode and start cycling the files, it only cycles the image files as intended. If XnViewMP is started in browser-view and an image file is opened from there, it also works as intended. I find it very strange, that the filter is applied after displaying a full list of all files instead of applying it before displaying files. I hope this description is useful in fixing the bug.

[edit] The bug may be the same as described here: viewtopic.php?f=62&t=32534 Thus, it seems to exist at minimum since XnViewMP 0.76.

Deetee
Posts: 4
Joined: Wed Apr 27, 2016 4:01 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby Deetee » Thu May 05, 2016 5:09 am

xnview wrote:yuo open an image file from windows explorer, right?? If so i found a bug here

Yes bro. I open from window explorer.
Glad that you detected bug there. Hope it will be fix. :D
but for some unknown reason, now it seems to be alright.


DeFi wrote:Hi,
I'm also experiencing speed problems with the newer versions of XnViewMP (including 0.79). When opening an image file from the desktop right after booting the PC, XnViewMP takes 5 to 10 seconds to display it (system is on a SSD). Opening the file a second time is moderately faster. With my old XnView 2.32 it opens immediately under the same conditions. While experimenting to fix the problem, I deleted the ini-files and played with the thumbnail cache settings, but nothing seems to work. However I discovered a maybe related bug:
When I open an image file from the desktop or in explorer directly in viewer mode and start cycling the image files in the respective folder, XnViewMP will cycle through all files in the folder. This includes really all files (.lnk, .exe .obj ... etc.). The files XnViewMP can not render are displayed as blank. If I however switch XnViewMP to browser-view it first starts very slowly listing all files. After the listing is complete, it filters the files according to my settings, so only image files remain. If I now switch back to viewer-mode and start cycling the files, it only cycles the image files as intended. If XnViewMP is started in browser-view and an image file is opened from there, it also works as intended. I find it very strange, that the filter is applied after displaying a full list of all files instead of applying it before displaying files. I hope this description is useful in fixing the bug.

[edit] The bug may be the same as described here: viewtopic.php?f=62&t=32534 Thus, it seems to exist at minimum since XnViewMP 0.76.

When i was suffering the problem, it doesnt make a different whether my that particular folder contains multiple files or single file.
As for older version of XnViewMP, i nvr experience such delay.

joro_abv
Posts: 8
Joined: Mon Mar 23, 2015 9:57 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby joro_abv » Sun May 29, 2016 8:02 am

I can confirm I have this desktop issue for long time, since 0.75 and before and I'm almost sure also with the legacy XnView - it is happenning on the desktop exclusively and not always, but randomly.
Simply sometimes it takes 10-20 seconds to open a double-clicked desktop file in the viewer. If I open another file with double-click, even in a dekstop subfolder - it opens instantly. If I open the desktop file from the xnview file explorer - it also opens instantly. I had it on Win7 and now I have it on Win10 too.

xnview-support
Posts: 11
Joined: Sat Sep 02, 2017 9:55 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview-support » Sat Sep 02, 2017 10:01 am

Using XnView MP 0.86 on Windows 10 Pro.

I too am seeing extremely slow XnView startup times. This did not occur prior to XnView updates a few months ago, but ever since then the app can take 5-10 seconds to open to view a photo. This defeats the purpose of using the app.

I tried deleting xnview.ini (Help » About » General » INI filename) and the following registry entries:
HKEY_LOCAL_MACHINE\Software\XnViewMP
HKEY_CURRENT_USER\Software\XnView\XnViewMP
HKEY_CURRENT_USER\Software\Trolltech

but this did not help.

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview » Mon Sep 04, 2017 9:44 am

xnview-support wrote:Using XnView MP 0.86 on Windows 10 Pro.

I too am seeing extremely slow XnView startup times. This did not occur prior to XnView updates a few months ago, but ever since then the app can take 5-10 seconds to open to view a photo. This defeats the purpose of using the app.

I tried deleting xnview.ini (Help » About » General » INI filename) and the following registry entries:
HKEY_LOCAL_MACHINE\Software\XnViewMP
HKEY_CURRENT_USER\Software\XnView\XnViewMP
HKEY_CURRENT_USER\Software\Trolltech

but this did not help.

if you start XnView MP and click on it to preview it or open the file in edit mode, same delay?
Pierre.

xnview-support
Posts: 11
Joined: Sat Sep 02, 2017 9:55 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview-support » Tue Sep 05, 2017 3:27 pm

Thank you for the followup.

If XnView is open and the file is selected and opened from within the XnView interface, opening the file is instantaneous.

The delay only appears to occur when opening the file with XnView (via OS command) when XnView isn't already open.

Please note:
1. The system used is very fast and can open even large applications like Photoshop very quickly.
2. XnView used to open nearly instantaneously via OS commands to open photos. Only in recent updates does it suddenly take a long time for the application to open.

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview » Wed Sep 06, 2017 8:00 am

xnview-support wrote:The delay only appears to occur when opening the file with XnView (via OS command) when XnView isn't already open.

For example from windows explorer? The folder opened has a lot of files? which setting do you have in General>Mode when starting?

2. XnView used to open nearly instantaneously via OS commands to open photos. Only in recent updates does it suddenly take a long time for the application to open.

No problem with 0.84?
Pierre.

xnview-support
Posts: 11
Joined: Sat Sep 02, 2017 9:55 am

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview-support » Fri Sep 08, 2017 3:54 pm

For example from windows explorer?

Yep!

The folder opened has a lot of files?

It doesn't seem to matter. A few files or many files, the slowness is the same.

which setting do you have in General>Mode when starting?

"Normal"

No problem with 0.84?

I'm not sure exactly which version was working quickly a few months ago; I didn't keep track of the version number.

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.79 x64 Open file very slow :(

Postby xnview » Tue Sep 12, 2017 7:13 am

xnview-support wrote:
For example from windows explorer?

Yep!

And if you start XnView in browser, no problem?
Pierre.


Return to “New”

Who is online

Users browsing this forum: jadO and 1 guest