0.84: Large row height due to linefeeds in comment

*** Please report new bugs here! ***

Moderator: Dreamer

phaolo
Posts: 61
Joined: Tue Dec 29, 2015 11:40 pm

0.84: Large row height due to linefeeds in comment

Postby phaolo » Mon Mar 27, 2017 6:59 am

XnView: MP 0.84 - 64 bit
OS: Windows 7 - 64bit

Browser mode, file "View as" "details", showing the "Comment" column:
if an image contains some specific text in the comment (carriage return?), then each file line in the folder will become taller than the default size by various times.

Effect: annoyance, less visible files in the window and weird format.

To reproduce:
- create a file with a specific text in the comment
- set the view and look

Actual behaviour (bug): each file line becomes very tall :bug:

Expected behaviour: same default line height of all files.

User avatar
m.Th.
XnThusiast
Posts: 1373
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.84: "Comment" column problem

Postby m.Th. » Mon Mar 27, 2017 8:33 am

In Edit | Comment I entered:
1
2
3

...and the program "translated" it into 1\n2\n3\nA and displayed in this way in "Comment" column.

Which text did you entered and where? Can you post a screenshot?


Hint:
Also, perhaps is better to use - if your format supports - the IPTC / XMP Window (it is located in Tools | Metadata ) which is a more powerful way to enter metadata.

Then you can use tooltips and labels to show under the thumbnails what you want.

You can customize them in

1. Tools | Settings | Thumbnail | Label (for labels) - put in the list from right what fields you want.


2. and for tooltips: Tools | Settings | Browser - check "Use tooltips" and press "Insert >>" in order to choose what fields to show into the tooltips.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.86 64bit & XnView 2.00 x64 on Win7 x64 -

phaolo
Posts: 61
Joined: Tue Dec 29, 2015 11:40 pm

Re: 0.84: "Comment" column problem

Postby phaolo » Mon Mar 27, 2017 11:02 am

m.Th. wrote:Which text did you entered and where? Can you post a screenshot?

The problem is that I didn't create the comment myself.
Some image\s among like 500 caused this.
I should have taken a screenshot, now I have to look for the folder again.

EDIT: ok, I found a folder with only a few similar files. The height isn't as tall as the other one I saw, however.

Comment (with a carriage return\newline):

Code: Select all

CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), quality = 100

Attachments
comment height.jpg

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: "Comment" column problem

Postby helmut » Mon Mar 27, 2017 11:41 am

Thank you for the screenshot, phaolo. Looks like the vertical aligment of the columns differs (top aligned vs. center aligned).

And XnView could perhaps trim the contents of "Comment" and truncate trailing spaces, tabs, and line feeds (or carriage return linefeeds).

User avatar
m.Th.
XnThusiast
Posts: 1373
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.84: "Comment" column problem

Postby m.Th. » Mon Mar 27, 2017 12:17 pm

helmut wrote:Thank you for the screenshot, phaolo. Looks like the vertical aligment of the columns differs (top aligned vs. center aligned).

And XnView could perhaps trim the contents of "Comment" and truncate trailing spaces, tabs, and line feeds (or carriage return linefeeds).


+1 - ok> +2 for both.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.86 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: "Comment" column problem

Postby helmut » Mon Mar 27, 2017 9:14 pm

@phaolo: Could you please upload a sample image that causes the problem? (This will make reproducing and fixing your problem much simpler).

phaolo
Posts: 61
Joined: Tue Dec 29, 2015 11:40 pm

Re: 0.84: "Comment" column problem

Postby phaolo » Mon Mar 27, 2017 9:34 pm

helmut wrote:@phaolo: Could you please upload a sample image that causes the problem? (This will make reproducing and fixing your problem much simpler).

Emm.. I can't do these. Maybe the old one, if I can find it again.

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: "Comment" column problem

Postby helmut » Mon Mar 27, 2017 9:36 pm

phaolo wrote:
helmut wrote:@phaolo: Could you please upload a sample image that causes the problem? (This will make reproducing and fixing your problem much simpler).

Emm.. I can't do these. Maybe the old one, if I can find it again.
O.k.. Could you perhaps make a copy of your image file and then use JPEG lossless cropping to crop your copied image to 10x10 pixels (Viewer: Tools » JPEG lossless operations » Crop)? Afterwards you remove the EXIF thumbnail in XnView browser (Browser: Tools » Metadata » Clean...).
This cropping and removing of the EXIF thumbnail will make the image's contents useless and perhaps allows you to provide it here? (if this isn't possible either that's o.k.).

phaolo
Posts: 61
Joined: Tue Dec 29, 2015 11:40 pm

Re: 0.84: "Comment" column problem

Postby phaolo » Mon Mar 27, 2017 10:21 pm

helmut wrote:Viewer: Tools » JPEG lossless operations » Crop

Crop is greyed out.
Do you really need it lossless? The problem is just the comment.
(if I hide the column and refresh, the file list returns normal)

EDIT: hey, did you change the title?
The vertical alignment is the lesser issue, it's the row height that can become problematic (that screenshot has only 2x, but the old case had like 8x)
I made a fake image to make you understand what I saw the first time (for all the files in the same dir).
Attachments
comment height 8x.jpg

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: "Comment" column problem

Postby helmut » Tue Mar 28, 2017 6:31 pm

phaolo wrote:
helmut wrote:Viewer: Tools » JPEG lossless operations » Crop

Crop is greyed out.
Do you really need it lossless? The problem is just the comment.
(if I hide the column and refresh, the file list returns normal)
As long as the comment is not touched you can do with the image whatever you like. First, you have to select an area and then apply lossless cropping.

phaolo wrote:EDIT: hey, did you change the title?
Right, this is what I do quite often in order to make bug handling easier. Just did it again. ;)

phaolo
Posts: 61
Joined: Tue Dec 29, 2015 11:40 pm

Re: 0.84: "Comment" column problem

Postby phaolo » Tue Mar 28, 2017 7:06 pm

helmut wrote:you have to select an area and then apply lossless cropping.

Okk, here you go.
It causes the same effect even if cut.
(except on the Desktop?? I only have links and text files there)
Attachments
41z5nz49i230yb.jpg
41z5nz49i230yb.jpg (368 Bytes) Viewed 283 times

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: "Comment" column problem

Postby helmut » Tue Mar 28, 2017 9:55 pm

Thank you very much for your sample file, phaolo. Unfortunately the problem doesn't occur. :?

What I did:
1. Download sample file
2. Copy it about 20 times
3. Browse folder containing the image files with XnView
4. Switch view to "Details" (View » View as » Details)

Perhaps there is some setting which enables the problem to occur. Could please try with default settings, see viewtopic.php?t=35085

phaolo
Posts: 61
Joined: Tue Dec 29, 2015 11:40 pm

Re: 0.84: "Comment" column problem

Postby phaolo » Tue Mar 28, 2017 10:16 pm

helmut wrote:Unfortunately the problem doesn't occur.[..]What I did[..]

Did you remember to show the "Comment" column?

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: "Comment" column problem

Postby helmut » Tue Mar 28, 2017 10:43 pm

phaolo wrote:... Did you remember to show the "Comment" column?
Yes, "Comment" column displayed (see my screenshot below). I'm on Windows 10 64 bit using XnView 0.85 beta 3. Just tried 0.84 to make sure but no change.
Detail_view_multiliine_comment.png

User avatar
helmut
Posts: 8120
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Large row height due to linefeeds in comment

Postby helmut » Thu Apr 06, 2017 7:46 pm

@phaolo: Perhaps there is some setting which enables the problem to occur. Could please try with XnView 0.85 and default settings, see viewtopic.php?t=35085


Return to “New”

Who is online

Users browsing this forum: No registered users and 1 guest