0.86: XMP for video files not being imported or exported

*** Please report new bugs here! ***

Moderator: Dreamer

mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

0.86: XMP for video files not being imported or exported

Postby mjbiggs » Tue May 16, 2017 1:31 pm

Hello


XnView: MP 0.86 - 64-bit
OS: Windows 7 Pro - 64-bit

Effect: XMP files not being imported or exported properly when using View->Update catalog from files or View->Update files from catalog:


XnView Settings:
    Tools->Settings->Browser->Metadata
    all checkboxes checked except Create IPTC data
    for Update or create XMP Sidecar then option <filename>.xmp is selected
Video file type: m2ts


To reproduce for import:
1. In XnView, select video file
2. Assign category/rating/label using View->Update catalog from files

Actual behaviour (bug): Category/rating/label details are not imported into XnView from XMP files

Expected behaviour: Category/rating/label details should be imported into XnView from XMP files


To reproduce for export:
1. In XnView, select video file
2. Assign category/rating/label
3. Assign to file on disk using View->Update files from catalog

Actual behaviour (bug): Category/rating/label details are not exported to existing or new XMP files. Either existing XMP files are overwritten with empty fields or new XMP file is created with empty fields.

Expected behaviour: Category/rating/label details should be exported to existing or new XMP file.


Thanks

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: XMP for video files not being imported or exported

Postby xnview » Sat Jun 17, 2017 11:35 am

If you have a .xmp sidecar associated with a video file, categories are correctly imported.
Pierre.

mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

Re: 0.86: XMP for video files not being imported or exported

Postby mjbiggs » Tue Aug 08, 2017 9:55 pm

Hello Pierre

Thanks for your time and your reply.

I have tested this issue now for XnView MP 0.87 Beta1, Beta2 and Beta3. Unfortunately, for me, for some reason the above problem still exists.

For a given video file with ticked categories and rating - XnView MP does not correctly export these details to the associated .xmp file.
For a given video file with associated detailed .xmp file - XnView MP does not correctly import these details from the .xmp file into DB categories.

The good .xmp files I am using to test this were originally produced by an earlier version of XnView MP. Not sure which version but the .xmp creation date is 2017-01-23 so I guess an XnView MP version issued before that date. For some reason, on my system, XnView MP cataloguing has not worked properly since then.

Regards

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: XMP for video files not being imported or exported

Postby xnview » Wed Aug 09, 2017 10:47 am

could you send me the xmp file?
Pierre.

mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

Re: 0.86: XMP for video files not being imported or exported

Postby mjbiggs » Wed Aug 09, 2017 5:56 pm

Hello Piere

Have just been testing again. Don't quite understand the behaviour but it is better than I described in my original message.

On my last test:

In XnView MP select video file with categories (set 1) and associated .xmp. Add some new categories (set 2) then update files from catalog. When examining the .xmp the new categories (set 2) have not been written, ie the .xmp appears unchanged, reflecting categories (set 1).

Now, with the same video file selected, randomly change categories (set 3) but then use update catalog from files. Would expect this to restore categories (set 1) as per the unchanged .xmp above. However, the new categories (set 2) are restored.

To me, seems to suggest XnView MP categories are stored somewhere else, in addition to the .xmp file?

Am attaching sample .xmp file.

mjb_20161106_201339_pc1_00001.7z
zipped using 7-Zip as wouldn't allow attachment of .xmp file.
(652 Bytes) Downloaded 3 times

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: XMP for video files not being imported or exported

Postby xnview » Sun Aug 13, 2017 1:36 pm

I can't reproduce, the xmp file is updated. I have test.mp4, and test.xmp, i change rating or categories on test.mp4, click on the xmp file, and the content of xmp is correct
Pierre.

mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

Re: 0.86: XMP for video files not being imported or exported

Postby mjbiggs » Mon Aug 14, 2017 8:25 pm

OK.

Many thanks for looking into it.

I'll have another good look on my system and see what I come up with. Will let you know what I find.

Regards


Return to “New”

Who is online

Users browsing this forum: No registered users and 1 guest