Rating information lost in latest version XnViewMp

*** Please report new bugs here! ***

Moderator: Dreamer

PeterH
Posts: 18
Joined: Tue Dec 01, 2015 2:30 pm

Rating information lost in latest version XnViewMp

Postby PeterH » Mon Jun 12, 2017 9:52 pm

In the latest version of XnViewMp Version 0.86 64bits (Apr 25 2017) I have lost rating information of a number of pictures several times by now. Getting irritated by this behaviour. Can't point out why it is going wrong but it looks like it has to do with new directories with pictures that you browse to.

If one opens this new directory in XnViewMp and start Rating the pictures using CTRL 4 or CTRL 3 for instance it can happen these ratings are lost. Not nice if you are working through a large number of pictures. Sometimes hitting F5 helps and restores the rating informations but this trick does not always work I have painfully learned. Usually I click on the first foto in a directory to open it to large size and start rating. With the latest version I have to check if the rating actually works by going back to the folder overview. By reopening a picture it looks like the issue does not happen again. At least I did not experience that.

In previous versions I have never experienced this. Any help to remove this issue would be super!

Regards Peter

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Rating information lost in latest version XnViewMp

Postby xnview » Thu Jun 15, 2017 12:00 pm

PeterH wrote:In the latest version of XnViewMp Version 0.86 64bits (Apr 25 2017) I have lost rating information of a number of pictures several times by now. Getting irritated by this behaviour. Can't point out why it is going wrong but it looks like it has to do with new directories with pictures that you browse to.

Do you export rating into the file?

If one opens this new directory in XnViewMp and start Rating the pictures using CTRL 4 or CTRL 3 for instance it can happen these ratings are lost. Not nice if you are working through a large number of pictures. Sometimes hitting F5 helps and restores the rating informations but this trick does not always work I have painfully learned. Usually I click on the first foto in a directory to open it to large size and start rating. With the latest version I have to check if the rating actually works by going back to the folder overview. By reopening a picture it looks like the issue does not happen again. At least I did not experience that.

Are you able to reproduce this rating lost?
Pierre.

PeterH
Posts: 18
Joined: Tue Dec 01, 2015 2:30 pm

Re: Rating information lost in latest version XnViewMp

Postby PeterH » Fri Jun 16, 2017 8:46 pm

xnview wrote:
PeterH wrote:In the latest version of XnViewMp Version 0.86 64bits (Apr 25 2017) I have lost rating information of a number of pictures several times by now. Getting irritated by this behaviour. Can't point out why it is going wrong but it looks like it has to do with new directories with pictures that you browse to.

Do you export rating into the file?

Yes I export the rating info the the jpg files so that I can use it from other apps.


If one opens this new directory in XnViewMp and start Rating the pictures using CTRL 4 or CTRL 3 for instance it can happen these ratings are lost. Not nice if you are working through a large number of pictures. Sometimes hitting F5 helps and restores the rating informations but this trick does not always work I have painfully learned. Usually I click on the first foto in a directory to open it to large size and start rating. With the latest version I have to check if the rating actually works by going back to the folder overview. By reopening a picture it looks like the issue does not happen again. At least I did not experience that.

Are you able to reproduce this rating lost?


No unfortunately I can't. Just tried to reproduce the issue with trying my usual working approach but it works like normal. Don't know why this happened so now and then. Experienced it at least a dozen times. Usually I work trough 100+ photo's when it happened. Not sure if that is relevant.

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Rating information lost in latest version XnViewMp

Postby xnview » Sat Jun 17, 2017 8:00 am

and if you use 'Update catalog from files' on files with categories lost?
Pierre.

PeterH
Posts: 18
Joined: Tue Dec 01, 2015 2:30 pm

Re: Rating information lost in latest version XnViewMp

Postby PeterH » Thu Jul 13, 2017 1:33 am

xnview wrote:and if you use 'Update catalog from files' on files with categories lost?


Just happened again to me. I selected a number of pictures from within XnViewMp. Hit ctrl x, browsed to a new folder location within XnViewMp, created a new directory and used ctrl v to relocate the selected pictures. Then I looked for the best pictures rating them using CTRL 4. After having looked at all pictures involved I selected the filter: Good, nothing there!
Back to all pictures and hitting F5 revealed the ratings. After that the filter worked, pffff...

Something is going wrong sometimes for some reason...

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Rating information lost in latest version XnViewMp

Postby xnview » Thu Jul 13, 2017 7:44 am

could you make a screen record?
Pierre.

PeterH
Posts: 18
Joined: Tue Dec 01, 2015 2:30 pm

Re: Rating information lost in latest version XnViewMp

Postby PeterH » Thu Jul 13, 2017 8:10 pm

xnview wrote:could you make a screen record?


The problem is that I cannot reproduce this behaviour but it does happen to often.
Unfortunately I do not have a clue why it sometimes does not properly stores the ratings.
Just tested the same procedure as last evening a couple of times and it works like it should. Hopefully next release removes the issue, think it started with the latest release: XnView MP Windows
Version 0.86 64bits (Apr 25 2017)

User avatar
xnview
Author of XnView
Posts: 28086
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Rating information lost in latest version XnViewMp

Postby xnview » Fri Jul 14, 2017 11:04 am

and if you check rating in metadata, it here?
Pierre.

PeterH
Posts: 18
Joined: Tue Dec 01, 2015 2:30 pm

Re: Rating information lost in latest version XnViewMp

Postby PeterH » Fri Jul 14, 2017 1:10 pm

xnview wrote:and if you check rating in metadata, it here?

If it happens again I will have a look and let you know.


Return to “New”

Who is online

Users browsing this forum: No registered users and 1 guest