Favorites panel is blank on startup

*** Please report new bugs here! ***

Moderator: Dreamer

User avatar
Brother Gabriel-Marie
Posts: 247
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Favorites panel is blank on startup

Postby Brother Gabriel-Marie » Fri Aug 18, 2017 4:07 pm

Normally, I start my MP in browser mode with the favorites panel showing.

When I first start MP, though, the panel is blank. I have to switch to Folders and back to Favorites for it to display.

Version 0.86 64bits (Apr 25 2017) on Windows 7x64.

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Favorites panel is blank on startup

Postby xnview » Sun Aug 20, 2017 3:04 pm

even if you restart it?
Pierre.

User avatar
Brother Gabriel-Marie
Posts: 247
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: Favorites panel is blank on startup

Postby Brother Gabriel-Marie » Sun Aug 20, 2017 8:21 pm

Pierre, yes, it happens every time.

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Favorites panel is blank on startup

Postby xnview » Mon Aug 21, 2017 9:43 am

Brother Gabriel-Marie wrote:Pierre, yes, it happens every time.

Try to change in xnview.ini

Code: Select all

Tab=-1
Pierre.

User avatar
Brother Gabriel-Marie
Posts: 247
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: Favorites panel is blank on startup

Postby Brother Gabriel-Marie » Mon Aug 21, 2017 5:00 pm

Mine was Tab=17 under [Browser]

What does that mean and do?

I changed it to -1 and it seems to work correctly now.

User avatar
Brother Gabriel-Marie
Posts: 247
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: Favorites panel is blank on startup

Postby Brother Gabriel-Marie » Sat Aug 26, 2017 6:32 pm

Okay, the setting didn't stick.
Now it's back to having a blank Favorites panel.

I checked the ini file and found this:
[Browser]
Tab=4294967293

That's a weird value, considering I had just 17 there the other day.
Maybe that value has to do with this problem that I've been having, too: viewtopic.php?t=36151

But if I close all my MP instances and change the ini file back to tab=-1 then the favourites panel shows up again. So I don't know what is causing it to be lost.

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Favorites panel is blank on startup

Postby xnview » Mon Aug 28, 2017 11:10 am

do you have this problem only when using multiple instance?
Pierre.

User avatar
Brother Gabriel-Marie
Posts: 247
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: Favorites panel is blank on startup

Postby Brother Gabriel-Marie » Mon Aug 28, 2017 1:13 pm

No, I have it also with a single instance that was started when no other instances were running.
I can set the tab value to -1, start MP and the favourites panel is showing fine. But when I close it, MP changes the tab value back to 4294967295 - but that doesn't seem to matter - the favourites panel shows fine.

I would conclude that something to do with the multiple instances is borking the preview panel. It doesn't matter whether [browser]tab is set to -1 or 4294967295 for a single instance. But for multiple instances, it does matter.

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Favorites panel is blank on startup

Postby xnview » Wed Aug 30, 2017 6:23 pm

Brother Gabriel-Marie wrote:No, I have it also with a single instance that was started when no other instances were running.
I can set the tab value to -1, start MP and the favourites panel is showing fine. But when I close it, MP changes the tab value back to 4294967295 - but that doesn't seem to matter - the favourites panel shows fine.

with one instance you can reproduce it each time? If yes, please send me your .ini?
Pierre.

Obelix469
Posts: 3
Joined: Wed Oct 04, 2017 3:14 pm

Re: Favorites panel is blank on startup

Postby Obelix469 » Wed Oct 04, 2017 3:24 pm

I have the same problem. the category filter panel is affected by it as well.
setting the [Browser] tab=-1 worked and yet was reset to a variation of 4294967295 on close as well.
Attachments
xnview.zip
(6.25 KiB) Not downloaded yet

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Favorites panel is blank on startup

Postby xnview » Thu Oct 05, 2017 5:35 am

Obelix469 wrote:I have the same problem. the category filter panel is affected by it as well.
setting the [Browser] tab=-1 worked and yet was reset to a variation of 4294967295 on close as well.

each time?
Pierre.

Obelix469
Posts: 3
Joined: Wed Oct 04, 2017 3:14 pm

Re: Favorites panel is blank on startup

Postby Obelix469 » Fri Nov 03, 2017 10:08 pm

yes everytime. updated latest version still happening

User avatar
Brother Gabriel-Marie
Posts: 247
Joined: Thu Aug 23, 2007 2:33 pm
Location: United States

Re: Favorites panel is blank on startup

Postby Brother Gabriel-Marie » Fri Nov 03, 2017 10:21 pm

Pierre, I haven't updated to the latest version yet (I'm doing it now), but I haven't had this problem in some time, probably due to some of those tweaks. I run multiple instances as a matter of course (so I can have the viewer open to different folders). I'm just reporting this in case it helps. I guess I haven't hit the right combination of actions to bork it again.

Obelix469
Posts: 3
Joined: Wed Oct 04, 2017 3:14 pm

Re: Favorites panel is blank on startup

Postby Obelix469 » Sun Nov 05, 2017 5:13 am

It appears to have been fixed with latest patch! Can open and close it shows up each time.
XnView MP Windows Version 0.88 64bits (Nov 2 2017)
Edit: Doesn't work any longer, not sure why.


Return to “New”

Who is online

Users browsing this forum: No registered users and 2 guests