0.87b3 : Problem of updating thumbnails in "Category Filter" mode when renaming a folder

*** Please report new bugs here! ***

Moderator: Dreamer

dreg
Posts: 34
Joined: Mon Aug 21, 2017 9:34 am
Location: France

0.87b3 : Problem of updating thumbnails in "Category Filter" mode when renaming a folder

Postby dreg » Wed Aug 30, 2017 6:35 am

XnViewMP 0.87beta3
Windows10pro64

Hello,

I noticed a repeatable problem when renaming a folder (by WXnViewMP)
Apparently the information is not well transmitted at the level of the categories database and links with the thumbnails:

1- either a "TEST" folder containing photos related to category "1"
2- in Category filter mode if you click on the title "1", all the thumbnails of the photos belonging to category "1" are listed in the thumbnail display window
3- if you rename the "TEST" folder to "TEST bug" by XnViewMP, go back to the "Category filter" mode, and click on category "1": the thumbnails do not appear more (they are replaced by a computer icon with a window in the background) and their labels only include the name of the photos: all other information has disappeared (shooting parameters, keywords if selected in parameters, etc ...)
Double-clicking on these thumbnails no longer opens the photos too.
4- If the folder "TEST bug" is renamed to "TEST": everything is returned in order in the "category filter" mode and the display of the thumbnails and their labels are normal again

It looks like there is no update of the categories database contained in the XnView.db file
No ?

Thanks in advance if you manage to solve this bug

Best regards

Return to “New”

Who is online

Users browsing this forum: No registered users and 2 guests