Create/File listing: wrong output if field contains carriage return

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
PeterNC750
Posts: 4
Joined: Wed Dec 13, 2017 6:10 pm
Location: Karlsruhe, Germany

Create/File listing: wrong output if field contains carriage return

Post by PeterNC750 » Wed Dec 13, 2017 7:44 pm

XnView: MP 0.88 - 64 bit
OS: Windows 10 - 64bit

Browser mode: "Create/File listing ..."
Output the fields {Comment} or {IPTC:Caption}
If one of the fields contains carriage return/line feed, then the result will be more than one line per picture.

Effect:
Output format: Text or CSV => the import in Excel creates a wrong table structure
Output format: XML => the import in Excel works fine

To reproduce:
- take a picture, "Edit/Edit comment ...", create an Embedded comment (for example: XnViewMP<press Enter key>is<press Enter key>great)
or
- take a picture, "Tools/Metadata/Edit IPTC/XMP ...", input in the Caption field (for example: XnViewMP<press Enter key>is<press Enter key>great)
- "Create/File listing ..." with the fields {Comment} or {IPTC:Caption} and view the result

Proposed Solution:
Replace carriage return/line feed with a blank

User avatar
xnview
Author of XnView
Posts: 30214
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Create/File listing: wrong output if field contains carriage return

Post by xnview » Mon Dec 18, 2017 7:38 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

User avatar
xnview
Author of XnView
Posts: 30214
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Create/File listing: wrong output if field contains carriage return

Post by xnview » Sat Dec 30, 2017 2:44 pm

This problem is supposed to be fixed in XnView MP 0.89. Please check and confirm the bug fix here.
Pierre.

User avatar
PeterNC750
Posts: 4
Joined: Wed Dec 13, 2017 6:10 pm
Location: Karlsruhe, Germany

Re: Create/File listing: wrong output if field contains carriage return

Post by PeterNC750 » Sat Dec 30, 2017 5:51 pm

well done ... the bug is fixed ... works perfect ...
Thanks a lot ... and a Happy New Year.
Peter

Post Reply