Slow on Startup

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Slow on Startup

Post by ruebyi » Thu Dec 27, 2018 7:31 pm

Hi,

I have to report a new Bug,

Mac OS Mojave 10.14.1
Macbook Pro Retina Mitte 2014
XNViewMP 0.92

Usually the program works great, but if I go to Standby on my mac while XNView is open XNView is not working properly after coming back from Standby.
It's trying to load the last folder, but only shows the rolling ball.

That behaviour lasts for about 15-25min and then it works again.
It does not help to cancle XNView or do a reboot - it needs the time.

best tobias

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow on Startup

Post by xnview » Thu Dec 27, 2018 7:36 pm

you start XnViewMP, make standby your mac, when you reactivate it, XnView doesn't respond anymore?
Pierre.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Fri Dec 28, 2018 7:45 am

Yes, for about 15min.
But only if the standby was a long one - like overnight.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Tue Mar 26, 2019 10:03 pm

It worked for a few months, but since 0.93 the problem is back...

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow on Startup

Post by xnview » Wed Mar 27, 2019 2:56 pm

ruebyi wrote:
Tue Mar 26, 2019 10:03 pm
It worked for a few months, but since 0.93 the problem is back...
very strange problem. If you restart XnView MP no problem?
Pierre.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Sat Mar 30, 2019 11:06 am

Restarted does not solve the problem

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow on Startup

Post by xnview » Mon Apr 01, 2019 11:09 am

ruebyi wrote:
Sat Mar 30, 2019 11:06 am
Restarted does not solve the problem
so you have this problem at each start of XnViewMP? not after a Standby?
Pierre.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Thu Apr 04, 2019 6:44 pm

Seem to be each startup - I just checked it.
I powered on my mac an started XNView.
6 minutes later I was able to use XNView MP

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow on Startup

Post by xnview » Mon Apr 15, 2019 1:20 pm

ruebyi wrote:
Thu Apr 04, 2019 6:44 pm
6 minutes later I was able to use XNView MP
6 min??
So with 0.92 no problem like that?
Pierre.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Tue Apr 16, 2019 9:04 am

Yeah, no problem in 0.92

Could my nas have an influence on this?

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow on Startup

Post by xnview » Tue Apr 16, 2019 9:11 am

ruebyi wrote:
Tue Apr 16, 2019 9:04 am
Yeah, no problem in 0.92

Could my nas have an influence on this?
XnView MP start on your NAS? Many files in the opened folder?
Pierre.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Tue Apr 16, 2019 9:18 am

No, but some of the catalogued folders are on my NAS

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow on Startup

Post by xnview » Fri Apr 19, 2019 9:42 am

could you try something.
Create an empty folder, start XnView MP, go to this folder, quit, restart MacOSX, start XnView MP, same delay?
Pierre.

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Wed May 08, 2019 7:43 pm

I'm still testing, but it seems to work!

ruebyi
Posts: 31
Joined: Thu Nov 22, 2018 9:28 pm

Re: Slow on Startup

Post by ruebyi » Sat May 11, 2019 8:20 pm

I have to report, that it happened again today - with the empty folder as start folder.

Post Reply