0.93.1 MP Forgets last zoom setting

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
unqltango
Posts: 53
Joined: Sun Sep 01, 2019 8:16 am

0.93.1 MP Forgets last zoom setting

Post by unqltango » Sun Sep 01, 2019 7:47 pm

OS: W10

This might actually be a feature. If it is, I'm not happy with it. :)

Steps to reproduce:
Set "Auto Image Size" to "Last Used" in both View and Fullscreen in the configuration menu.
Activate "Lock Zoom" in View menu (verify that the icon's background is blue)
Double click on a photo, Zoom Out
Browse a couple of photos, they should be on the same zoom level
Press Esc to return to Browser
Doubleclick on the same photo again.

Faulty behavior: The photo appears with "Fit Vertical" (if bigger than the screen). The "Lock Zoom" deactivated in View menu.

Expected behavior: The zoom is the same as the user last used, because of 2 reasons: The "Auto Image Size" is still set to "Last Used" and "Lock Zoom" should be still active.

User avatar
xnview
Author of XnView
Posts: 33615
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1 MP Forgets last zoom setting

Post by xnview » Tue Sep 03, 2019 6:19 am

currently 'Lock zoom' is not kept between tabs open
Pierre.

unqltango
Posts: 53
Joined: Sun Sep 01, 2019 8:16 am

Re: 0.93.1 MP Forgets last zoom setting

Post by unqltango » Tue Sep 03, 2019 7:40 am

xnview wrote:
Tue Sep 03, 2019 6:19 am
currently 'Lock zoom' is not kept between tabs open
Thank you for the answer.

By your wording ("currently"), can I assume that "Lock Zoom" will be kept between tabs in a later release?

It is frustrating, that I have to Lock Zoom each time I want to check a batch of photos (especially because of another bug, Custom Hotkeys are getting forgotten).

Thanks,
Tango

Post Reply